Hello Guest it is July 20, 2019, 06:07:14 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - giannis121

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 »
31
VB and the development of wizards / Macros in Addons???
« on: May 23, 2011, 07:21:42 AM »
Do Addons have macros???
If yes, where can i place my own macro? (Which folder)

(I have created a button inside an Addon, that i want to run a macro.)

Thank you,
Giannis

32
I have made a wizard screen with "screen4" (a lot of work) under c:\mach3 installation folder.
In order to move it to another folder, i select "defaults" -> "mach location" and i show the new location.

The problem now is when i open the .set file to edit it,
there are hundreds of messages appearing with an exclamation mark and an OK button,
and there is no written message on them.

After pressing to all OK, the set file opens as well, but
when i press over an image button to edit it, says "Text function file is missing".
I have searched other posts, but i cant find any solution.

My will is to just move the set file under other folder than c:\mach3
Any ideas would help...

Thanks,
Giannis


33
Thank you! Thats it!

34
Very helpful!!
Thanks!

And by the same way how can i get a DRO and write it to a txt file?

Regards,
Giannis

35
How can i read a value from a txt file (on a VB script button)
and then put the value to a DRO?

The txt file contains only the number value.
I have tried to use "file input/output" from the VB-Script-Commands.pdf in Mach Wiki,
with no success.

Any ideas would help.
Kind regards,
Giannis

36
PoKeys / Re: Pokeys analog input & Feed Rate DRO
« on: March 27, 2011, 05:12:52 AM »
Ok, the problem was found!
I went to Config-->General Config--> FeedOverRide Persist should be checked!

Thank you very much for your time and for the brain also (witch i will use - i like the "near 100%" method)

Kindest regard,
Giannis

37
PoKeys / Re: Pokeys analog input & Feed Rate DRO
« on: March 26, 2011, 12:35:33 PM »
I just checked. (Thank you sharing the brain!)

The use of the LED, locks the value to 100%. (The pot cannot be used.)
Also the Reset FRO sets the Feed Override to 100%.

So, also with LED its the same reaction.

Maybe Reset button resets also the FeedRate Override.

Still looking for the answer...


38
PoKeys / Re: Pokeys analog input & Feed Rate DRO
« on: March 26, 2011, 11:44:20 AM »
Yes of course i made these changes and also bypassed your LED.
Giannis

39
PoKeys / Re: Pokeys analog input & Feed Rate DRO
« on: March 26, 2011, 10:28:38 AM »
Its does the same thing!
(When i hit reset button to enable, goes to 100%)

Maybe it has to do with any configuration in Mach?


40
PoKeys / Pokeys analog input & Feed Rate DRO
« on: March 26, 2011, 09:15:44 AM »
I use an external potensiometer with pokeys, to control the Feed Rate DRO (0-200%).

I have made a brain that reads the 10bit value and multiplies by 0.1954 (to give 0-1024 = 0-200%).
The pot works very good. (No delay - as i have read to other topics.)

My problem is when i run Mach for first time and i hit reset button,
allthough the pot can be at any position, the DRO goes to 100%.

The value is not beeing refreshed, unless i move the pot.
So the Feed Rate DRO has a wrong value.

How can i move it to the true value?
Seems like the brain does not work when the value is the same...(???) (i dont know)

How can this be solved?
Have you faced it before?

Any ideas would help...

KInd regards,
Giannis

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 »