Hello Guest it is July 17, 2019, 07:22:09 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - giannis121

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 »
21
Modbus / modbus settings...???
« on: April 23, 2012, 01:33:34 PM »

I have made a slave device with an AVR uC.
By using ComTestPro http://www.baseblock.com/PRODUCTS/demosoftware.htm
i can enable and disable an output.

Now the question is how will i configure the mach3 to work with it.

What i have done until now is:
   Config-> Port&Pins-> Checked "Modbus Input" & Plugin (1)

   Function CFGs-> SetupSerial Modbus-> see attachment (2)

   I have made a brain that reads a user LED and sends the status to modbus (3)

In any way or settings i cant change the status of the output.
(While i am receiving modbus commands for staying OFF.

Do i miss anything?
I need help....

22
General Mach Discussion / Re: Toolpath background white color.
« on: February 24, 2012, 07:43:51 AM »
I can't wait!!!   :)  :)  :)

23
General Mach Discussion / Toolpath background white color.
« on: February 24, 2012, 07:32:23 AM »
I would like to change the toolpath background color to white.
But the loaded file dissapears in any other combination of material color.

How can i do that?

24
VB and the development of wizards / Actual position when i hit pause.
« on: November 04, 2011, 03:22:34 PM »
How can i record the exact position on X & Y axis when i hit pause?

When the machine is running and i hit pause, it takes some time until the machine deccelerates and stops.
So, i want to record the exact position and current line and move automaticaly back to this position.

Does GetVar(2000) or GetParam(XDRO) have to do anything with that?

Any ideas please...
Giannis

25
A lot of code behind image buttons!

Do you think there is problem?

26
I have made a very big .set file (1.5MB).
I can see that it needs more time to start Mach3 (~6sec instead of 1-2sec), but after that the functionality is good and quickly (as it was allways).

Have you worked in such big files?
Do you think there is going to be any problem on this?
Will Mach crash or give any watchdog timeout (or anything else)?
Should i fear of something or not?

Regards,
Giannis

27
That's it doc!
Thank you!

28
Very nice! Thanks!

One more question.
I have a UserDRO 1061.
Each time i restart the wizard, this value goes to 0.
All other DROs are untouched.
Why is that?

Regards
Giannis

29
How can i put an "Author name" and a "Description " to a new created wizard?
I can't find any post related...

Regards,
Giannis

30
VB and the development of wizards / Re: Macros in Addons???
« on: May 24, 2011, 02:47:05 AM »
My real problem is not that.
The code contains a MSGBOX and the message is written in my language.
So, although the first time the message appears, if i open the button to edit it, the letters become questionmarks.

Exactly the same happens in the main screen of Mach.
So, if i put my code in a macro (it is tested in the main screen) the message appears as well.

Finally my question is where is the "macro" folder for the addons....

Thank you...
Giannis

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 »