Hello Guest it is January 28, 2022, 01:00:06 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - donrecardo

Pages: « 1 2
11
General Mach Discussion / Re: Strange Jogging results
« on: January 25, 2013, 09:05:25 AM »
Thanks for the help Hood

I used Screen4 and set 2 decimal places which give me nice round numbers
1.01  1.02  1.03  etc

Regards
Don

12
General Mach Discussion / Re: Strange Jogging results
« on: January 25, 2013, 08:17:45 AM »
Thank you Hood

That now makes perfect sense .

I think I will also follow your advice and
try to reduce the DROs to show 2 decimal places

Don

 

13
General Mach Discussion / Re: Strange Jogging results
« on: January 25, 2013, 06:32:05 AM »
Hi Rich
  and thanks for your reply . I was not questioning the accuracy of the small moves.
it was the fact that it screws up the jog control readout

If I set the jog increment to .1000  for example it steps .0994 .2006 etc
setting the increment to .0100 gives .0094 .0188 etc

yet if I leave the motor tuning as is when you first instal the software ( Steps 2000 velocity 120 acceleration4 )
the jog behaves perfectly and reads out in perfect .1 or .01, .001 steps

Don

14
General Mach Discussion / Strange Jogging results
« on: January 25, 2013, 05:52:17 AM »
When I first installed Mach3 I could set the jog increment to
1.0000 ,0.1000 ,0.0100 or 0.0010 and set it for single step then
pressing the jog button it would jog as I would expect it to

setting it to 0.0001 didnt work so obvious. For about every 8 presses
on the jog button it would increase by 0.0005 but I doubt I would want to
jog in steps that small anyway

So far so good .

My lead screws are 3mm pitch and my motor drivers are set to 16 microsteps
and the motor is 200 steps /rev so I calculate that as needing 1066.666667 steps per mm

When I went to motor tuning I changed the original
Steps 2000 , velocity 120  acceleration 4     to my calculated
Steps 1066.7 velocity 120 acceleration 4

The motor moved as expected . Doing G0 X3
made the motor rotate one full turn which with a 3mm pitch screw  gives me 3mm.

Now I went to jog ,

setting step size to 1.0000 and pressing jog it read  0.993 , then 1.9996 , 2.9999 ,4.0002
setting step size to  0.1000 and pressing jog it read 0.0994 ,0.1997, 0.3000
as the step size reduces the problem gets worse

How can I set it to suit my motors required step rate but still work correctly in jog mode ?

Also in Config/General config is a table that will select step size each time you press Alt J
it has 10 lines , but as I dont want to jog in 0.0001 steps I really only need 8 lines.
Is there a way to achieve this without just duplicating a line to fill up the space

Regards
Don

15
Thank you for your help but unfortunately
I still get the same result.

I ran Mach3 as Admin and enabled the joypad plugin
I saved the config
I even ran joypad setup exe as admin but still it said
there was no button map found , and when I tried to save it said
it cant write to the file

Could it be because I am on a windows 7 64bit OS ?

Don

16
Hi , I just downloaded the plugin

I ran joypad.m3p and it said plugin installed ,  I can see it in config plugins  so I enabled it.

When I run Joypad setup.exe it tells me " no button map file found , using defaults , which I OKd

When I try to save it tells me .... error saving button assignments to file, check if Joypad.Button.Settup is open or write protected.

What am I doing wrong ?

Don



Pages: « 1 2