Hello Guest it is March 03, 2024, 09:38:10 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Durero

Pages: « 1 2 3 4 5 6 »
11
I think it could be a bug in the Lua editor.

The last thing I remember doing before the error appeared involved using a lot of Find & Replace where match WholeWord was set to ON. 

Now I've set match WholeWord to Off and the error seems to have gone.

12
"Invalid value 2 for a boolean key "WholeWord" in config file"

I'm struggling to program m6 for my ATC.

I thought I had it licked, just needed to change all of my mc.mcCntlGcodeExecuteWait to mc.mcCntlGcodeExecute, but I've made too many changes and broken something.

Any clue for the meaning of this error message is greatly appreciated.

Leo

13
Yes that checkbox has taken care of it.  Thanks Chaoticone.

14
Mach4 General Discussion / Re: Mach4 UI unresponsive during m6 macro
« on: September 27, 2017, 11:52:15 PM »
Thanks very much for that link Craig.

How frustrating to follow several linked threads to find out that the Lua Scripting Manual has been deprecated since the beginning of 2016!

Why is it still featured on the main Mach4 documentation site?  http://www.machsupport.com/help-learning/product-manuals/

Well back to my machine!

15
Mach4 General Discussion / Re: Mach4 UI unresponsive during m6 macro
« on: September 27, 2017, 08:16:53 PM »
Blind guess:

Does mc.mcCntlGcodeExecuteWait prevent the UI from updating while its Gcode statements run?

16
Mach4 General Discussion / Mach4 UI unresponsive during m6 macro
« on: September 27, 2017, 08:14:08 PM »
I'm getting a working ATC m6 script by following the Lua Scripting Manual.

So far so good, except that the UI is completely inactive during the toolchange, then updates correctly when m6 is finished.

I'd certainly prefer to see the DRO's update and be able to press Stop while I'm still working out the script.

Any ideas why the dead UI?

Thanks again to the patient helpers on this forum.
Leo

17
Hi Craig, yes I've checked all of the other m6 scripts in other profiles and the Lua examples folders but I still don't see any wx.wxMessageBox calls in any of them.

The MTC message box stays away when the "do not display again " checkbox is ticked, so I guess I can live with the workaround. Just wish I understood where it was coming from in the first place.

18
Hi Craig, my script is named m6.mcs

I'm trying to understand where else Mach4 might be looking for code relating to m6. My macro folder is empty except for my m6 script and mcLua.mcc

19
I'm doing my best to follow the M6 scripting example in the Lua Scripting Manual.

I'm adapting the example script for my machine and ATC, but when I run it this MTC message box appears (see attached image.)

I'm not asking for any message box anywhere in my M6 script.  Can anyone enlighten me as to why this keeps appearing and where it lives in Mach4?

Thanks in advance for any clues!

Leo

20
PoKeys / Does Pokeys 57E support more than 4 axis in Mach4?
« on: September 19, 2017, 11:01:28 PM »
The website for the 57E says 4-axis for Mach3 and Mach4, but there is another thread here which mentions support for more axis in Mach3.

Does anyone know if the 57E can support 5 axis or more machines in Mach4?

Thanks.
Leo

Pages: « 1 2 3 4 5 6 »