Hello Guest it is December 07, 2022, 08:51:45 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - gallenat0r

Pages: « 1 2 3 4 5 »
21
CS-Lab / Re: Shorting output pin for disabling gecko G251X
« on: August 09, 2013, 10:58:32 AM »
I found some small relays at element14 with DIN sockets and they are now installed.
It works like a charm :)

Now is there a way for the CSMIO to have outputs default to high so the drives are disabled when mach3 is not running?

--
gallenat0r

22
CS-Lab / Shorting output pin for disabling gecko G251X
« on: August 06, 2013, 08:00:22 AM »
I'm currently wiring up my mill to a CSMIO/IP-S using geckodrive G251X's.
As opposed to the geckodrive G203V where the disable pin needs 5V to disable - the G251X disable pin needs to be connect to ground of the power supply.
I could do it with a relay, but I'd rather keep the setup simple.
Would changing polarity for a set of output pins do the trick?

--
gallenat0r

23
I switched IJ mode from incremental to absolute in general config and that took care of the rest of them :)

gallenat0r

24
How did you overcome the crop circle junk gcode?
For me unchecking reversed arcs in lathe options just makes the circles appear somwhere else.

--
gallenat0r

25
I had some more time to fiddle with it but am having trouble with x-pullout when cutting threads.
I've seen elsewhere that it's common problem with csmio vs mach3.
Do you know how to solve this?

--
gallenat0r

26
General Mach Discussion / Re: Spindle index on Optimum D280x700 Vario Lathe
« on: February 22, 2013, 01:17:54 PM »
Thanks again!

Attached is first impressions.  :D

So for the e-stop I want to feed 24v into input pin 1 and 0v to input pin 5? (it is!)

--
gallenat0r

27
General Mach Discussion / Re: Spindle index on Optimum D280x700 Vario Lathe
« on: February 22, 2013, 12:17:43 AM »
So I connected pin 2 and 15 on the controller to the enable+ on the drives and pin 15 to enable- on the drives.
In mach I setup port 10 pin 0 to enable 1 and port 10 pin 1 to enable 2.
I can see the leds go on and off, but cannot measure anything on the pins nor does it affect the drives.
I also connected pins 1 and 5 on input0-15 to a mushroom switch and set estop in mach to port 10 pin 0.
Nothing is registred here either.
The good news is that the encoder seems to be working although mach fails g76 with "external estop requested"
Oh the joy...

28
General Mach Discussion / Re: Spindle index on Optimum D280x700 Vario Lathe
« on: February 21, 2013, 01:55:07 PM »
yes that was what I meant :)
so always port 10 and then whether it's input or output the plugin finds out for itself?
meaning input pin 5 is port10+pin5 and output pin 5 is port10+pin5 in mach?

29
General Mach Discussion / Re: Spindle index on Optimum D280x700 Vario Lathe
« on: February 21, 2013, 01:45:21 PM »
Thanks, how are input and outputs mapped?

Pages: « 1 2 3 4 5 »