Hello Guest it is August 02, 2021, 11:08:04 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - TPS

751
General Mach Discussion / Re: Program pause command?
« on: January 19, 2020, 04:02:16 AM »
why are you not using M6T?? and set toolchange to "Stop spindle wait for Cycle Start" ?

752
Green- 2 pin ( mpg A+)
White- 3 pin ( mpg B+ )
Config -> Ports&Pins -> Encoder/MPS -> MPG1 Enabled | A-Port = 2 | A-Pin = 2 | B-Port = 2 | B-Pin = 3

Green&black- 1 pin ( jog on led +5v )
White&black- gnd ( jog on led gnd)

this is only the led, we will take care later


Yellow- 4 pin ( select x axis )
Config -> Ports&Pins -> Input Signal -> OEMTrigger#1 Enabled | Port = 2 | Pin = 4
System Hotkeys -> Trigger#1 OEM Code = 259


Yellow&black- 5 pin ( select y axis )
Config -> Ports&Pins -> Input Signal -> OEMTrigger#2 Enabled | Port = 2 | Pin = 5
System Hotkeys -> Trigger#1 OEM Code = 260


Brown- 6 pin ( select z axis )
Config -> Ports&Pins -> Input Signal -> OEMTrigger#1 Enabled | Port = 2 | Pin = 6
System Hotkeys -> Trigger#1 OEM Code = 261


Brown&black- 7pin ( select a axis )
Config -> Ports&Pins -> Input Signal -> OEMTrigger#1 Enabled | Port = 2 | Pin = 7
System Hotkeys -> Trigger#1 OEM Code = 262



Gray- 8pin ( x1 )
Config -> Ports&Pins -> Input Signal -> OEMTrigger#1 Enabled | Port = 2 | Pin = 8
System Hotkeys -> Trigger#1 OEM Code = 265


Gray&black- 9pin ( x10 )
Config -> Ports&Pins -> Input Signal -> OEMTrigger#1 Enabled | Port = 2 | Pin = 9
System Hotkeys -> Trigger#1 OEM Code = 266


Orange- 10pin ( x100 )
Config -> Ports&Pins -> Input Signal -> OEMTrigger#1 Enabled | Port = 2 | Pin = 10
System Hotkeys -> Trigger#1 OEM Code = 267


Orange&black- +5v ( com for selector )
this is wrong, Needs to be connected to GND


753
so lets do some tests

if you Trigger the z-axis home Switch can you see it changing in diagnostic Screen?
in Manual mode if you press page up button z-axis goes upwards and z-axis dro is going to plus?
if you are in diagnostic Screen, what is Happening if you press the Ref Z button?

754
@ tps.. so are you saying I should rewire my whole pendant to match the example you posted ?? The wire color does not matter as long as I know what colors go where and they all match up according to the example in reply #10
for the Moment i am not able to follow you, how the pedant is wired on the PP port side??!

755
according to the example from my link wiring would be:

yellow -> Pin 3
yellow/black -> Pin 4
Brown -> Pin 5
Brown/black -> Pin 6

gray -> Pin 7
gray/black -> Pin 8
orange -> Pin 9

orange/black -> Pin 25

green -> Pin 13
White -> Pin 15
red -> Pin 10
black - Pin 24

the you can use all Settings from example


756
VB and the development of wizards / Re: Simple Code No run
« on: January 17, 2020, 03:36:39 PM »
hello,

tested your code on Version R3.043.022 and on Version R3.043.062 no Problem, just as expected.

757
is there no documentation about the used wire color's?

758
The pendent I am using is a little different than the one in this setup
1) I dont have a enable button on the side of my pendent.
2) The pendent I am using does not have an e-stop  button on it

does not matter just skip them, the pricipal is the same.

759
General Mach Discussion / Re: 3 axis lathe Mach3 tool charger Quicktech
« on: January 16, 2020, 08:27:36 AM »
if you use

Code: [Select]
  Code "G0 G53 Y"&toolpos1 'move Y-axis

insted of your code and you can enter numbers directly to dro 66.123 will be 66.123 in real

if you want an Offset to 66 use

Code: [Select]
  temp = 66 + toolpos1
  Code "G0 G53 Y"&temp 'move Y-axis

760
if it is hardwired to lpt2 you will not Need any plugin at all.

here:
http://www.markusmechatronics.com/Handrad_HowTo.html

is an example for a hardwired pedant.