Hello Guest it is September 20, 2021, 08:05:06 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - TPS

731
General Mach Discussion / Re: Synchronized I/Os over Modbus (?)
« on: February 14, 2020, 01:53:55 AM »
just a thought, maybe i am thinking to easy.
why not turning the nozzles on/off by customized M call's

for example:

G1 X10 F100
M200 'turn nozzle 1 ON
G1 X20
M201 'turn nozzle 1 OFF



732
General Mach Discussion / Re: Arc Ok signal always on
« on: February 13, 2020, 01:25:07 PM »
maybe a wiring Problem?

733
General Mach Discussion / Re: Need a new screen for Mach3
« on: February 10, 2020, 02:46:35 PM »
nothing to do with the .png file.
just go to Config (main menue) -> General Config and make the setings like sugested

734
General Mach Discussion / Re: Need a new screen for Mach3
« on: February 09, 2020, 01:26:21 PM »
if you use attached Settings, it does not look so bad here (1920x1000 21" wide Screen)

735
Mach3 under Vista / Re: Mach3 Jog buttons not working when ran as script
« on: February 09, 2020, 01:14:58 PM »
IMHO you will not be able to do a XY jog via a Screen button (i do not know a way, but maybe there is a way).
i have attached a smallĀ“brain for a XY plus jog via Trigger of input1.

-copy it to your C:\mach3\brain Folder
-use Operator -> Brain control and enable the brain
-goto Config -> ports&pins -> Input Signals -> enable Input1 ->enable emulated -> assign a hotkey

and you will see, you can jog X/Y via the assigned hotkey

736
Mach3 under Vista / Re: Mach3 Jog buttons not working when ran as script
« on: February 09, 2020, 07:47:57 AM »
normaly DoOEMButton(307) DoOEMButton(309) should be excecuted and start the axis to jog.
make sure JogMode is on.

the Problem will be that a DoOEMButton(307) will start JogX-movement and a DoOEMButton(334) has to stop JogX.

a normal Screen button will only run the when the button is pressed and you have no controll when the button is released.

you can test your macro code in Operator -> VB Script Editor window and use the >|| button to test code line by line.

737
General Mach Discussion / Re: Feed rate accelerating/decelerating question.
« on: February 09, 2020, 05:58:18 AM »
maybe a simple macro can create the GCode. dont know how "perfect" the liearity has to be

Code: [Select]
'set the varaibles
StartX = 100.0
EndX = 10.0
StartSpeed = 5
EndSpeed = 10
StepOver = 0.1

'do some calc's

Steps =  ABS(Startx-EndX)/StepOver
StepPer = (EndX-StartX)/Steps
SpeedChangePer = (EndSpeed - StartSpeed) /Steps


DoOEMButton (169)                    'close all open files
OpenTeachFile "Test.tap"

Code "G64" 'use CV mode
Code "G0 X"&StartX

AktX = StartX
AktF = StartSpeed

For i = 1 to Steps
AktX = AktX + StepPer
Code "G1 X" &AktX &" F" &AktF
AktF = AktF + SpeedChangePer
next i

Code "M30"

CloseTeachFile
Call LoadTeachFile()


738
CS-Lab / Re: CSLab CSMIO input problem
« on: February 05, 2020, 02:11:49 AM »
try to run 062 for example from here:

https://warp9td.com/files/Software/Mach3/Mach3Version3.043_2018.exe

i run 043.022 because it was recomended by CSLAB.

739
CS-Lab / Re: CSLab CSMIO input problem
« on: February 05, 2020, 01:49:42 AM »
BTW. witch Version of Mach3 are you running?

740
General Mach Discussion / Re: System wait macro function help
« on: February 04, 2020, 01:34:51 AM »
do you mean macro will not wait until Input is on, or does the macro not goin Forward after Input is on?