Hello Guest it is June 16, 2021, 01:40:54 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - TPS

1581
General Mach Discussion / Re: Only X-axis motor is working
« on: March 19, 2018, 05:29:09 AM »
Looks like your board Needs pin14 as enable, have you configured this ?



1582
General Mach Discussion / Re: external START bottom
« on: March 19, 2018, 05:21:52 AM »
Config -> Ports&Pins -> Inputs
config OEMTrig #1 to what ever port and pin you use

Config -> System Hotkeys
Trigger #1 OEM Code -> 1000 (for cycle start)


1583
sorry Little mistake, right code:

If IsOutputActive(OUTPUT1) Then
  DeactivateSignal(OUTPUT1)
Else
  ActivateSignal(OUTPUT1)
End If

it will only work for Outputs witch are enabled in Config -> Ports&Pins -> Outputs

1584
General Mach Discussion / Re: Probing
« on: March 18, 2018, 04:22:41 AM »
your link to the board
is not working

1585
General Mach Discussion / Re: Mach3 Settings Keep Changing
« on: March 17, 2018, 01:46:05 PM »
so if you set up mm and GCode is inches, what would you expect ?

1586
General Mach Discussion / Re: STEPCRAFT 840 to Mach3... Help
« on: March 17, 2018, 01:43:40 PM »
and a red car.

sorry ;D

1587
General Mach Discussion / Re: Mach3 Settings Keep Changing
« on: March 17, 2018, 01:42:08 PM »
and your GCode what does it look like.

G20/G21 ???

1588
declare Standard code of your button as 34 (execute Basic stript)

then einter this vb code to script


If IsActive(OUTPUT1) Then
  DeactivateSignal(OUTPUT1)
Else
  ActivateSignal(OUTPUT1)
End If

1589
General Mach Discussion / Re: How to add a 3d printer to cnc machine?
« on: March 16, 2018, 11:20:09 AM »
i think you have to add a second PP, because you are out of Outputs on PP1.
and you have used Input1 + 2 where the 5th axis is linked through internaly
for what ever reason.

1590
General Mach Discussion / Feed hold
« on: March 16, 2018, 08:57:39 AM »
had a strange Thing today

run a simple Programm for seed Validation

g0x200y200
g0x0y0


then i pressed feed hold during the g0x200y200
when i tryed to start again got he following errormessage:

Fri - 13:53:40 ---Command too long , Block = G0 X21044981090020823000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000.0000 Y-518.5300 Z-205.0500 A-4962710013563463000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000.0000 B0.0000 C0.0000Line 0

Thomas

M3 v .022