Hello Guest it is November 22, 2019, 10:30:58 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - TPS

1321
Mach Screens / Re: tooltiptext
« on: February 09, 2015, 03:04:07 AM »
hi andmar2005,

a tooltiptext is only showing up, if you are with the mouse
over the element.

Thomas

1322
VB and the development of wizards / Re: macro for homing
« on: February 09, 2015, 03:02:16 AM »
Hi,
ok than let's try an other road:

   Message ("ref. Z-axis")
   DoOemButton(1024) 'Ref Z
   Sleep(500)
   While GetOemLed(809) = true 'wait normal reference to be finished
       Sleep(200)
   Wend
                Message ("ref. Z-axis to index mark")
                'here you can do your reference onto the index signal

Regards Thomas

1323
VB and the development of wizards / Re: macro for homing
« on: February 07, 2015, 03:15:35 AM »
hello,

have a look for oembutton(150).

Thomas

1324
Hello,

i think the line

code "M1002"

is the problem a macrocall in a macro gave allways problems to me.

oder vielleicht können wir auch auf deutsch weiter machen, da einige Kommentare auf Deutsch sind.

Gruß/Regards Tom

1325
CS-Lab / Re: CSMIO/IP-M observations
« on: January 29, 2015, 06:26:37 AM »
Juha,

Quote
Where can I get CSMIO/IP Motion Montroller Configuration tool?

there is no tool, you have to go to main menu bar cofiguration -> configure plugin.
hope it is named so in the english version, because i have a German version.

Quote
But I'm still curious to know why STEP/DIR output minus signals (e.g. pins 14 and 15) do not fuction as expected.

CSMIO/IP controller has differential outputs and your driver has optocoupler inputs.
my english is too bad to explain the difference (hope one of the english guys will explain).

here:
http://en.wikipedia.org/wiki/Differential_signaling

is something to explain differential sgnaling

Thomas

1326
CS-Lab / Re: CSMIO/IP-M observations
« on: January 28, 2015, 09:37:07 AM »
Hi,
Quote
How is it, are these IOs protected e.g. against short circuit or not?
yes only step/dir not.

Quote
Are the signals fixed or can these be configured in Mach like it is the case with LPT-port?
in Mach3 port/pin -> motor outputs only the enable axis is important rest is done in the
configuration of the cs-lab plugin.

for the wiring, you first have to figure out, witch inputs your motor controllers have,
the choose the right wiring diagram.

Quote
just cannot get the meaning of "and in the CSMIO/IP-M we have to use the GND on 2nd PIN or ANALOG I/O 8 connector"
Where the GND can be found from, is it analog IO terminal pin #2 or pin#8 or what?

CSMIO/IP_S GND at step/dir connector pin 13
CSMIO/IP_M GND at analog connector pin 2 or pin 8

Regards Thomas

also not a native English speaking person

1327
CS-Lab / Re: Connection Failed. CSMIO/IP not found.
« on: January 26, 2015, 07:13:22 AM »
Hi,

have you been able to do the firmwareupdate with this PC ?

sorry i have only experience with mach 3 and cslab, not on mach4.

Thomas

1328
CS-Lab / Re: Connection Failed. CSMIO/IP not found.
« on: January 26, 2015, 04:32:03 AM »
Hi,

are you able to ping the CSMIO ?

Thomas

1329
General Mach Discussion / Re: Homing Slaved Axis Y(A)
« on: January 13, 2015, 07:08:11 AM »
rename your file to cncbobuk.xml for example.

1330
FAQs / Re: Home/Limit/E-Stop...Out of Pins need Help
« on: January 13, 2015, 05:43:12 AM »
forgot something

Y and A home switch should have seperate inputs.

Thomas