Hello Guest it is December 08, 2019, 06:07:17 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - TPS

1061
Screen designer tips and tutorials / Re: Tranparent Pushbutton - Dro Mach3
« on: December 15, 2017, 05:25:29 AM »
Hi Klaus,

that was the clue. did not know that can Change order in this selectbox.

every day a new Experience.

Thank You very much.

Thomas

1062
Screen designer tips and tutorials / Re: Tranparent Pushbutton - Dro Mach3
« on: December 15, 2017, 03:01:16 AM »
Hello Klaus,

ich denke wir könnten in Deutsch weitermachen, aber um die anderen im "Rennen" zu halten machen wir in Englisch weiter.

i am using your screeneditor.

usage is very easy.
-copy the attached macro in your macrofolder

put this code into button , for example to edit OEMDRO(824)

Code: [Select]
Sub Main
  newvalue = NumericKeyboard("OEM DRo 824", GetOEMDRO(824) )
SetOEMDRO(824 ,newvalue)

End Sub
'-----------------------------------------------------------
'TongIL has to be replayced with your Profile Name
'-----------------------------------------------------------
#Expand <\..\..\macros\TongIl\Numeric_1>


as wiritten, the code itselve is not the Problem, only to get the "Tranparent Pushbutton" to be the 1st if it is placed over the DRO.

Thank You Thomas

1063
Screen designer tips and tutorials / Tranparent Pushbutton - Dro Mach3
« on: December 14, 2017, 12:48:26 PM »
Hi guy's

for the moment i am a Little bit out of ideas (probably im am sitting on the pipe)

I have written a VBScript for numeric Inputs , via transparent button, on a Touchsreen witch is able to to enter values into a specified DRO (i know this Auto-Calculator Option) .

to use it, it is necessary, to put a "transparent Button" over the DRO Display.

for the moment i am hang up, to get the "transpartent button" as the "TOP" Event,
means the DRO is the master, and takes the focus for Input, and the button Event is not triggerd.

hope somebody understands what i am trying to explain in my bad Bavarin english.

Thank You Thomas

PS. if i get this running, it will be shared.
 

1064
G-Code, CAD, and CAM discussions / Re: A-Axis TC
« on: December 13, 2017, 11:37:52 AM »
Hi,

sometimes life is so easy.

the Config-General Config-> Ang Short Rot on G0 was the clue.

now i can do absolute positionigs Mach3 uses the shortest way , everyting perfect.

i can book this 4-5 hours of working arround under "getting some new experience"

Thomas

1065
G-Code, CAD, and CAM discussions / A-Axis TC
« on: December 13, 2017, 01:46:04 AM »
Hello together,

for the moment i am working on a retrofit of  a TongIL TNV40 Mill.
CS-Lab Controller, new servo motor's for axis , Mach3 aso.

now i have a little "fight" with the TC turn axis (A).
i configured in General config:

-A-Axis is angular
-Rot 360 rollover

positioning of A-Axis is as expected with the rollover at 360°

i have wiritten a small script witch calculates the nearest angle to the next expected tool (not an new idea).

so i get out a relative +/- angle to do the move to the TC Position.

so far so good.

G-code would look like this for example:

Situation:
TC P1 = 0
TC P2 = 30

A-Axis is at 0 (P1) and i want to move to P2(30)


'move incremental to P2
"G91 G1 A30 F800"

'do a absolute move to inviod angle Errors
"G90 G1 A30 F800"

ok this sample makes not much sense in this case, but if you have to go ccw for two ore thre positions, or at the rollpver it makes sense.
it is only to discribe the principal.


so now the real Problem:

'move incremental to P2
"G91 G1 A30 F800"
is working like expected, axis is moving +30deg, and axis dro is 30  at the end

'do a absolute move to inviod angle Errors
"G90 G1 A30 F800"
it does a complete turn in CW direction, an can not understand why.


i am not sure wether this is a Mach3 Problem, or CS-Lab Controller issue.

so i would prechiate if someone could do this simple test on a different Controller,
to figure out on witch side the Problem is.

Thank You in advance, and excuse my bad english.

Thomas
 












1066
VB and the development of wizards / Re: global script file Mach3
« on: November 26, 2017, 06:09:29 AM »
Hello Gerry,

"played" a little bit around with the #Expand.

Looks like that is exactly what i am looking for.

Thank You Thomas

1067
VB and the development of wizards / global script file Mach3
« on: November 25, 2017, 03:10:57 AM »
Hi guys,

is there a possibiltiy to declare/create a global script file,
where i can put all my functions witch are needed from
different scripts ?

Thank You Thomas

1068
VB and the development of wizards / Re: Macro does stop
« on: October 30, 2017, 02:55:21 PM »
Hi,

why should your Probepos be equal -ZMove when the probe was never hit ??

--> Probepos = GetVar(2002)
--> If Probepos = - ZMove Then

something like this should work:

While IsMoving()
        z = GetOEMDRO(802) 'Z-actpos
        If z <=  - ZMove _In Then
            DoOEMButton(1003) 'Stop
            MsgBox ("Probe **ERROR**" )
        End If
 Wend

Thomas         

1069
VB and the development of wizards / Re: Auto tool zero script problems
« on: October 28, 2017, 04:32:20 AM »
have you checked your probe Input in diagnostic Screen ?

try to hit the probe Signal long before you reach the -278,5 to see that your Motion controller is working ok.

in dont know this Motion controller, and i don't know wether your Motion controller is doing the
handling for G31 maybe probing needsto be Setup somewhere else , plugin ?

could no find a Manual on their Homepage.

goog workinh G31 is very Controller specivic.


1070
VB and the development of wizards / Re: Control micro servo with Macro
« on: October 28, 2017, 04:16:14 AM »
if you need such a precise timing  (1,5/18,5ms) the only way is a extrenal Signal Generator.