Hello Guest it is November 29, 2022, 12:36:40 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Vogavt

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 »
241
General Mach Discussion / Re: Alarm/buzzer when cutting is finished
« on: October 12, 2008, 03:36:24 PM »
Yes, I'd thought about that already.

I'd use this:

M9 (to shutoff running coolant)
M7 (to start buzzer - simulated "Mist")
G4 P3 (to pause for 3 seconds)
M8
M30


I still have a question about the voltage and where to connect the actual wiring for the 12v buzzer?

242
General Mach Discussion / Re: Alarm/buzzer when cutting is finished
« on: October 10, 2008, 10:52:41 AM »
Thanks Arturo for the quick response.

Yes, your memory serves you correctly. I still have a both of the onboard electromechanical relays available.

Just so I've got this straight, I'd plug the wires in to one of the relays and activate it from within Mach3.  If I use the M7 code and set it to pause for 10 seconds or so, thus leaving the relay active (buzzer buzzing), and then use the M9 to stop the M7 (faux mist) wouldn't that turn off the buzzer?

Excuse my ignorance but what is the voltage that goes through the electromechanical relay?


243
General Mach Discussion / Re: Alarm/buzzer when cutting is finished
« on: October 10, 2008, 09:32:24 AM »
Thanks for the responses. Definitely food for thought.  Had forgotten about the built-in wav player for Mach.  Might be an option, but I'd have to add speakers to the PC. Not sure I'd hear it over my stereo in the shop, that's why I bought a buzzer (distinct sound). And besides, I'm not sure I'm ready for my mill to start talking to me. My wife thinks I'm nuts already! LOL!

I've invited Arturo to chime in (pun intended) to give his thoughts for all of us to see.  You've already given me some great options, just want to get his input as well.

Vogavt

244
General Mach Discussion / Re: reading excel files in Mach 3
« on: October 09, 2008, 02:14:46 PM »
Post a little bit your code and I'll see if I could write a macro for Excel to do the conversion.  A portion of each type would be needed.

245
General Mach Discussion / Re: Alarm/buzzer when cutting is finished
« on: October 09, 2008, 02:08:00 PM »
Yes, I use flood coolant. Familiar with the M8/M9 on/off. I use a cnc4pc C11 board which has an analog relay where my 110v pump is turned on.

Still new to me, but do I just hook up the wires of the buzzer to the pins and set Mach to activate the pin?  I guess I'm confused about the 12v buzzer and where it would physically hook up to the board. For example, I'm not using Mist control (M7) so I suppose I could use that as an output or maybe use one of the other outputs in Mach, but how do I enable that output via g-code? I still have outputs 2-6 available.

246
General Mach Discussion / Alarm/buzzer when cutting is finished
« on: October 09, 2008, 12:41:42 PM »
How would one go about setting up a buzzer/alarm for letting the machinist know the job is complete?  I bought a 12v buzzer from Radio Shack and got to thinking about how to make it work then realized it would require some deeper thinking. I searched the forum, but didn't find what I was looking for.


Thoughts or ideas?

247
What's a reasonable step-over for creating a detailed tap file for photos?  It appears to default at 0.001". I was just wondering if that was a bit of overkill.

Thanks,
Vogavt

248
LazyCam (Beta) / Re: Need help with entity - Weird problem
« on: August 26, 2008, 02:42:17 PM »
Will give that a try, but these are already "exploded" entities and saved as a dxf.

The problem I have with clicking directly on the entity to lock the arrow in, is that when doing so it locks the arrow exactly where you click. Therefore creating another location/point for Lazycam to have to calculate g-code for.

249
So can we get the working code all in one place/post? Never having done this sort of thing, I don't know where to put what.  Really need this sorted out to help another poor soul...

Thanks in advance,

Vogavt

250
LazyCam (Beta) / Re: Need help with entity - Weird problem
« on: August 21, 2008, 09:19:35 AM »
Thanks for the quick response!

Yes, I've used the Clean and optimize buttons after loading the dxf.

However,the problem still exists even after doing that: arrow disappears, cant' lock with single click, etc.

I've saved the lcam file, closed LazyCam, restarted the program and opened the file again, but still "No Joy" with the arrow.

Has anyone else ever seen this happening?

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 »