Hello Guest it is May 11, 2021, 04:49:15 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Lawley

Pages: « 1 2 3 »
11
General Mach Discussion / Re: Following Error
« on: February 16, 2010, 03:41:33 AM »
Dear Hood

The acceleration for the y Axis is set to 500 and the X and Slaved A Axis are set to 300, the following error is apparent even when running a constant traverse of say 2 meters. I am based in Johannesburg South Africa.

Regards Brian

12
General Mach Discussion / Following Error
« on: February 15, 2010, 02:07:03 PM »
I am experiencing following errors on a gantry router running Panasonic servo drives, I have tried tuning the drives and have got them to a point just before instability sets in. The following error is around 900 counts on the drives. The motors are capable of 3000 RPM and are running a 25 to 1 planetry gearbox with a 50mm spur gear onto a rack, Mach is tuned for 312 pulses per mm with a velocity of 8000 mm/min, in order to achieve the velocity, the drives are running an electronic gearing of 1 to 5. The computer is a core 2 duo 2 Ghz set at a kernel speed of 60KHz (anything higher causes jitters in the pulse train) in order to achieve an acceptable 90deg x to y transition, linear speed needs to be kept below 2000mm/min.
Any suggestions would be appreciated 

13
General Mach Discussion / Re: Upgrade Failed
« on: November 24, 2009, 02:52:30 AM »
Many thanks for all the assistance, I have got the machine running again. To sumarise: a new computer was used, blank hard drive, new XP Pro, Ver 3.04 was loaded with driver, NO JOY!! The only thing that has remained common was the XML file there definitely appear to be glitches in Ver 3.04 E.G. changing between G20 and G21 does not change the units on the screen but the units have in fact changed. I deleted Ver 3.04 and removed all of the directory contents this allowed me to put back Ver 1.84 which runs fine.
I am busy putting together a large gantry router, guess which version Mach I will be using.

Brian 

14
General Mach Discussion / Re: Upgrade Failed
« on: November 23, 2009, 12:27:19 PM »
Backlash is not enabled Motor velocity is 2000mm/min steps are 625 /unit accel is 1000 these settings have worked for 18 months with ver 1.84 Interesting is the fact that there is a vast size difference between the XML file size from ver 1.84 to ver 3.04 is 42 kb versus 102 kb

 Brian

15
General Mach Discussion / Re: Upgrade Failed
« on: November 23, 2009, 07:57:17 AM »
Thanks Rich

The problem is not really with threading, but the servos on the axis are ramping up and down in speed during a cut. This is also evident on the feedrate DRO, I am running digital AC servos using step and direction from the parrallel port, which all worked fine on version 1.84. 

16
General Mach Discussion / Re: Upgrade Failed
« on: November 22, 2009, 11:45:36 PM »
Hi Eddie

Many thanks for the info, could it be that the computer is marginal, IE with the lower demand that the earlier Mach versions placed on it, it worked fine. I have just seen that the minimum system requirements are a 1Ghz machine with 512Mb ram.
Is the XML file the only thing required if one removes the program to reload an earlier version?

Brian.

17
General Mach Discussion / Upgrade Failed
« on: November 22, 2009, 03:00:18 PM »
Can anybody assist, I upgraded from mach ver1.84 which was working perfectly on my lathe, to ver 3.042 now the spindle will not control above 600 RPM it just ramps to full speed, axis run with an intermittent motion ramping from slow to set speed and back. The driver diagnostics appear normal, the computer is a PIII 531 MHz with 256M ram running windows XP Pro the kernel speed is unchanged at 25000Hz.

Brian.

18
Hi Guys

Many thanks for the advice, looks like I am coming right with the dxf. This is foreign to me as I am used to doing everything in 3D.

Regards
Brian

19
G-Code, CAD, and CAM discussions / Importing a part into MasterCam
« on: July 28, 2009, 03:42:03 PM »
Can anyone assist me with importing a part from Solidworks into Mastercam Lathe. Is it better to use a parasolid or iges file. I cannot obtain a chain to write a toolpath from. I have no problem using either format for Mastercam mill .

20
General Mach Discussion / Re: Step and Dir to Analogue converter
« on: May 13, 2007, 12:31:07 PM »
Thanks for that, its worth a try. The machine I am trying to convert is a large router 4' by 8' with 2 servos on the Y and 1 each on the X and Z axis. they are 1.5 kw units so I cannot afford to scrap them. I thought of possibly implementing this in a PLC, but I am not sure whether my programing skills are up to it.

Brian

Pages: « 1 2 3 »