Hello Guest it is September 22, 2019, 05:14:52 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - first off

Pages: 1 2 3 »
1
VB and the development of wizards / Re: GoTo Zero script
« on: August 19, 2019, 01:27:02 AM »
Ahhhh yes that will do it. Thanks very much for your help Tweakie. Wow you have been doing this for a long time. I remember getting help from you years ago.
Regards, Russ

2
VB and the development of wizards / GoTo Zero script
« on: August 18, 2019, 05:38:17 PM »
Where do I edit the [GoToZero] bitmap button script? It is NOT a blinking button that is easily changed in Mach3 with the VB editor. It is linked to a Hot-Key which is scan code 2128. And what program do I use to edit it? Mach3screen? ScreenTweek? Screen4? I want to stop the Z-axis movement.
Thanks to the community for all your help. You are the best!!!!!                   

3
General Mach Discussion / Re: Lattepanda win10 mach3 and ESS
« on: March 16, 2017, 08:58:42 PM »
Well I got it working finally. Later all.

4
General Mach Discussion / Lattepanda win10 mach3 and ESS
« on: March 15, 2017, 04:42:54 AM »
Hey all. I am hoping all are well in the Mach community. I have a Lattepanda which comes with win10, unlicensed. I am using an ESS also. I have put together many systems running win7 on conventional PC's. So I have proven xml and plugins. But when I tried my rock solid sytem on the Lattepanda running win10 the DRO does not change nor does the graphics move when running g_code. And there obviously no signals out to the ESS board. The DRO does change when I jog with the screen MPG however. I know others are using mach3 in win10. But I have not seen any posts about the Lattepanda board. Has anyone else had any luck with the lattepanda and win10 and Mach3?
Thanks for any help. Russ

5
Ok i will ask another question. How do I make this auto-z macro work "active low" instead of "active high"? I am sure others have this same issue. I don't want to change the input setting when I go from my digitizing probe to my auto-z plate.

'Auto tool calibration to fixture z field Sept 10/2015
'input probe pin15 port 1
CurrentFeed = GetOemDRO(818) 'Get the current feedrate.
PlateThickness = GetUserDRO(1151) 'You could put your z-plate thickness here instead
'ProbeFeed = GetUserDRO(1152) 'You could put a probing feedrate here instead.

If GetOemLed (825)=0 Then
DoOEMButton (1010)
Code "G4 P3" 'Time to get to the z-plate, 3 seconds
Code "G90 G31 Z-2 F4." 'probing move, can set the feed rate here as well as how far to move
While IsMoving()
Wend
ZProbePos = GetVar(2002)
Code "G1 Z" &ZProbePos
While IsMoving ()
Wend
'Call SetDro (2, PlateThickness)
Call SetDRO(2, Abs(GetOEMDRO(1001)))
Code "G4 P1.0" 'Pause for Dro to update.
Code "G0 G91 Z1.0" 'Change the Z retract height here to what you want, must be higher than touch plate
Code "(Z axis is now zeroed)"
Code "F" &CurrentFeed 'returns to prior feedrate
Else
Code "(Z-Plate is grounded, check connection and try again)"
End If
Exit Sub   

As always I appreciate your help and time.

6
yes l understand that G31 is a probe input. How do I change it so that it does not use a G31 or a probe and uses input1 instead?

7
Hey guys I need some help with this auto-z macro. I want to use input 1 instead of probe and I do not know what to change. Here is the macro I use now using a probe input. And I know there is alot of discussion about auto-z macro's but I have not had any luck making this work myself.

'Auto tool calibration to fixture z field Sept 10/2015
'input probe pin15 port 1
CurrentFeed = GetOemDRO(818) 'Get the current feedrate.
PlateThickness = GetUserDRO(1151) 'You could put your z-plate thickness here instead
'ProbeFeed = GetUserDRO(1152) 'You could put a probing feedrate here instead.

If GetOemLed (825)=0 Then
DoOEMButton (1010)
Code "G4 P3" 'Time to get to the z-plate, 3 seconds
Code "G90 G31 Z-2 F4." 'probing move, can set the feed rate here as well as how far to move
While IsMoving()
Wend
ZProbePos = GetVar(2002)
Code "G1 Z" &ZProbePos
While IsMoving ()
Wend
'Call SetDro (2, PlateThickness)
Call SetDRO(2, Abs(GetOEMDRO(1001)))
Code "G4 P1.0" 'Pause for Dro to update.
Code "G0 G91 Z1.0" 'Change the Z retract height here to what you want, must be higher than touch plate
Code "(Z axis is now zeroed)"
Code "F" &CurrentFeed 'returns to prior feedrate
Else
Code "(Z-Plate is grounded, check connection and try again)"
End If
Exit Sub   

As always I appreciate your help and time.

8
General Mach Discussion / Where is The V3.0 Probing Plugin?
« on: July 21, 2012, 04:13:34 PM »
I see many references to the download page and I do not see it there. Where is it? Is there an Alternate for this Plug in that someone is using?
Any direction to getting started would be appreciated.
Russ.

9
Post Processors / Re: Post for Signlab V5.
« on: September 13, 2011, 09:46:20 AM »
Sorry....they are routing signs.

10
Post Processors / Re: Post for Signlab V5.
« on: September 13, 2011, 09:45:02 AM »
I just converted a fellows Precix machine to Mach3. They have been using Signlab and they have memorized the steps to get code to the machine. They dont want to re-learn software. I need to make this transition as seamless as possible for that reason. That why i have the request for the post.
Russ.

Pages: 1 2 3 »