Hello Guest it is April 18, 2024, 03:25:47 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - sawcnc

Pages: 1
1
LazyCam (Beta) / Circle gcode only an arc
« on: August 12, 2011, 04:37:09 PM »

I made a circle in illustrator to do a test on my cnc using mach3. I imported a dxf into LazyCam bit it was an octagon. I imported a pct and it was a circle. I then saved the gcode to import into Mach3 but Mach3 only sees an arc. I am new to all this but it seemed that is should have worked. ???

2
General Mach Discussion / Gecko G540 adn Mach3 won't talk (win 7)
« on: July 30, 2011, 11:34:23 PM »
I have done the basic wiring of  the Gecko g540, i.e. power and estop. When I turn the charge pump off, I get a green light. I hit the estop and I get a red light.  So far so good.

In Mach3 I have enabled  the motors  in the the Ports & Pins config and set the charge pump to port 1, pin 16 under the Output Signals tab. The Rosewill has two ports and I have tried both of the first hex values found in "i/o range"   under the Device Manager -> Ports -> Resources. Still only getting a red light from the gecko.  I am using the LPT3 hex C00.

I have looked at three different set up guides and think I covered everything they told me too. I know the cable works because I did a circuit check on each pin.

Windows 7 Home Premium
Dell Inspiron 560s
Pocessor: Pentium(R) Dual-Core CPU E5800 @ 3.20 GHz 3.20 GHz
INstalled Memory (RAM) 3.00 GB
Sysem Type: 32-Bit Operating System
Rosewill RC-304 2 port Parallel PCI card with the moschip driver.

Geckodrive G540
48V 12.5A switching power supply

3
General Mach Discussion / Jog Hot keys don't work.
« on: July 27, 2011, 11:45:10 AM »

I just installed Mach3 on a Dell Inspiron 560s running 32-bit windows 7 and a Rosewill 2 port Parallel Universal PCI card, Model RC-304.

The installation seemed to go fine and I started doing a dry run. The jog “fly-out” screen  would not change the values on the axis DROs when I clicked on it and when I would enter in in the MDI (ie G00 X1.6 Y2.3 ) the axis DROs would not change. I reread the manual about about  the driver test program and realized I was running the Rosewill driver. I went to the device manager and disabled the mach3 driver. The axis DROs now change when I enter values in MDI and they also change when I click on the buttons on the Jog “fly-out” screen. The Jog hot keys do not work. (I set them to the correct ones (From 999) in the key configuration.)

I am (obviously) new to the CNC world and want to make sure everything is working as the manual indicates before plugging in my machine.

4
General Mach Discussion / Total newb - Inspiron 560s
« on: July 06, 2011, 11:22:50 AM »
I am building Joe's hybrid 4x4 with the R&P mod. I am using the Gecko G540 4 axis stepper motor driver with Nema 23 380 oz-in stepper motors.

I am planning on buying the Dell Inspiron 560s to run Mach3. Are there any problems with that computer? Can someone recommend a parallel port adapter for the PCI slot? Is there anything else I need?  I will be getting the 32 bit version of windows.


Thanks

Pages: 1