Hello Guest it is August 05, 2021, 09:45:54 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - danand

Pages: 1
1
General Mach Discussion / Re: micRO from Lumenlab
« on: September 27, 2010, 07:28:50 PM »
Tnx,

Will try Mach3 lite tomorrow.

//Dan

2
General Mach Discussion / Re: micRO from Lumenlab
« on: September 27, 2010, 05:40:14 PM »
I have the TB6560 driver.

I have a .HAL file, describing the pins etc. And a .ini file that "glues" the pins to the axis drivers.

The micRO M3 use two steppers for the X drive, steppers on separate drivers.

( .hal filer first, then the .ini file )

//Dan

////////////////////////////////////////////  micRO M3.hal  //////////////////////////////////

 #this file was created and edited March 14th 2010
#this is a beta release .hal file for micRo V2
#please report any problems to support@lumenlab.com or www.lumenlab.com/forums
#opening these configuration files with Stepconf will erase certain modifications!
#modify at your own risk!
#www.lumenlab.com
# BATCH 2 has inputs at pins 10, 11, 12, 13 not assigned in this revision.
# BATCH 2 assumes rotary axis A on Breakout "E", pin 1 = Step, pin 14 = dir
# rotary axis not used yet. file needs re-write for rotary axis.

#copies kinesmatics for joint 0 to joint 6 (X1 & X2 are same, assigned EMC axes"X" and "U"
loadrt gantrykins
setp gantrykins.joint-0 0
setp gantrykins.joint-1 1
setp gantrykins.joint-2 2
setp gantrykins.joint-3 3
setp gantrykins.joint-4 4
setp gantrykins.joint-5 5
setp gantrykins.joint-6 0


loadrt [EMCMOT]EMCMOT base_period_nsec=[EMCMOT]BASE_PERIOD servo_period_nsec=[EMCMOT]SERVO_PERIOD num_joints=[TRAJ]AXES
loadrt probe_parport
loadrt hal_parport cfg="0x378 out  "
setp parport.0.reset-time 4700

#an error will occur if step type isn't assigned for all axes 0-6, even if axis is not used
loadrt stepgen step_type=0,0,0,0,0,0,0


addf parport.0.read base-thread
addf stepgen.make-pulses base-thread
addf parport.0.write base-thread
addf parport.0.reset base-thread
loadrt pwmgen output_type=0
addf pwmgen.make-pulses base-thread

addf stepgen.capture-position servo-thread
addf motion-command-handler servo-thread
addf motion-controller servo-thread
addf stepgen.update-freq servo-thread
net spindle-cmd <= motion.spindle-speed-out


#breakout A, micro axis X "X1" joint 0
setp parport.0.pin-02-out-invert 1
net xstep => parport.0.pin-02-out
setp parport.0.pin-02-out-reset 1
#setp parport.0.pin-03-out-invert 1
net xdir => parport.0.pin-03-out

#breakout B, micro axis U "X2" joint 6
setp parport.0.pin-04-out-invert 1
net ustep => parport.0.pin-04-out
setp parport.0.pin-04-out-reset 1
#setp parport.0.pin-05-out-invert 1
net udir => parport.0.pin-05-out

#breakout C, micro axis Y joint 1
setp parport.0.pin-06-out-invert 1
net ystep => parport.0.pin-06-out
setp parport.0.pin-06-out-reset 1
setp parport.0.pin-07-out-invert 1
net ydir => parport.0.pin-07-out

#breakout D, micro axis Z joint 2
setp parport.0.pin-08-out-invert 1
net zstep => parport.0.pin-08-out
setp parport.0.pin-08-out-reset 1
#setp parport.0.pin-09-out-invert 1
net zdir => parport.0.pin-09-out

#breakout E, micro axis A joint ?
#axis A is not used yet
#setp parport.0.pin-01-out-invert 1
#setp parport.0.pin-01-out-reset 1
#net astep => parport.0.pin-01-out
#net adir => parport.0.pin-14-out

#breakout shares pin 17 as enable for all axes
net xenable => parport.0.pin-17-out

#breakout A, axis X "X1", joint 0
setp stepgen.0.position-scale [AXIS_0]SCALE
setp stepgen.0.steplen 1
setp stepgen.0.stepspace 0
setp stepgen.0.dirhold 31400
setp stepgen.0.dirsetup 31400
setp stepgen.0.maxaccel [AXIS_0]STEPGEN_MAXACCEL
net xpos-cmd axis.0.motor-pos-cmd => stepgen.0.position-cmd
net xpos-fb stepgen.0.position-fb => axis.0.motor-pos-fb
net xstep <= stepgen.0.step
net xdir <= stepgen.0.dir
net xenable axis.0.amp-enable-out => stepgen.0.enable

#breakout B, axis U "X2" , joint 6
setp stepgen.6.position-scale [AXIS_0]SCALE
setp stepgen.6.steplen 1
setp stepgen.6.stepspace 0
setp stepgen.6.dirhold 31400
setp stepgen.6.dirsetup 31400
setp stepgen.6.maxaccel [AXIS_0]STEPGEN_MAXACCEL
net upos-cmd axis.6.motor-pos-cmd => stepgen.6.position-cmd
net upos-fb stepgen.6.position-fb => axis.6.motor-pos-fb
net ustep <= stepgen.6.step
net udir <= stepgen.6.dir
net uenable axis.6.amp-enable-out => stepgen.6.enable

#breakout C, axis Y, joint 1
setp stepgen.1.position-scale [AXIS_1]SCALE
setp stepgen.1.steplen 1
setp stepgen.1.stepspace 0
setp stepgen.1.dirhold 31400
setp stepgen.1.dirsetup 31400
setp stepgen.1.maxaccel [AXIS_1]STEPGEN_MAXACCEL
net ypos-cmd axis.1.motor-pos-cmd => stepgen.1.position-cmd
net ypos-fb stepgen.1.position-fb => axis.1.motor-pos-fb
net ystep <= stepgen.1.step
net ydir <= stepgen.1.dir
net yenable axis.1.amp-enable-out => stepgen.1.enable

#breakout D, axis Z, joint 2
setp stepgen.2.position-scale [AXIS_2]SCALE
setp stepgen.2.steplen 1
setp stepgen.2.stepspace 0
setp stepgen.2.dirhold 31400
setp stepgen.2.dirsetup 31400
setp stepgen.2.maxaccel [AXIS_2]STEPGEN_MAXACCEL
net zpos-cmd axis.2.motor-pos-cmd => stepgen.2.position-cmd
net zpos-fb stepgen.2.position-fb => axis.2.motor-pos-fb
net zstep <= stepgen.2.step
net zdir <= stepgen.2.dir
net zenable axis.2.amp-enable-out => stepgen.2.enable

net estop-out <= iocontrol.0.user-enable-out
net estop-out => iocontrol.0.emc-enable-in

loadusr -W hal_manualtoolchange
net tool-change iocontrol.0.tool-change => hal_manualtoolchange.change
net tool-changed iocontrol.0.tool-changed <= hal_manualtoolchange.changed
net tool-number iocontrol.0.tool-prep-number => hal_manualtoolchange.number
net tool-prepare-loopback iocontrol.0.tool-prepare => iocontrol.0.tool-prepared


/////////////////////////////////////////////////////////////

And a micRO M3.ini file


//////////////////////////////////////////////////////////



#this file was created and edited March 14th 2010
#this is a beta release .ini file for micRo V2 with syncRo batch 2
#please report any problems to support@lumenlab.com or www.lumenlab.com/forums
#opening these configuration files with Stepconf will erase certain modifications!
#modify at your own risk!
#www.lumenlab.com
#this file is for batch 2 syncRos. 


[EMC]
MACHINE = micRo M3
#NML_FILE = emc.nml
DEBUG = 0

[DISPLAY]
DISPLAY = axis
EDITOR = gedit
POSITION_OFFSET = RELATIVE
POSITION_FEEDBACK = ACTUAL
MAX_FEED_OVERRIDE = 1.2
INTRO_GRAPHIC = emc2.gif
INTRO_TIME = 5
PROGRAM_PREFIX = /home/syncro/emc2/nc_files
INCREMENTS = .1in .05in .01in .005in .001in .0005in .0001in

[FILTER]
PROGRAM_EXTENSION = .png,.gif,.jpg Greyscale Depth Image
PROGRAM_EXTENSION = .py Python Script
png = image-to-gcode
gif = image-to-gcode
jpg = image-to-gcode
py = python

[TASK]
TASK = milltask
CYCLE_TIME = 0.010

[RS274NGC]
PARAMETER_FILE = emc.var

[EMCMOT]
EMCMOT = motmod
COMM_TIMEOUT = 1.0
COMM_WAIT = 0.010
BASE_PERIOD = 30637
SERVO_PERIOD = 1000000

[HAL]
HALFILE = M3.B1.R1.emc2.4.hal
HALFILE = custom.hal
POSTGUI_HALFILE = custom_postgui.hal

[TRAJ]
AXES = 7
COORDINATES = X Y Z
LINEAR_UNITS = inch
ANGULAR_UNITS = degree
CYCLE_TIME = 0.010
DEFAULT_VELOCITY = 0.10
MAX_LINEAR_VELOCITY = 3

[EMCIO]
EMCIO = io
CYCLE_TIME = 0.100
TOOL_TABLE = tool.tbl

[AXIS_0]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 1
MAX_ACCELERATION = 30.0
STEPGEN_MAXACCEL = 37.5
SCALE = 19200.0
FERROR = 0.05
MIN_FERROR = 0.01
MIN_LIMIT = -0.25
MAX_LIMIT = 19.25
HOME_OFFSET = 0.0

[AXIS_1]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 1
MAX_ACCELERATION = 30.0
STEPGEN_MAXACCEL = 37.5
SCALE = 19200.0
FERROR = 0.05
MIN_FERROR = 0.01
MIN_LIMIT = -0.25
MAX_LIMIT = 19.5
HOME_OFFSET = 0.0

[AXIS_2]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 1
MAX_ACCELERATION = 30.0
STEPGEN_MAXACCEL = 37.5
SCALE = 19200.0
FERROR = 0.05
MIN_FERROR = 0.01
MIN_LIMIT = -0.25
MAX_LIMIT = 3.25
HOME_OFFSET = 0.0

[AXIS_6]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 1
MAX_ACCELERATION = 30.0
STEPGEN_MAXACCEL = 37.5
SCALE = 19200.0
FERROR = 0.05
MIN_FERROR = 0.01
MIN_LIMIT = -0.25
MAX_LIMIT = 19.25
HOME_OFFSET = 0.0


//////////////////////////////////////////////////////////

3
General Mach Discussion / Re: micRO from Lumenlab
« on: September 27, 2010, 12:48:55 PM »
I have the EMC2 setup files but they are all gobbledigook for me.

//Dan

4
General Mach Discussion / micRO from Lumenlab
« on: September 27, 2010, 11:24:48 AM »


Hiya,

I have one of Lumenlab's micRO  M3 bots and I'm running EMC2. However, the EMC2 gives me grey hair and occasional mill-rage attacks.

Is there a setup in Mach3 for micRO? If so, I'll buy a license immediately and install Win XP in my bot computer.

 ( No, my programming days ended 1995. Nowadays - I'm only telling people what to do :) So "setup file" DIY is not an option.

//Dan, M0DFI

Pages: 1