Hello Guest it is November 30, 2021, 01:27:20 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jay77

Pages: 1
1
Galil / Re: Galil HELP DMC-1842
« on: August 14, 2012, 09:02:00 PM »
If you don't have tons of experience, keep it simple for now. I have to find my manuals but it is relatively easy, Galil has configurable pins, map them in Mach and you're all set.  I would recommend step/direction to the drives for the time being and a simple pot to control the spindle.  Get the machine running and then tweak.

2
General Mach Discussion / Problem cutting arcs and circles
« on: February 21, 2011, 10:33:43 PM »
Wondering if anyone can give some advice.  Finally got my old CaMaster machine running about a month ago.  It needed some rewiring, adjusting, and new software.  The problem is when cutting a circle or arc I get a jittery, or whatever you would like to call it, result.  The circle is the right average diameter and from a distance it looks good but there is a fluctuation of +/- .040" along the edge.  The error is not consistant, I cut an O ring grove inside of a circle just to make sure.

The first circle I cut was very jittery but then I realized the feed direction was CCW and the spindle rotated CW.  The feed direction is now CW along with the spindle and the result is better but still not perfect.  I am using the Galil plug-in with linear interpolation checked under move settings and have tried different vector time constants and buffer levels settings to no avail, actually not much difference at all.  I have adjusted the motor tuning and kernel speed in Mach3 and tuned the servos (PacSci) with WSDK from Galil but as this is my first experience setting up a machine, I'm not sure everything is correct.  The gantry motion (axis A slaved to axis X) and Y axis are pretty smooth but not perfect.  The Drives (PacSci) are set to torque mode as recommended by Galil.

My first attempts cutting a circle were with G-code from Lazycam, then tried the circle wizard found in Mach with about the same results, maybe a little better.  I'm just hoping this is not a mechanical issue but after all the tweaking I fear this may be the case.

I also have an intermittent problem while jogging, sometimes the X axis decouples from its A axis slave.  A resest in Mach usually corrects it.

Any help will be greatly appreciated.

3
Galil / Re: Ganrty setup in Mach3
« on: November 05, 2010, 12:41:17 PM »
Worked great!  Love the easy fixes.

Thanks

4
Galil / Ganrty setup in Mach3
« on: November 03, 2010, 05:27:15 PM »
I'm having a little difficulty configuring the gantry of my machine.
Here's a run down of what I'm working with:

Galil DMC 1842
Galil ICM 2900
(4)Pacsi PC833 drive
(4)Pacsi PMA24C servos

Code burned into the controller:

GM ,,,1
GA ,,,CX
GRW=-1
ER 500,500,500,500
OE 1,1,1,1

The X and W axis are controlling a linear style gantry on a 6' x 12' router.  When issuing a command in SmarTerm (For example PR 5000 ; BGX) the gantry moves in a coordinated fashion.  The problem is when jogging the X axis in Mach.  I've tried a couple of different configurations with differing results.

First I configured the Galil plug-in, under axis setup I mapped the Mach axis to Galil axis X->X, Y->Y, Z->Z, A->W and motor types as servo motors.  Under slave axis selection in Mach, X Axis ; Slaved Axis -> A Axis.  With this configuration, when jogging the X axis, both servos in the gantry move but in opposite directions.

Second I tried changing the motor type in the plug-in, X->Servo Reverse.  When resetting, the X axis runs away and the gantry racks.  I then tried changing the D axis to servo reverse and got the same results.

I know that there is a homing function in Mach, which may explain the run away and racking, but the other axis do not attempt to move after being reset.  I'm wondering if the code burned into the controller needs to be there or if Mach takes care of this for you.

Any help would be great.

5
Galil / Re: Galil HELP DMC-1842
« on: August 17, 2010, 03:59:04 PM »
I recently acquired the CaMaster 6'x12' cnc router. I called CaMaster and they said there is no support available for this particular machine as it is old and since it has been manufactured, the company has changed owners. The tech suggested that I contact the controller manufacturer.

This is what I have:
cnc router - CaMaster 6'x12' (X axis utilizes 2 amplifiers and servos)
computer - Asus p5ql socket 775 Intel dual core
cpu - E5200 2.50 GHZ
os - Windows XP Professional SP3
monitor - 3M touch screen
controller - Galil 1842 REV C S/N AM-3669
interconnect module - ICM 2900 OPTO
amplifiers - Pacific Scientific PC833 brushless servo dive (4)
motors - PMC24 (4)
cnc contol software - Mach3Version 3.042.040

Stumbling upon this forum I now realize the hours I've spent trying to get this machine going utilizing the software were in vein.  If anyone could offer help or elaborate on the instructions that were recommended to Bryan, it would be much appreciated as I have nowhere near his knowledge of these machines.

Thanks

Pages: 1