Hello Guest it is January 26, 2021, 01:38:45 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ozwes007

Pages: « 1 2 3 4 5 6 7 8 9 10 11 »
21
Mach3 under Vista / Re: Z unwantedly repeats itself when drilling
« on: June 25, 2015, 03:27:44 AM »
Try This

%
(Boring av hull i rekker)
(Program Posted for Soft Steel )
G0 G49 G40.1 G17 G80 G50 G90 G98
G21 (mm)
F20(change this to suit your feed rate)
G0 X-15.0 Y-15.0
G43 H1.0 Z4.0
G83 X-15.0 Y-15.0 Z-12 Q3.0  
G91 X-15 Y0 L10
G80
G0  Z4
G90 (may want this here to reset distance mode)
M30
%


Wes

My Blue should be minus ;-)
Also TP on mine the Peck cycle does not work with the original. Hence the reason I changed it, although i only tested it on my demo version.

Wes

22
Mach3 under Vista / Re: Z unwantedly repeats itself when drilling
« on: June 24, 2015, 09:47:24 PM »
Try This

%
(Boring av hull i rekker)
(Program Posted for Soft Steel )
G0 G49 G40.1 G17 G80 G50 G90 G98
G21 (mm)
F20(change this to suit your feed rate)
G0 X-15.0 Y-15.0
G43 H1.0 Z4.0
G83 X-15.0 Y-15.0 Z-12 Q3.0 
G91 X15 Y0 L10
G80
G0  Z4
M30
%


Wes

23
General Mach Discussion / Re: Mach3 Major Bug?
« on: June 24, 2015, 09:28:05 AM »
the XML is included in the zip file here - http://www.machsupport.com/forum/index.php/topic,30351.0.html
the input for this particular gear is 26 tooth gear, 22 wide, 6.014138 Deep and 1 for the cut depth.
You can play with the tooth numbers and you will notice the inaccuracy at higher numbers is quite high(for gear cutting)

The full Code for the Macro and GCode is here - http://www.machsupport.com/forum/index.php/topic,29895.0.html
I have altered it a little for precutting the gears, however this issue relates to what's in this code.

This is the macro I used to run through the different number outputs - http://www.machsupport.com/forum/index.php/topic,30344.0.html

I have noticed when I set all my X,Y,Z and A axis DRO's to six decimal points for some reason a very small discrepancy in cutting that I have had since the machine was built appears to disappear.(only talking fractions of mm's here over 20-30 repeated cuts, which i assumed was backlash in the belt drive system)

Hope this helps.

Wes

24
Mach3 under Vista / Re: Z unwantedly repeats itself when drilling
« on: June 24, 2015, 07:15:03 AM »
Id Post the code for peer review, then we could go from there.

Wes

25
General Mach Discussion / Re: Mach3 Major Bug?
« on: June 24, 2015, 07:11:57 AM »
I am trying to pass a value from a script to Mach3. The Value is 13.846153846154. However, instead of passing this value it passes 13.8567.

I don't see this here. If we take this snippet from your macro and enter your 26

Code: [Select]
Teeth = Question ("How Many Teeth on the Gear?")
Gear1=Val(Teeth)
Gear1 = 360/Gear1
Print Gear1
SetVar(1, Gear1)

The value that is printed is 13.846153846154 and the value in var 1 is exactly what it should be i.e. 13.8461538461538 so I don't understand where your 13.8567 is coming from.

Hi Stirling,
All the above I have resolved. The 13.8567 is what appears in Mach3 DRO as #1 after it is passed. The Value in the Macro is exactly as you state. Im not 100% sure where the 13.8567 comes from either, however if you check the bottom of the previous page you will see how I used a rounding function and Increasing the DRO decimal places actually fixed the Issue. My personal belief is that there "appears" to be a double rounding when you pass the Var back to Mach3. And Just for clarity the rounded Number as it should round is 13.8462, and this is applied when I use the Round function and actually appears in the DRO as such.

Wes

26
General Mach Discussion / Re: Motors will lock but will not turn
« on: June 24, 2015, 02:55:46 AM »
Hi Mark,
Changing the Pin states in the Port settings doesn't alter there state only the trigger point from leading edge to trailing edge. The Gcode triggers the state from 0 to 5v.
I have attached my Hobby Pro CNC set-up XML(In the zip File) you can try. Just note the settings and trial them.
I Use 5MM ball screws with a 3:1 reduction so the steps etc. will be different to yours.
Also I have included a shot of the Pin assignment. I believe the only difference between the Hobby and HobbyPro is the A axis.

Word to the wise, try  the settings with the CV_TEST_CODE.tap file I have included, no tools in the system and check the Max settings are within limits and be ready to hit the space bar or the emergency stop.. If it is anywhere near right the units will sing to you ;-)
Let Us know how you go

Wes

27
General Mach Discussion / Re: Motors will lock but will not turn
« on: June 23, 2015, 11:46:11 PM »
Just had a quick check of the Specs

Easy Plug and Play installation
Automatically selects IRQ & IO address
Supports IRQ sharing
Multi – card capability – allow for upgrade with additional serial or parallel cards
For 5V PCI slot only

Notice it has IRQ sharing - not a good thing. See if you can manually set the IRQ and IO address.
Also it is for the older 5V PCI slots, check your PCI slots are 5v ones and not 3.3V otherwise you will not have 5V

Wes

28
General Mach Discussion / Re: Mach3 Major Bug?
« on: June 23, 2015, 07:31:16 PM »
Hi Ken,
The issues I have found nearly always come from the setup and the GCode speed. Also the need to reboot the machine daily helps. This may be a windows issue, as XP and most other versions of windows have memory leaks(memory over time is lost or corrupted while in use). I push my Machine to its limits on accuracy, so errors i predominately see are related to this. TP's comments on G2-G3 issues may be true, i have not found that to be the case, however I always put G04 P250 Moves after all Z moves and G2-3 moves. I do this because reading to many lines ahead and not having error correcting Ram in your machine is just a disaster waiting to happen. And quite honestly I have witnessed the same issue happen on top range machines(unexplained crashes) and the only thing we can put it down to is Hardware feedback or memory glitches. A lot of this latter can be eliminated by ensuring the Power input to your device is as glitch free as possible(use a UPS at a bare minimum).
So go for it Ken, get a kit, start fiddling. Its  fun, its frustrating, however there are a multitude of people on this and other forums that have been there and done that.
As for Buggy versions of Mach3, they are documented in the Known bugs section. I use version .67.

Wes

29
General Mach Discussion / Re: Motors will lock but will not turn
« on: June 23, 2015, 07:03:41 AM »
If you have a Hobby CNC controller and you pulled the cable while it was energised you have probably blown one if not all of the Control chips.
The processor being 64Bit is not the issue. I would be checking the Parallel port card settings. IE Standard, EPP, ECP maybe. Also double check the wiring and the Step Dir Active is ticked in the Config page.

I use the HobbyPro CNC Controller without issues.

Wes

30
General Mach Discussion / Register Your Country?
« on: June 22, 2015, 08:38:07 PM »
Hi All,
Does anyone think it would be worthwhile Setting up Country and under that County/Town/State specific Forums for people wanting to meet others in there area?

Or do you think that it would be stalkerish? allow for undesirables to case for burglary?

Just asking, as I'm interested in meeting like minded people to discuss issues specific to our region. i.e. parts suppliers, material suppliers etc etc.

Wes

Pages: « 1 2 3 4 5 6 7 8 9 10 11 »