Hello Guest it is May 22, 2024, 05:18:01 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - thosj

381
PoKeys / Re: Mach only see's inputs when pockey software is running.
« on: April 30, 2011, 07:07:30 AM »
I do. Also, have you read Scott's thing about upgrading PoKeys? Here?  http://www.machsupport.com/forum/index.php/topic,16920.0.html  That may have been my problem when I tried a newer version. My upgrade didn't work, so I copied a copy of the entire Mach3 directory back and have since forgotten about upgrading PoKeys, it just works and I don't need to change anything.

I'll attach the file, not sure if that's OK, but if some mod deletes it, or it's too big (3.4MB), send me your email and I'll email it to you.
 
I can't seem to attach it. Too big? Says 6MB and the file is 3.4MB, but it won't post if I attach the file. I'll need an email address to send it to.

Tom

382
PoKeys / Re: Mach only see's inputs when pockey software is running.
« on: April 28, 2011, 10:49:23 PM »
I have Pokeys and Smoothstepper and it seems to run fine. I think I run Pokeys 10.4. I tried 10.6.4 once and it didn't work, so I quit upgrading Pokeys plugin and just use 10.4. I'm not sure what you mean by "pokeys software running in the background." It's a plugin, and once activated, it should just run. You don't mean the Pokeys software for programming the pokeys, do you? I don't see how that would relate to Mach3 running Pokeys. I guess I don't have much to offer for help. What SS plugin are you using? I'm currently using 17bd, but I've used others all along and Pokeys and SS worked fine together.

One time there was something about load order of plugins, so maybe remove all the plugin dlls from the plugins folder, put them back one at a time, start Mach, activate it, stop Mach, add another. Do you have any other plugins running that might be conflicting. Maybe by reinstalling them one at a time and trying things you can figure out a conflict.

On the FRO brain, I have to do the code 223 line by using Send String and entering 223. If I use DRO and hand enter 223, it shows as OEMDRO 223, not just 223 as yours shows. I tried it with OEMDRO 223 and it didn't work. I have it working fine now.

Thanks again.

Tom

383
PoKeys / Re: Mach only see's inputs when pockey software is running.
« on: April 28, 2011, 11:04:08 AM »
Wow, thanks for doing that, Mat! I'm not home to try it right now, but will in a few hours.

Just out of curiosity, and to learn(!), what did you pick to terminate the Mod:126-IN/Formula a/6.827 block? Did  you pick Send String and just type 223? It doesn't seem picking DRO works as yours just has 223 in the termination box, not DRO 223 or USERDRO 223 or anything.

Thanks again,

Tom

384
PoKeys / Re: Mach only see's inputs when pockey software is running.
« on: April 28, 2011, 07:45:40 AM »
Thanks again, Mat.

I'll have to edit it for the first Mod 126 in to be around 680 greater than or less than, but I need to know what the last line is in the brain. What's the 223 terminator, a string? What does it do? I'll need to re-do it so I need to know what it is.

I also see you put the Reset FRO back before the Feed Ovrd. Wasn't that the original intent of this new brain to work with Mach 035, to have the Reset at the end?

Wish I knew more about these brains!!

Tom

385
PoKeys / Re: Mach only see's inputs when pockey software is running.
« on: April 27, 2011, 06:51:56 PM »
Thanks Mat,

The brain fixed the 100% thing. I had to rewrite it as my pot is on ModIO 126, and I prefer 150% max instead of 200%, but no problem, it works now and doesn't go to zero. Now the problem is the pot doesn't seem to control rapid, just feed. Even with Lock Rapid DRO to Feed DRO checked in General Config. I wonder if there's a way to have the brain control rapid at the same time as feed? Even though it's supposed to lock to feed if the box is checked, but doesn't!!

386
PoKeys / Re: Mach only see's inputs when pockey software is running.
« on: April 27, 2011, 10:45:34 AM »
What Mach version? If dev rev 035, try lockdown 022. On your pots for feedrate override, does it go to zero when it gets to 100%? Mine does with 035, fine with any older version.

387
General Mach Discussion / Dev 035 and FRO
« on: April 24, 2011, 11:12:21 AM »
I have an analog pot on a Pokeys and use a brain in Mach for FRO. It's worked for years 'til 035. If I switch back to 030 dev. it works fine. It's worked fine in all versions of Mach up to now!!

What it does. When the FRO percentage gets to 100% it actually goes to 0%. I've tried this while feeding and it does indeed stop. It works fine above and below 100%.

I'll attach the brain file, originally written by Hood, and pretty simple, in case anyone thinks editing the brain would fix this in Mach 035!! As I said, switching to any other Mach3.exe and my pot and brain work fine.

Any help appreciated.

Tom

388
SmoothStepper USB / Re: Port 3 Inputs?
« on: April 05, 2011, 11:21:47 AM »
Ah, man, I Hate it when I do that. I read thru the doc and got to all the Windows install bits and thought I was done and didn't find it. I should have printed it, or found my printed copy and I'd have seen that.

Sorry!

Tom

389
SmoothStepper USB / Port 3 Inputs?
« on: April 04, 2011, 07:32:26 PM »
So, Pins 1A, 1B, 1I on the SS? Are these Port 3 Pins 1-3 respectively? And although I don't need them now, what ports/pins are the differential inputs?

I'm at the moment wanting to run my spindle index signal into the SS, but for the life of me I can't remember the port/pin deal even though I'm sure I knew this at one time!! Reread the doc and searched a bit, but can't seem to find it.

Thanks,
Tom

390
PoKeys / Re: Pokeys analog input & Feed Rate DRO
« on: March 26, 2011, 05:25:43 PM »
So....the first 3 lines of my brain just reset to 100% when it's about 3% either side, so it's not floating around near 100%, flickering the LED in Mach. You could delete those 3 lines of the brain and the last two lines should do the FRO thing at 150%. It doesn't do that for you? You could change the formula to a/5.12 to get 200%. If those don't work, I have no idea. Works for me just the way it's written, FRO starts up at whatever the pot is set to, lives thru RESET, and moves to whatever the pot sets it to, and it jumps to 100% when it's around 100% +/- approx. 3%.

Again, the offer stands, upload your brain and I'll see if it works here, and take a look at it, for what it's worth. Can't hurt!