Hello Guest it is May 22, 2024, 03:28:14 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - thosj

281
rhtuttle just go old school and use a macro b

Good if he has Mach4 Industrial, I think.

282
Mach4 General Discussion / Re: Jog a Linear A with Keyboard
« on: January 25, 2018, 06:06:05 AM »
Hmmm......didn't work. I cleared out the Inputs, so nothing there for Jog, like your screenshot. Setup the Keyboard plugin with the jogs. Now no axis jogged with the keyboard. I put it back, XYZ jog, A does not.

You said "You can't jog A axis because you don't have it setup in the I/O and you don't have any function assigned to it in the Keyboard plugin." If you look up above at my screenshots, it IS setup in I/O and it is the ONLY one setup in the keyboard plugin. When it's like that, XYZ jog and A does NOT!! I tried every combination I could think of and A will not jog with the keyboard.

Your screenshots show nothing setup in I/O and ONLY setup in the plugin. I tried that and no axes jogged. How does yours jog setup like your screenshots and mine does not. What motion controller do  you use? I have an ESS. Maybe that's it?

283
Mach4 General Discussion / Re: Jog a Linear A with Keyboard
« on: January 24, 2018, 07:35:07 PM »
Thanks, Mike, I'll go try that.

But.......what I don't understand is how am I able to jog X, Y, and Z now? Is the keyboard plugin jogging or are the I/O's jogging. If it's the I/O's, why do I still have to enable the keyboard plugin in the system tray in order to jog X, Y, and Z? Without the tray icon enabled I can't jog XYZ. And why can't I job A no matter what?

I'll disable the I/O stuff and see if I can get it to jog with the keyboard plugin!!!

BTW, we talked at Cabin Fever 4/5 years ago in York, that's how I know you're Mike!!!

284
Mach4 General Discussion / Re: Jog a Linear A with Keyboard
« on: January 24, 2018, 07:47:27 AM »
Excuse me if I misunderstand, but how could I jog X, Y, and Z, with the keyboard, if the keyboard plugin were disabled?

As an aside, why does the keyboard plugin start disabled anyway? Why doesn't it start in the state it was left in?

And not to distract from my keyboard issue, but in the vein of not starting, why, if I turn of Soft Limits, does it not start ON next time? Or is there some way to have it be active on start?

Tom

285
Mach4 General Discussion / Re: Jog a Linear A with Keyboard
« on: January 23, 2018, 06:41:55 PM »
Not the keyboard, tried two different ones. Not the Shuttle thing I saw, which was in MPG and disabled.

Here are two screenshots, the keyboard setup and the Mach Inputs. Are these conflicting somehow, or is this correct?

Otherwise, still stuck, can't jog A with the keyboard. And, still, XYZ jog fine with the keyboard.

286
Mach4 General Discussion / Re: Jog a Linear A with Keyboard
« on: January 23, 2018, 09:44:22 AM »
I tried exactly that last night. No A movement and no DRO movement, and no flashing LED on my control panel (from PMDX-126) indicating step pulses flowing. The screen does "grey out" same as when pressing other jog keys. I tried different keyboard keys and I tried different selections in the function box, nothing. What I hate is having to restart Mach4 every time I change this keyboard setup before it'll work.

What I did NOT try is a different keyboard!!! I'll try that tonight when I get back to the machine. I have a little Tormach keyboard which SHOULD be nothing more than a USB keyboard, an ASCII key press should be an ASCII key press. I DON'T have a Tormach machine, I have a home CNC'd BP clone.

And, yeah, I, too, have no idea why my X, Y, and Z jog fine with nothing in the function box and I'm afraid to PUT something in the function box for fear those will stop working, too!!!

Like I said, this was brought along from a version last April, now to 3418 or whatever the current version is on the web site. I DO believe I couldn't jog A back then either, but COULD always jog X, Y, and Z with the keyboard. And......I can Gcode command the A and I can jog the A with my VistaCNC P2-S pendant.

**Edit***

Just thinking about this, I tried a Shuttle Pro last year and didn't like it. Removed the plugin, but it almost seems I saw something about Shuttle Pro is Mach settings recently. Could something like that do this?

Tom

287
Mach4 General Discussion / Re: Jog a Linear A with Keyboard
« on: January 23, 2018, 06:17:45 AM »
If by that you mean is my A axis working, yes. It works and jogs with my pendant.

But, if you mean I don't have anything selected in the rightmost column, notice nothing shows up in X or Y or Z and they jog with the keyboard. So what function do I pick in the right column to get the A to jog like the other 3 axes?

One note, this profile/screen setup has come along with several Mach4 versions, XYZ have jogged all along, but not A.

Tom

288
Mach4 General Discussion / Re: Jog a Linear A with Keyboard
« on: January 22, 2018, 05:44:44 PM »
I can't get it to work. I'll attach a screenshot. I've tried several key combos, nothing.

How would one delete one of these entries, so I can try by adding the A again?

Tom


289
Mach4 General Discussion / Re: Jog a Linear A with Keyboard
« on: January 22, 2018, 01:52:20 PM »
I have it setup like Bryanna said. I must not have something right because I've tried different key combos and nothing makes the A axis job. I'll try adding the A+/A- again. Is there a way to remove one?

I'll be back with a screenshot when I get a chance to get to the machine and check it out and can't get it to work. Actually, I'll be back either way to post what I had wrong or what I had to do to get it working.

Thanks!

290
Mach4 General Discussion / Jog a Linear A with Keyboard
« on: January 22, 2018, 12:56:03 PM »
Seems I remember this from the past, but.....I have a linear A axis, in my case the knee of my BP clone. I cannot jog A with any keyboard key selection. Is this by design, or perhaps there's something I need to set somewhere to get it to Jog A with keyboard keys? Maybe something with how I have it set in the Keyboard Plugin config? It jogs fine with my VistaCNC P2-S pendant. And in Mach3 it jogs with keyboard keys.

Thanks,
Tom