Hello Guest it is September 25, 2023, 06:49:58 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Chip

1591
LazyCam (Beta) / Re: Lcam 2.0...
« on: May 07, 2007, 03:07:42 PM »
Hi, Brian & Paul

Just downloaded Paul's NC file, It Crashes Mach3 to Windows error report.

Having the same problem with the LC Lathe G-code, The K values are huge, 1000K Billion's, Bigger than I can count.

N640 G1  X-5.0748   
N645 G0  Z0.1000
N650 G1  Z-1.0000 
N655 G3  X-5.1250  I-2.5625  k-6277438562204192500000000000000000000000000000000000000000000000000.0000
N660 G0
N665 G1   
N670 G0  X0.0599  Z0.1000
N675  Z-1.0000
N680 G1   
N685 G0
N690 G1  X-0.0664   
N695 G0
N700 G1   
N705 G0  X-0.0820  Z0.1000
N710  Z-1.0000
N715 G1   
N720 G0
N725 G1   
N730 G0
N735 G1  X-5.0305   
N740 G0  Z0.1000
N745 G1  Z-1.0000 
N750 G3  X-5.1250  I-2.5625  k-6277438562204192500000000000000000000000000000000000000000000000000.0000
N755 G0
N760 G1   

Thanks, Chip

1592
LazyCam (Beta) / Re: Lcam 2.0...
« on: May 07, 2007, 01:33:34 PM »
Hi, Brian

Missed your comment on Post options looking forward seeing the list, Thanks.

Items 1, 2 working now with 05 07 Update.

Item 3 still not working.

Working now 05-07 Update 1. Duplicate. line in lower left Square is missed by old and new LC, with Remove Redundant lines Checked or Un-Checked, Load Options.

Working now 05-07 Update 2. Dots are missed in Layer_3_ Dot, with Remove Dots Checked or Un-Checked Load Options, or with Layer Enabled Checker, Old ver Worked.


3. What I find is, If I load the Attached file and don't zoom in on the Origin Marker first and Move it, LC errors out to Windows error report.

Once I've moved it and double click to default size window it seems to work fine from then on, Iif I load a new file, I have to repeat the

Zoom, Mover Origin again. Un-less it the same file

I have the same version of Visual Studio you use, If I could get some partial source code, New or Old that covers this type of Origin move and  a little guidence from someone maybe we could track this problem down and be done with it.

I've reported this before with Debug of program with EXE file but its in Assembly code, Guess this is hard to work with,

I have the time and computer with this problem, Would like to help on this if you have a way, This problem is causing a few others problems also.

Another Great Advance In New LC, This is So-----Nice.

Thanks, Chip

1593
General Mach Discussion / Re: Mach3 + Geckos 201 + C11
« on: May 07, 2007, 01:25:23 AM »
Hi, SiN

Dose your stepper motor lock up with power on.

There should be low ohms reading from RED to WHT = phase 1 & connected to Gecko Phase A, B and YEL to GRN =  phase 2 to Gecko
Phase C, D.

Check your other stepper motors or disconnect motor to check.

Check pin 7 on your Gecko drive, If wire connected disconnect, Does the stepper lock up and work now (Disable Pin, Gnd to Disable Drine)

Gecko Pin 10, 5 Volts + from Arturo┬┤s c11 board, Put a volt meter between pin 10 to pin 8, Should see 5 volts when stepping in one direction.

Let us know

Hope this Helps, Chip



1594
General Mach Discussion / Re: Tuning keling motors in Mach3
« on: May 06, 2007, 11:19:52 PM »
Hi, Tybrenis

First thing to try is in motor tuning set the Step & Dir Pulses to 5, Don't forget the Save Settings, (This gives your stepper control more time to see the Pulses sent out by Mach).

If that doesn't help, In Ports & Pins, Motor Outputs set the Dir & Step Low Active to a different State (X to Check or Check to X), By clicking on it, Don't forget the Apply, (Some stepper controls are sensitive to leading and Trailing Edge Pulses).

Steps Per sets # of steps to move 1 unit whether Inch or MM.

Vel. sets Max speed (Try 50 to start, Set it up till it misses steps back it down some till no steps are lost)

Accl. sets rate from dead stop to max Vel speed. (Try 10 to start, Set  it up till it misses steps back it down some till no steps are lost)

Others may have more specific information on your control.

Hope this Helps, Chip

1595
General Mach Discussion / Re: step and direction spindle
« on: May 06, 2007, 08:47:06 PM »
Hi, Rick

No you need a 555 timer.

Do you have the Immediate Relay off before delay Checked in ports & pins Spindle Setup page.

Are you using an M5 in your code and the G04 Delay.

Post your code.

Sending you a Personal Msg. Top of this Page, Just above the Search Window.


1596
General Mach Discussion / Re: Thanks Chip!
« on: May 06, 2007, 07:23:12 PM »
Hi, Keith

Enjoyed helping (in a small way) you sorting it out.

You did all the hard work, Glad you didn't have to go to plan C or D-yna-mite.

Put it together, Post the funniest Video Clip's also.

Thanks, Chip

1597
General Mach Discussion / Re: step and direction spindle
« on: May 06, 2007, 06:20:29 PM »
Hi, Rick

Radio Shack should have what you need if you have one near by.

How about adding a G4 P5 (P value can ether be Sec, or Mil-Sec depending on selection in General Config, "Go4 Dwell in ms Check box"),

Top Right of page.

Ether use in G-code or I think thy work in Macros also ?

Hope this Helps, Chip


1598
LazyCam (Beta) / Re: LCam failed to initalize
« on: May 06, 2007, 05:39:40 PM »
Hi, All

Had the some problem with LC, The fix for me was set the Video acceleration in Windows to None.

Start, Control Panel, Display, Settings, select Monitor if you have more than one, Advanced, Troubleshoot, "Hardware acceleration".

Set it to, NONE, Apply, OK.

Worked Hear, Chip

1599
General Mach Discussion / Re: step and direction spindle
« on: May 06, 2007, 03:19:06 PM »
Hi, Rick

Your encoder sounds like a standard 1 puls one, "I think" The short pules is there whether its low pulsing high or high pulsing low + - , The same way as changing  Active  low with an X or Check Mark in Mach.

In the Diag., Select the C1 for range and Var. R1 for Delay Time adjust.

Are you running in 45 Khz kernel mode ?, Should help Mach to see your pulses.

Whats your Computer speed ?

More Info, Chip

1600
General Mach Discussion / Re: step and direction spindle
« on: May 06, 2007, 01:55:13 AM »
Hi, Rick

On My Compact 5 Lathe the index disk is about 4.5" in Dia. with about a 5/8 " slot to allow Mach to have time to see the opto Puls.

You may be able to use your Index pulse output as it is and add a IC555 Timer to reset with a adjustable time delay, R1 Var. resistor.

Just A Thought Hear, Chip

Edit: the resistor value is 1K and cap is 0.1 uf. This seemed to be the best values.