Hello Guest it is August 08, 2020, 03:05:44 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - JTulley

Pages: 1 2 »
1
General Mach Discussion / Re: Tormach / Mach3 / Sprutcam code failure
« on: August 01, 2008, 07:29:08 AM »
Hood, It appears to have resolved itself.

The program runs fine today. Very strange as I did several reboots yesterday when I was having the problems.

Thanks again for the help.

2
General Mach Discussion / Re: Tormach / Mach3 / Sprutcam code failure
« on: August 01, 2008, 03:36:53 AM »
Here's the .xml and full code.

3
General Mach Discussion / Re: Tormach / Mach3 / Sprutcam code failure
« on: July 31, 2008, 03:28:57 PM »
Thanks for your help Hood.
I guess I'll just have to manually reenter the code line by line until I find the fault.
Could even be an"invisible" character on the code line.
I can check if the firstpart.nc file still runs, it may well be that working in metric with the Tormach throws up more errors as they are clearly mostly used in the US, not Europe.

4
General Mach Discussion / Re: Tormach / Mach3 / Sprutcam code failure
« on: July 31, 2008, 03:08:53 PM »
I have them here. Hopefully they are attached OK

5
General Mach Discussion / Re: Tormach / Mach3 / Sprutcam code failure
« on: July 31, 2008, 02:59:53 PM »
I've just checked out the M6 macro as well. I have two, M6start.m1s and M6end.m1s

M1Start has the code:

  tool = GetSelectedTool()

  SetCurrentTool( tool )

but M6end is blank.

Does this make sense ?

6
General Mach Discussion / Re: Tormach / Mach3 / Sprutcam code failure
« on: July 31, 2008, 02:56:07 PM »
One of the things I notice is that some of the G codes have the leading zeroes missing. ,e.g rather than G00 this code has G0.
I don't think that this should be important, but I'll probably modify the code tomorrow when I'm next at the machine to see if it makes a difference.

7
General Mach Discussion / Re: Tormach / Mach3 / Sprutcam code failure
« on: July 31, 2008, 01:58:33 PM »
I should also say that I set the units to metric in the M990 file as previously discussed, and also that the M998 worked when using the firstpart.nc program.

' Revised 3 Jan 07 to shorten Not Reffed message
' Revised 2 Aug 2005, JAP to ignore the 9999 values and to be Units aware. 
 
Option Explicit   
' This macro iimplements Goto Tool Change logic   
Dim x, y, z, CurrMetric   
Dim PosIsMetric, DestX, DestY, DestZ   

If NOT GetLED (7)  AND Not GetLED (8) AND Not GetLED (9) Then ' axes are reffed so Abs coords OK                           
   x = GetUserDRO( 1200 )   
   y = GetUserDRO( 1201 )   
   z = GetUserDRO( 1202 )   
   PosIsMetric = GetUserDRO (1209)  ' this is definition of what units the tool change position is in
   CurrMetric = GetLed (2)   
   If (CurrMetric <> 0 And PosIsMetric <> 0) Or (CurrMetric = 0 And PosIsMetric = 0) Then ' we need no conversion   
       DestX = x   
       DestY = y   
       DestZ = z   
    ElseIf CurrMetric <> 0 and PosIsMetric = 0  Then ' we need to convert to metric   
       If x <> 9999 Then DestX = x * 25.4   
       If y <> 9999 Then DestY = y * 25.4   
       If z <> 9999 Then DestZ = z * 25.4   
    Else ' convert to imperial   
       If x <> 9999 Then DestX = x / 25.4   
       If y <> 9999 Then DestY = y / 25.4   
       If z <> 9999 Then DestZ = z / 25.4   
    End If ' got a valid set of destinations   

   Code "G0"  ' to switch things to G0 mode if not there already   
   If z <> 9999 Then 
       Code "G53Z" & DestZ   
       If x <> 9999 And y <> 9999 Then ' can do coordinated move 
           Code "G53X" & DestX & "Y" & DestY   
       Else ' do separate move 
           If x <> 9999 Then Code "G53X" & DestX   
           If y <> 9999 Then Code"G53Y" & DestY 
       End If 
   Else   
        Message " Z must be moved for safety of X and Y moves but position is 9999"                             
   End If 
Else 
   Message "Cannot use button/M998 as not referenced"   
End If   

8
General Mach Discussion / Re: Tormach / Mach3 / Sprutcam code failure
« on: July 31, 2008, 01:10:26 PM »
The spindle is in the auto position, and I can start it with either the spindle start button on the screen, or using an M3 command in the MSI.
M5 also works in the MDI to stop the spindle.

9
General Mach Discussion / Tormach / Mach3 / Sprutcam code failure
« on: July 31, 2008, 12:30:56 PM »
I've just attempted to run my first personally generated G-code program using Solidworks to Sprutcam for a Tormach PCNC110.

When I run the code it starts off OK, i.e. moves to a tool change position, requests tool change then moves Z towards the workpiece. However the spindle does not get turned on and an error box pops up saying

Error on line:2 - Unspecified error

Meanwhile the G-code program continues running, generating machine motion ( but no spindle rotation)

Clicking OK to the first error message brings up another window - M5 - Mach3 VB Script Editor with the code DoSpinStop()

Funny thing is there isn't an M5 command issued from my code. ( Is the M5 part of the M998 instruction ? )

Any ideas why this is happening ?

[Program sample below]

%
OProject
N10 G90 G17 G40 G80 G49
(Pocketing)
N20 M998
N30 T12 G43 H12 M6
(Cylindrical mill L21, D12)
N40 G0 X160.315 Y32.987 Z25. S1600 M3
N50 G0 Z21.
N60 G1 Z16. F100 M8
N70 G3 X160.315 Y32.987 Z16. I-0.316 J-2.9837
N80 X159.724 Y33.234 Z16. I-1.4125 J-2.544
N90 X159.018 Y33.359 Z16. I-0.9163 J-3.113
N100 X156.876 Y28.425 Z16. I0.9815 J-3.3579 F200

10
General Mach Discussion / Re: Set Tormach Mach3 to metric
« on: July 30, 2008, 03:16:57 PM »
I've made the G21 change to the init file, and it behaves as you've all described.
Thanks for the tips.
Now I just have to find out while my coolant reservoir is leaking...

Pages: 1 2 »