Hello Guest it is May 30, 2024, 06:33:20 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - zafarsalam

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 »
281
Works in progress / Re: 4 axis screens for 800x600 display
« on: March 05, 2010, 02:09:39 AM »
Screen 2 is ready.

282
Works in progress / Re: 4 axis screens for 800x600 display
« on: March 02, 2010, 11:44:58 PM »
Here is the capture image of the first screen for 1280x1024 screen set.

283
Works in progress / Re: 4 axis screens for 800x600 display
« on: March 02, 2010, 11:06:53 PM »
I am working on a 1280x1024 screen. I guess it will be finished in a couple of days. It's for a machining center, so there are tool change and spindle speed controls on it. Also it is based on Xbox 360 hand held controller so there are no mpg controls on that screen. If you need mpg controls too then let me know. I'll add them to this screen.

Zafar

284
Works in progress / Re: 4 axis screens for 800x600 display
« on: March 01, 2010, 10:22:55 AM »
Another request. Could you post a photo of your machine with this screen loaded and running. I'd be happy to see it in action. The machine I designed it for is still under construction. I'll also post it's photo when it's done.

Zafar

285
Works in progress / Re: 4 axis screens for 800x600 display
« on: March 01, 2010, 10:17:12 AM »
There is very slight difference in appearance with the Autoscreen Englarge enabled and disabled. With it enabled there is slight overlapping of LED's with the buttons. The screen looks more crisp with the autoscreen enlarge disabled. The difference is not that noticeable (if you are not as much fussy about details as I am).

Zafar

286
Works in progress / Re: 4 axis screens for 800x600 display
« on: February 28, 2010, 11:09:19 PM »
Thank zafarsalam

I had already tested your screen set. It is really great. I saw the Simulate Program Button in your screen set.

But I have font error with your screen set. I install your Digital7-Mono Font. But I can't see this font in my DRO and see other font. And the font size is a little big than DRO size. I upload this photo and please advice me how can I solve this problem.

Another problem is that I cannot use Load Wizard and Last Wizard. I think you did not set this function in this button. Please upload if you finish for this function.

High Tech Key

You have to make a few changes in your General Config and Fonts section of Mach3 Menu. Go to Config/General Config menu in Mach3 and deselect Auto Screen Enlarge and Boxed DRO's and Graphics. This screen is best viewed in it's original resolution. For the fonts go to Function Cfg's/Fonts menu and select Digital-7 font for the DRO's there. I am running this screen on a 12" LCD monitor which won't go above 800x600 resolution. And the wizards are designed for 1024x768 screens. That's why I disabled these buttons. You can select wizards from the menu bar of Mach3.

Zafar

P.S.  I am designing a high res. version of this screen these days. You'll get wizards button on that one.

287
Works in progress / Re: 4 axis screens for 800x600 display
« on: February 28, 2010, 12:26:11 AM »
Simulate Program Run Button is there on the "Program Load" screen. I added it after I captured images of the screens that are posted here. Download the .set file that I posted on Feb. 12.

Zafar

288
Feature Requests / Unicode text
« on: February 26, 2010, 04:55:17 AM »
Is it possible to have unicode fonts support for Mach labels and buttons text. That would be helpful in designing screens with my native language which is written in Arabic fonts.

Zafar

289
General Mach Discussion / Re: Screen
« on: February 25, 2010, 12:38:22 AM »
Thanks a lot Klaus for the fix. Save and Saveas functions are ok now. The same error window now appears every 10 minutes and I have to click it off. Again, I say, it's not much a bother. Just wanted you to know.

Zafar

290
General Mach Discussion / Re: Screen
« on: February 23, 2010, 10:17:13 AM »
I am running winxp.

Zafar

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 »