Hello Guest it is May 30, 2024, 07:05:24 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - zafarsalam

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 »
121
Build Thread (Update)

Here are latest photos from Khalid. Paint job is complete on the machine. Nice inscriptions are painted onto it and the slide guards are all in place. Looking nice. They have a big job of drilling for complete heat exchanger set scheduled next month. Can't wait to see the pics and vids for that job.


122
Modbus / Re: Mach3, Arduino, Modbus and MPG
« on: February 15, 2013, 09:51:09 AM »
so, any word, did you get it working?

Haven't tried it yet. Maybe next week. Another out of town visit is on schedule.

123
Build Thread (Update)

It is second day at Sadiqabad. At breakfast table I receive SOS call from home. Chicken pox has erupted on kids, wife needs me home ASAP. I have already planned the job to be finished by the evening. So make plans to leave at night instead of next morning.

The sliding strips are screwed onto the guards outer edges. We prepare supports for the moving and stationary portions of the guards. Putting the flexible, sagging, 180 kg SS guards in place for alignment and fastening wasn't as simple as we had anticipated. Ended up consuming most of the day in putting them straight and levelling them with the machine structure. After 14 hours of work we finally accomplished installation of the guards on one side of Y-axis. Checked their movement against the limits of machine and at different speeds. Works perfectly as calculated. Another goal achieved. Now I know why all the fabricators charge those exorbitant charges for seemingly simple jobs. No job is simple with fabrication (I've learned the hard way :) ). Here is a short video of guards sliding with table movement.

https://www.facebook.com/photo.php?v=4824743251181

In the end I gave instructions for installation of the other end's guards. Their alignment was already done. They had to do drilling tapping and fastening (another 2 hours work). Left Sadiqabad that night and this morning I am back in Karachi. Khalid's team must have installed it by now. I am going to give him a call and inquire about it right after posting this update.

124
Modbus / Re: Mach3, Arduino, Modbus and MPG
« on: February 11, 2013, 08:39:50 PM »
Thanks a lot Scott for the explanation. I am out of town right now. Will give it a try when I get back home and let you know if I get any better results.

125
Build Thread (Update)

I am back in Sadiqabad again. Had the stainless steel sheets sheared and bended in Karachi and brought them with me here yesterday. Today we welded them together and assembled the set of guards ready to be installed on machine tomorrow. Khalid's team is going to screw in the sliding strips to SS sheets during the night and hopefull I'll get them ready to be installed on Y-axis slides by tomorrow morning. The structure for walkway around the machine is also ready. They are going to put it in place tomorrow too. I'll take a few final snaps of the machine when I leave Sadiqabad tomorrow night.

126
Modbus / Re: Mach3, Arduino, Modbus and MPG
« on: February 11, 2013, 11:48:00 AM »
Hey just thought I would add my two cents here.....

Modbus: 
The time values on the config is how often you want it to poll that register group.
For MPG to work reasonably well, your hardware would need to buffer the counts,
and to get some kind of "smooth" action you would need to send in a "Tick Count"
to Mach3 as well.

Delay: since BOTH Modbus, and a motion plugin, all run at mach3's update loop, 1/10 per second your
not going to get "real time" MPG control......  see the thing about the count buffers in the hardware
above.

Scott


Scott,

That's what I wanted to ask. How do I calculate the tick count. Maybe that is what's causing the delay. The delay I get is definitely much bigger than 100 ms, the refresh cycle duration of brains.

Zafar

127
Modbus / Re: Mach3, Arduino, Modbus and MPG
« on: February 10, 2013, 12:53:09 PM »
John,

Have you tried LCD output with Arduino and modbus. I did it once to display axes DRO's on a 4x24 LCD module. Have to give it another try too some time.

Zafar

128
Modbus / Re: Mach3, Arduino, Modbus and MPG
« on: February 10, 2013, 12:50:17 PM »
John,

I had tried differnt timeout values and baud rates etc. with my modbus MPG, but they had no effect on it's response. Maybe there was some difference and I couldn't notice it. The lag only becomes noticeable when you try it on the real machine. On your desktop PC with no hardware attached to Mach you can't catch it.

I am using MPG hooked up with PP or Smooth Stepper now. I'll give it a try once again with Arduino when I return back from my out of town visit.

Zafar

129
Modbus / Re: Mach3, Arduino, Modbus and MPG
« on: February 08, 2013, 10:44:28 PM »
Zafar:
Were you able to properly configure the MPG?.
As you connected? .

MPG works with Arduino in Mach3 but there's a delay of about 0.5 seconds in it's response. Couldn't figure out to fix that. Haven't touched it for quite some time. Maybe I'll give it another shot in a few days.

Zafar

130
Works in progress / Re: 4 axis screens for 800x600 display
« on: February 08, 2013, 09:16:52 PM »
Dan,

You need to change the DRO font in Mach3. Just go to the Function Cfg./Fonts menu and change the DRO fonts to Digital-7. You should have Digital-7 font installed in Windows before that.

Zafar

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 »