Hello Guest it is November 18, 2019, 10:05:08 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mouridsen

Pages: 1
1
Mach4 General Discussion / Re: Can't set machine position in script
« on: January 24, 2019, 12:56:01 PM »
Hi

Quote
The correct approach is to at the start of the new session reference (home) your machine and THEN using your stored
work offsets resume the job from where you left off.

We are fully aligned  8) This will be my way of doing it. Thanks!

Brian

2
Mach4 General Discussion / Re: Can't set machine position in script
« on: January 24, 2019, 11:52:51 AM »
It sound like it is not possible.
The most important function is to save the work offset position and load it again and that works.
My reason for doing it was to make it possible to save the position for all coordinates and then be able to shut down the machine and pc (for what ever reason) in a random position. Then I could start it all again (the next day maybe) and load all positions and continue where I stopped.
The bad thing about this approch could be that I might loose a step when I turn off and on for the stepper drives.
Now I have to rely on the Homing and proximity sensors. I have seen that they should be quite precise.

I still think it could be nice to have the possibility :)

Brian

3
Mach4 General Discussion / Re: Jog buttons are not activated
« on: January 24, 2019, 11:32:05 AM »
Solved!

Hi again,
Of course it was me who did something.
It was the whole tab that wasn't enabled. After I checked this it works. See picture.

Thanks for the suggestions  :)

Brian

4
Mach4 General Discussion / Re: Jog buttons are not activated
« on: January 24, 2019, 01:34:27 AM »
Hi,

I will try your suggestion out tonight  :)
I have never used the keyboard for jogging. I always use the buttons on the screen and the mouse.
That is also the ones I’m referring to. It’s something that has happens since I upgraded and reinstalled Mach 4 (and maybe I have touched something  ;) )
I Will check if the keyboard input plugin is enabled, I can’t recall.

Brian

5
Mach4 General Discussion / Jog buttons are not activated
« on: January 23, 2019, 03:52:06 PM »
Hi

I have a weird behaviour on my Mach 4.
When I start Mach 4 and "Activate" and the try to Jog, then the jog buttons are not active.
I have to go into "Edit Screen" and then exit "Edit Screen" again. The they are active.
So I don't edit anything, but just go into "Edit Screen".
This is quite annoying. 
I have tried to insure the button are active as a standard setup for the Jog buttons.

Any ideas?

6
Mach4 General Discussion / Can't set machine position in script
« on: January 23, 2019, 03:41:40 PM »
Hi

I have made a button to save the machine position and work offset position into the register. This works!
I have also made a button to load these positions again. It works for the work offset position but not for the machine position.
I use the mc.mcAxisSetMachinePos but it doesn't seem work.
I the ScreenScript.lua there is a WriteRegister & GetRegister function.

Any ideas?


Pages: 1