Hello Guest it is February 28, 2021, 02:40:01 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - GeneYo

Pages: 1 2 »
1
General Mach Discussion / Re: Strange X Axis Moves and Hot Keys in Mach3
« on: January 17, 2009, 02:47:43 PM »
I dug out my old computer and now everything is working fine on an older Mach3 release.  Weird!!

Anyway it works.  Thanks for the help.

2
General Mach Discussion / Re: Strange X Axis Moves and Hot Keys in Mach3
« on: January 17, 2009, 02:21:28 PM »
I made this change and it did not do any major improvements to the axis.  Maybe its slightly better but still running very jumpy and erractic.  It's always the same axis as I can change around the wiring and it changes the motor which is running erractic. 

I've changed out everything except the computer.  I have a backup computer and will drag that out as it's the only thing that it could be.  When I said I changed out the Xylotex box I actually got a completely different setup so a different power supply, etc. 

Also, I'm using what you suggest but still not able to get the motors to turn in idle mode.  I think my old computer had Mach2 so maybe that will work.

Any other suggestions?

3
General Mach Discussion / Strange X Axis Moves and Hot Keys in Mach3
« on: January 16, 2009, 11:31:58 PM »
I used Mach2 before and getting my feet wet with Mach3.  I have a new setup and have a couple very weird problems that I cannot understand.  Maybe someone can point me in the right direction?

1. The X axis on my system is not smooth when I use the up / down keys for moving in the Motor Tuning setup menu.  It's always the X axis and if I have confirmed it's nothing to do with the stepper motor as I have moved them around to different X, Y, Z outputs and even (believe it or not) changed out the main Xylotex board because I thought it was bad.  Nope, it wasn't bad.  I reinstalled the latest version of Mach 3 and still the same thing.  Also, I changed out the printer / LPT1 cord.

What happens in motor tuning is the X axis runs erratically and sounds like something is terribly wrong.  However when I run a G-Code program it then sounds normal.  This is driving me bonkers and curious if anyone has seen this before?  Or has any good suggestions?

2. This is probably a dumb question but I cannot get the Hot Keys to work.  I went into the Config and set them up, i.e. you push X and it gives it a number such as 88 or whatever.  When I go into the regular screen and then push X nothing happens.  What am I missing here?  I'm guessing there is some magical button or check mark here?  Could someone please point me to the right direction.  I could set this up (almost) in my sleep in Mach 2 but not getting Mach 3 just yet..

Thanks for your help and suggestions which hopefully don't include that I'm a stupid user!!

4
General Mach Discussion / Mach3 Setup Question and Estop
« on: December 24, 2006, 10:58:01 AM »
I've been a user of Mach2 for well over a year and decided to upgrade to Mach3.  I have Mach2 and Mach3 on the same computer.

I have spent hours and hours reading this forum and trying different setups but cannot get Mach3 to do anything.  First I had the Estop problem but changed that to Active Low so now I can control the software on my screen but the motors won't turn.

I've gone through the Motor Tuning and Ports Pins connections several times making sure my Mach2 and Mach3 port pins configs are the same. 

Also, I managed to setup something so when I push a hot key it will only step 0.010" per push.  Any idea what I did here?

I am using a Xylotex 3 axis board which is about 6 months old.  My computer is a Dell  using XP at 2.4 ghz.

Anyone have any ideas??  I'm certain my motors ports pins are correct.  I wonder if the Estop is what's the problem but it appears to work on my computer screen.

5
Yes, I have the C11 Multifunction CNC Board from www.cnc4pc.com .. This has TTL outputs on it.  I haven't hooked it up yet but it's basically plug and play.

6
Excellent info...  Now if I can figure out the next step.

I found the 'Z is 2.5D on Output #6' in the State settings under the Config pull down menu.   

Any idea on how to implement this?  And does Output #6 mean?  I wonder if Output #6 ties to the LPT1 port or what..

On the laser you have does it use a + and - for the TTL input on the power supply?  Or is it just a 5V+ input.


7
On the internet there are a few people who are controlling CO2 Lasers with Mach2 / Mach3.   These laser power supplies have a 5+ volt TTL inputs which tell them when to turn on/off. 

Can anyone explain how they're sending these signals?  As an example when you move from one cut to another the laser needs to turn off and then back on. Otherwise all of your rapid movements would leave a visible laser mark.

All I can figure out is to cue off the Z axis movement which I know is wrong.  I was told that people may use the spindle for controlling the laser TTL inputs but not sure how that works?  I thought in spindle control it would just turn on when you hit start and run until the complete job was finished which wouldn't work for controlling a laser.

Any help would be greatly appreciated. I'm wanting to buy my first laser and work it with Mach3 but can't figure out how to accomplish that one step on controlling the lasers TTL inputs..

8
General Mach Discussion / Re: Laser Control using Spindle Controls
« on: August 21, 2006, 03:49:35 PM »
I decided to go to the source and asked Art directly.  He said most people were using the spindle speed control to send a pulse to the laser.  I guess as you increase the speed of the spindle it will tell the laser to amp up or down. 

Now has anyone used Mach2 or Mach3 to control the spindle?  Does it require a breakout board and how would this connect to the actual computer itself or would it connect via a LPT1 connection?

9
I looked at the links and it appears a couple people are using Mach2 or Mach3 but there was no mention of how they are interfacing.  I probably need to find someone who's actively using Mach2 or Mach3 with a laser.  Worse case if I don't get any addt'l replies I'll post on the other site you provided.  Thanks!!

10
 ???Hopefully someone in this forum knows the answer or can point me in the right direction.

I'm wanting to use a laser for engraving.  The power supply or laser driver module has TTL inputs that apparently will electronically modulate or change the amp level going to the laser.

1. On the Artsoft website it does mention the ability to control a laser but curious where that's located within the software and how it works?  Is anyone using this feature?
2. I've got a 3 Axis CNC setup right now on my router I plan to convert over to a laser engraver.  Is there something like a breakout board necessary to control a laser with TTL inputs via Mach2 / Mach3 or do I need to buy a new 3 axis driver board that is setup for additional outputs such as TTL?  Or is this completely seperate and it doesn't matter what 3 axis driver board I use?  And is there any recommendations on where to get this board (driver or breakout) / power supply / matching Nema 23 stepper motors if I do need to purchase a new board with TTL inputs / outputs?

Drum roll...  Anyone got some answers?   :o

Pages: 1 2 »