Hello Guest it is August 02, 2021, 06:08:22 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - rndpig

Pages: 1 2 »
1
Mach4 General Discussion / Re: limit switch config
« on: April 23, 2018, 07:20:57 AM »
I've installed a total of 3 NC mechanical limit switches that will serve as the limit- points. No limit+ switches nor home switches have been installed. My intent is to only ensure that the gantry doesn't crash into the CNC housing, which is where there are only limit- switches in my setup.

2
Mach4 General Discussion / Re: limit switch config
« on: April 22, 2018, 09:25:12 PM »
Craig,

I've only installed limit- switches for now, and these will double as home switches as well. I will ultimately use soft limits for limit+ boundaries, so I'm really trying the simplest of setups. I'm needing input from someone who knows both Mach4 and the Pokeys interface when it comes to the pulse engine. These are the settings that are throwing me right now, though I'm glad to have continuity on the NC switches that I've wired.

rndpig

3
Mach4 General Discussion / limit switch config
« on: April 22, 2018, 12:37:58 PM »
I'm running Mach4 with the Pokeys57CNC board and I recently wires limit- switches for X, Y, and Z axes. I'm now having trouble configuring the switches in Mach4 and I could use a little assistance. All 3 limit switches are wired NC and I've already checked continuity, so I know the wiring is correct (switches are wired in parallel, by the way). I connect the limit switch wires to the Pokeys57CNC board via a DB9 connector that translates to the 20 pin flat cable IDC socket connector that plugs into the dedicated port on the Pokeys board, and I've checked that wiring from the DB9 connector to the 20 pin connector on the Pokeys board has correct continuity as well. Therefore, I believe I'm solid on the hardwiring aspects and my issues all lie in Mach4 software configs.

When I start Mach4, I immediately get a "Limit switch -- tripped!" warning for X, Y, and Z axes and that prevents the Pokeys pulse engine from starting and functioning properly. Again, this tells me that I have a software config issue that is preventing proper communication. Could someone walk me through what Mach4 settings I should be using both in Configure > Mach...? Do I need to focus only on the Output Signals tab here? Also, what about settings in Configure > Plugins... > PoKeys plugin - PoLabs? I assume all focus here is on the Pulse engine page settings, correct? I currently have all the Limit- switches set to Ext. dedicated as specified in the Pokeys documentation.

When I get through all of these, I hope to have created a tutorial for others to follow as this has been really challenging to work through! Any advice provided is greatly apprecaited.

rndpig

4
Craig,

Thanks for the reply, and I'm sorry that the thread went a little off-topic here recently. I will say that being a novice, I've learned far more by having to really dig into the hardware/software, which is in contrast to the sentiments being expressed recently.

I will ensure that the steppers are set up for microstepping, but I believe I'm missing a few set screws to connect the stepper motors to the leadscrews. I'm trying to figure out the setscrew specs now, but when I sacrificed some from another axis, the X-axis motion issue appeared to go away. Thus, I'm beginning to conclude that this was a hardware issue all along.

Regards,

Ryan

5
PoKeys / Re: Mach4 spindle control - no voltage through pin 17
« on: March 11, 2018, 09:10:24 AM »
Thanks, NeoTO. That was the ONE thing I neglected to try, and entering 24,000 maxRPM for spindle 0 immediately fixed the problem. Are there any other settings on the Mach config spindle page that I should worry about? Accel or decel time? Max spindle motor RPM (default is 3600)?

Ryan

6
PoKeys / Mach4 spindle control - no voltage through pin 17
« on: March 10, 2018, 06:11:20 PM »
I'm banging my head against the wall. I've followed the Pokeys57CNC/Mach4 guide and feel like I've got all the settings correct, but I'm not getting any voltage out of pin 17 to control the speed of the spindle through the VFD. In the Pokeys config > miscellaneous, the 'Enable PWM outputs' box is checked (freq set to 20000 Hz), the pin 17 enable box is checked with default (%) set at 0, and the Spindle output dropdown is set to Pin 17 (set to 0 when OFF is checked). Is there anything else I need to do to have Mach4 tell the Pokeys57CNC to send voltage through pin 17?

Ryan

7
PoKeys / Re: spindle direction on Pokeys57CNC
« on: March 03, 2018, 12:14:00 PM »
NeoTO,

Thanks for the reply, but I was hoping for a bit more help. Can you confirm that there is no native pinout on the Pokeys57CNC that is designed to control spindle direction? If so, then I'll continue working on how to control spindle direction using the optocoupler outputs mapped to Mach4 as specified in the PoKeys57CNC and Mach4 step-by-step guide (pages 18-21).

Ryan

8
PoKeys / spindle direction on Pokeys57CNC
« on: February 26, 2018, 01:39:43 PM »
I'm trying to configure my Nowandforever E-100 VFD to work with the Pokeys57CNC, but I don't see anywhere in the board specs where I can wire the VFD to receive this information. I'm currently using the GND and pin 17 on the galvanically-isolated I/O bus, but pin 14 (labeled spindle error input) doesn't seem to be what I need. The spindle won't run until I give the VFD a closed circuit in terms of spindle direction (i.e., I have to have this in order to control the spindle from Mach4). Am I missing something here? Do I need to use one of the on-board relays to give me Mach4 control over whether the spindle is engaged? If using a relay is necessary, what output pins are associated with the relay? And can I map that relay between the Pokeys57CNC and Mach4?

Help for a newbie is greatly appreciated.

Thanks!

Ryan

9
As time allows, I've made good progress on getting my setup working. Based on submitted feedback, I've added a Pokeys 57CNC motion controller board that communicates with the original JP-3163B stepper driver via a custom cable (see attached photos). I've been able to print mounts that still allows me to use the original controller housing, but I'm having a few issues getting smooth control over the CNC.

At this point, I can control the Pokeys board via Mach4 and when I send MDI commands, they're being transmitted by the Pokeys57CNC motion controller and relayed through the JP-3163B stepper driver. However, just doing a test on the x-axis runs, the motion appears to be jerky or not smooth when I use a feed rate less than 50. With help from an engineering colleague, I've been messing with the counts per unit (i.e., the steps per unit) for the x-axis motor, and while I don't know the exact specs of my leadscrews,  I've pretty much got it dialed in to get the correct distance per input I provide in the MDI code. My problem is that I can't figure out why I'm not getting smooth motion when testing the x-axis.

I've convinced myself that this isn't a hardware problem because I have a direct drive setup and the stepper motor isn't physically slipping on the leadscrew. As I try to diagnose the issue, I've noticed that the jerky motion isn't consistent from run-to-run, but it is certainly much worse when I use a slow feed rate. Any feed rate less than 50 and I'm sure to lose distance moved because the motion hesitates at some point. In the attached video (http://www.amazon.com/photos/share/LzcklOx62Hd6FQ00eDM10hM5eXv15WHFSIYEV0rsoyw), you can hear the hesitation (low hum goes away during hesitation). I tried to keep my phone still while recording, but there are places in the 30-second video where you can see and hear the problems I'm having.

Any ideas of what may be going on? Could it be that the Pokeys57CNC motion controller is sending commands to the JP-3161B stepper driver too quickly? If so, what would I need to change in the configuration? I didn't find an option in the Pokeys plugin config that allowed me to change the baud rate or even change the communication speed. When I used the Pokeys diagnostics tool, it appeared that the communication was never more than 25% of max, so I'm really at a loss here.

Any ideas?

Ryan

10
Craig - I’m in the US and while I appreciate your generous offer, I’d rather replace existing junk with higher quality components.

I’m going to get some local engineering eyes on my situation and I’ve passed this thread to my local contact so he can help me make a decision. It seems straightforward to purchase a motion controller with expansion capacity and then gain CNC experience before replacing steppers down the road.

You’ve all been great and thank you for being so responsive all day today. I’m watching some good football while typing this post, so I’ll sign off and bid you all a good night.

Pages: 1 2 »