Hello Guest it is October 19, 2020, 11:58:33 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Yorkshire Pudding

Pages: 1
1
Mach4 General Discussion / Re: PMDX-422 help please
« on: June 18, 2020, 02:10:24 PM »
Thanks again,

now I am happy the supplied kit works I can install it in the machine and then fine tune it.

Here are the pictures of the switches.
 

2
Mach4 General Discussion / Re: PMDX-422 help please
« on: June 18, 2020, 11:55:37 AM »
Thank you for the help.

I have the drive wired as shown and I now have a new question.

If I enter G01 G91 X1. F10. and cycle start the drive steps round and the white line on the knob stops at the point it started,  if I change the F10. to F20. the same but quicker.  If I change it to F30. the shaft is jumping back and forth and stops in random places.  Change it to F40, 50, 100, 200 even 300 and its spot on again.

Setting are steps/per 200
Velocity 2000
Accelaration 100
Driver set to 1:1 stepping

My question :- do steppers have a no go speed?

Also is it possible to attach video to the forum?

Thanks
YP

3
Mach4 General Discussion / PMDX-422 help please
« on: June 17, 2020, 08:21:51 PM »
Hi All,

I purchased a basket case router that has a PMDX-422 Rev A1 and 3 4A drives for the steppers.

Nothing was connected to the machine so I decided to test the PMDX and drives before I started the rebuild.

I have a updated the PMDX and installed Mach4 Hobby demo version and the PMDX seems to be working.

I have a 24V psu connected to one drive and the moter connected to the drive.  The PMDX is USB powered.

My question is how do I connect the 4 inputs on the drive to 3 outputs on the PMDX and what should the 3 way jumper be set to +5V or GND and do I need to common the whole lot together somehow.

Thanks for your help, I am not daft just confused by new terminology.
YP

4
Thank you Klaus for the PM and getting me sorted.

5
Hi Klaus,

thank you for the reply, I have the LED sorted.

My problem now is how do I select the global background image and the tool path on page 3 to make the toolpath come to the front?

Thanks,
YP

6
Thanks for the help so far but I need a bit more.  I have the LED issue sorted but no matter what I do I can not get the toolpath window on top of the background image.

The background image is on page 0 and the toolpath is on page 3 and is hidden behind the background.  I have tried in Screen4 to move the images to back and had it in Machscreen but nothing seems to work.

Any help much received.

Thanks
YP

7
Hi All,

I have made some LED buttons in Real Draw and exported them as PNG's with transparency, in Machscreen they look good with a clear background but when I load the screen into Mach3 I get a black background not the transparency.

Can you give me any idea what I may have done wrong.

Thanks
YP

8
Why not try :-

G00 X6.5 Y6.5
G03 I-6.5 F100.
G00 Z15.

Pud

9
Mach Screens / Can I swap an image in a Mach3 screen
« on: January 19, 2017, 02:53:33 PM »
Hi All,

is it possible to swap 2 images in a screen depending on a button press so one is shown if the button is on and a different one if the button is off and if so how can it be done?

Thanks for any help.
Pud

Pages: 1