Hello Guest it is December 04, 2020, 06:05:38 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Paul G

Pages: 1
1
General Mach Discussion / Re: How to setup MACH3 for dual parallel port
« on: October 31, 2016, 12:18:54 AM »
Can anyone set me straight on how to set up PWM spindle control in MACH3.

Ok - i have axis moving now with keyboard manual control and via MACH3 commands :), and Estop enabled.  I think i have the charge pump working (not quite sure).

Next is the spindle control.  Question is how to set it up properly in MACH3?
Machine config:
HW wise -  it should be all setup correctly (well meaning it worked for previous MACH3 XML that i don't have access to):
  -BOB is sound logic -PC2 Rev 3.
  -PDMX-106 spindle controller - is PWM, and i suspect relay for direction control.

  -PDMX instructs to use Output Pin 14 for direction and Pin 16 for PWM.

  -I've read the MACH 3 manual and from that - am totally confused.

  -I have enabled the spindle in "ports and pins/axis" with pin 14/16. and enabled PWM in the "ports and pins/spindle setup".[/left][/pre][/left][/center][/left]

Can anyone set me straight on how to set this up in MACH3.


2
General Mach Discussion / Re: How to setup MACH3 for dual parallel port
« on: October 10, 2016, 01:29:44 AM »
Thanks.

I'll look into this.  Is there a standard pin configuration that is commonly used for pin assignments - i.e. most MACH3 has default settings and most people would just use those when setting it up?

thx,

Paul G

3
General Mach Discussion / How to setup MACH3 for dual parallel port
« on: October 09, 2016, 02:56:28 PM »
Hi - I'm new to CNC and could use some help getting this machine going.

My specific question is - connecting PC parallel ports from PC to machine - does it matter which one is connected where?  Or just connect them and then configure in MACH3 settings?

The machine is a Light Machines 2000 and it was previously retrofitted with Gecko G320X-DC drivers, a Sound Logic BOB, and Mach3 that was connected from PC to machine by 2 parallel ports and all was good per PO.  The did not have the PC at the time i purchased.

I have build a PC, installed MACH3, the PC has one parallel port on the mainboard IO panel and it has a second parallel port on the PCI parallel port adapter card  (that was on the previous PC that ran this machine). I am running on Windows XP.

I have read the MACH3 manual where it states 2 parallel ports can be used, but there is no documentation on connecting parallel ports to the BOB or other interface or which parallel port to use for which - or does it matter.  The first parallel port in the pictures goes to the pendant, the other two are the 50/50 guess.


Can anyone point me in the right direction big picture of things i may need to think about, perhaps advice on connecting the parallel ports or if there is a good thread or tutorial to shed light on this.

Thx,

Paul G

Pages: 1