Hello Guest it is December 08, 2019, 08:56:24 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - OzzieII

Pages: 1 2 3 4 5 6 7 »
1
Newfangled Solutions Mach3 Wizards / Re: NFS Turn Wizard
« on: June 19, 2014, 03:44:42 PM »
Hi Ron,
I downloaded the Turn Wizards latest version and played with it for a while.
Some things I noticed:
The feed Dro at the top won't accept an entry.
I can enter a feed under the tool tab but the wizard doesn't enter a feed in the G-code it creates.
The G94/G95 at the top of the screen does put the machine in that mode but the command doesn't show up in the code.
Ozzie

2
Newfangled Mill Wizard / Re: Pointer to current version
« on: November 17, 2013, 12:21:39 PM »
Ron,
I just downloaded .13 to replace .6.
I notice that it is a smaller download, please explain.
Also I see that one of the additions on your log is the ability to send code to Mach 4, but I don't see where this is facilitated.
Thanks,
Ozzie

3
PoKeys / Re: Adventures in Pokeys ---- Working
« on: August 15, 2013, 12:34:41 PM »
It has been just over a month since this forum has heard from NEOTO.
Scott "PoppaBear" has helped some here, including a private message to me. Thanks Scott.
From time to time, I've continued to tinker with my Pokeys powered console. The most recent of my problems to solve were:
Keyboard hotkeys no longer working at all.
Noise changing axis dros.
Noise changing FRO dros, extreme.
C axis jog not working correctly.
Confusion about how the Mach 3 plug-in and the native Pokeys program interact.
----
I decided to rebuild my Mach 3 Pokeys setup.
I suspected that the hotkey problem might be related to using the keyboard as a usb unit. I connected it to the standard keyboard port with an adapter. As I rebuilt the Pokeys setup I kept checking the hotkeys; they are still working.
I suspected that the axis dro noise might be from the the Wingman joysticks I was using. Posts on other forums, gaming forums, suggest that those analog joysticks are difficult to tune and stabilize. So in the new setup I eliminated them. The axis dros are now dead steady.
The FRO noise was hard to repeat, it would stay steady for long periods of time then suddenly leap to thousands. Since everything else looked steady I decided it was a bad unit or the associated wiring. I bought a couple new encoders from Ebay; I think the same units that Paul Tegler has. I used a more secure type connectors in rewiring them. So far the dro looks steady, but I want to test longer.
I want to power the knee on my milling machine so I have two jog buttons for a C axis on my board. I  tried to set it up the same way I did the X,Y.Z, and A axis jog buttons, but when pressing and releasing the button, the axis would continuously move until I press the other direction or escape. I tried to set it up as B axis; same result. I tried creating hoykeys for the C; that works. After playing with Pokeys for a couple hours the C jog buttons now work, but I'm not sure what I did to it. It is certainly not straight forward.
I believe some of my problems come/came from not understanding the interaction between the Mach 3 plug-in and the Pokeys stand-alone. Somewhere I read that a setting in the plug-in would override a setting in the stand-alone. I'm not sure that is totally correct. In getting things to work here I made sure I did not have a setting in both. One might think that if you don't have the stand-alone running, it has no effect, that is not correct. To set up a keyboard emulation I set the plug-in for that pin to inactive and then route the pin in the plug to a keyboard emulation. That works even though I don't start the stand-alone in a session. I set an emulation for "shift" (for rapid jogs), and that always works. Part of what I did to get the C buttons to work was to clear the pin settings in the stand-alone.
--
So my Pokeys powered board is working! No joysticks, still testing the encoder, but it is working.
I should end this on a bright note but I'm compelled to bitch about the lack of public support and the deplorable documentation from the Pokeys people. And I might add that no one from Artsoft made any attempt to help. I think that if you support a plug-in, you share some bit of responsibility.
--
I run both milling machine and lathe from one computer, one instance of Mach 3. I tried enabling Pokeys on my lathe profile, but the Milling machine settings come up, leading me to believe that I can't use one Pokeys unit for both machines. If mach 3 would arrange storage of the Pokeys plug-in tied to a machine profile, I could use a different set of settings; get the use of Pokeys on more than one machine. I think that would work?
Ozzie

4
PoKeys / Re: Adventures in Pokeys
« on: July 24, 2013, 05:03:56 PM »
Hello MR,
If you would sign I could address you properly.
Anyway thanks for your encouragement though I hardly think I need it. This isn't my first rodeo, as they say. I've followed along with Art as he developed Mach since the beginning around 2002; even was able add a couple cents worth here and there; found a couple major bugs. I've been published in Digital Machinist and Home Shop Machinist 10 times, my stuff on the cover twice.
I fumble through the wiring and electronic stuff I need to make my machines run, but electronics are pretty much a mystery. I see that in this new issue of Digital Machinist there is a big article centered on the Arduino. I speed read it and I will read it thoroughly, but I saw enough to know it is way over my head. There are far too many words totally foreign to me, abbreviations, initials. I'm sure the author thinks it's very fundamental, but it 'aint baby; not for this old dog.
Before I bought Pokeys I was about to create a control console using Mach's KeyGrabber and a couple Wingman jotstick controllers; I should have stayed on that path. For me that's easy, take it apart, wire switches, pots, looks totally pro.
However with the help of Matevz I led myself down a path that looked golden but now seems more gravel.
Pokeys is cheap and it is probably a good product; ,,,,,,,,,,,,,,,,,for someone smarter than I.
Arduino is cheap and maybe better than Pokeys; for someone smarter than I.
I wouldn't need to be smart if the docs were better. It took me about 10 minutes to get my Ethernet Smooth Stepper running. Hook this up here, run this wire, on the computer do this, etc. etc., etc.
My uneducated thought is that both Pokeys and Arduino are electronic black boxes that can do many and varied things. For me to make use of them I need someone to make them Mach specific, which may be as simple as writing a PDF. Problem is, how do you make a buck doing that.
I am surprised that Pokeys has a plug-in for Mach, but that no one from Mach is chiming in here on this Mach support forum! The docs for that plug-in are as bombastic as the regular Pokeys manual.
Hey, I still have my keyboard and mouse which work fine, a half dozen of my custom screens which work fine; along with a pretty board full of buttons and knobs.
Ozzie

5
PoKeys / Re: Adventures in Pokeys
« on: July 22, 2013, 08:11:16 PM »
Scott Baby,
That's so easy for you, impossible for me.
I need explicit directions; buy this, do this, wire this here, etc, etc.
I tried to learn a little electronics a while back; it was all about vacuum tubes and stuff. I gave up.
Don't spread it around but I don't really know what an Arduino is. Sounds like a new hot Italian chef.
I have no idea how many Pokeys customers there are or who is interested in this sort of thing. I've operated Mach for a very long time with just a keyboard and a mouse, (and I will probably continue to do so for a while). But if there is a market Poppa Bear, I think that you'd be an ideal guy to come out with some package; something electronic dummies like me can deal with.
For those of you that might not know Scott, he's a straight up guy, no BS, been around this stuff long time.
Ozzie

6
PoKeys / Re: Adventures in Pokeys
« on: July 22, 2013, 11:19:23 AM »
No posts from NeoTo/Matevz for 9 days. At that time he asked for individual contact. It is strange that rather trying to help anyone reading these posts he prefers to keep it private. Maybe they'd like to abandon this forum, maybe he's just on vacation. ;D
I have not been able to solve my noise problem, axis DROs just suddenly move while system is sitting idle.
My keyboard jog buttons do not work since installing Pokeys; even if I disable Pokeys.
Some sort of response would be nice, even to say we don't know.
Ozzie

7
PoKeys / Re: Adventures in Pokeys
« on: July 15, 2013, 02:20:13 PM »
Following Paul's instructions I succeeded in upgrading the "stuff". So far I haven't noticed any differences. For Paul it is a different story, good.
My keyboard hotkeys still do not work but all that was there is now on my control board, so if I decide to continue with Pokeys that won't be a problem, (just a question as to why).
I got all my buttons routed but two, (wired in parallel), they were to be "shift" keys for my jogging buttons. I can not find a way to do that on the plug-in inside Mach. But there is on the Pokeys setup. At first I couldn't get that to work, seemed to have no effect, but eventually worked. You must disable the button in the plug-in, enable the keyboard equivalent in Pokeys, send to device, then restart Mach 3.
So this morning I've played around trying all the buttons and knobs and the joysticks, tried running a g-code dry, no servos running. All seems to work okay, BUT, one really scary thing is that once in a while one or more Dros change without apparent reason. Those that change are the axis and the FRO, not insignificant. The FRO changes by monster amounts and the axis by tenths or thousandths. I realize this is noise/cross-talk but I don't know the source or how to find it. I do notice that every time I make a change in either setup this axis dros go crazy. I guess I'll check all the wiring connections, but beyond that I'm stuck.
I want to get back to machining stuff, I'm tired of playing electronics about which I know nothing. I wish there were more people on this site, contributing either their successes or failures and advice.
Ozzie

8
PoKeys / Re: Adventures in Pokeys
« on: July 13, 2013, 07:24:26 PM »
Thanks Paul,
It's comforting to know you've got it going. I'll get back at it tomorrow, (calmer now).  :P.
I did manage to get back to where I was before I tried the new plug-in.
Ozzie

9
PoKeys / Re: Adventures in Pokeys
« on: July 13, 2013, 01:03:37 PM »
In the past hour I've gone from aggravated to infuriated.
I've tried everything I can think of to make this work to no avail.
Okay, as I said above, it's not supposed to be a puzzle and I've wasted way too much time and money on this. I made an expensive mistake, Pokeys, switches, push buttons, leds, joysticks, etc.
--
The thing that infuriates me is that although I've done all I know to totally remove Pokeys from the system, it has somehow modified my screenset so that now my hotkeys do not work. I say screenset because if I go to the standard set the hotkeys do work. ?????? I have no idea how to fix this. Nor can I imagine what has happened. Both screensets have the same profile, (XML).
--
Additionally I believe the device was messing with my Ethernet Smooth Stepper. During the approximately dozen times I started and re-started Mach trying to fix the problem there were three times that Mach could not find the ESS. Only un-powering/rebooting the ESS fixed that problem.

Ozzie


10
PoKeys / Re: Adventures in Pokeys
« on: July 13, 2013, 11:47:11 AM »
CRAP!
I replaced the old .dll with the new, now Mach says it can't find Pokeys. I tried to reconfigure, says it can't find Pokeys !!!!!!!!!!!!!!!!!!!
What now?????????
Aggravated Ozzie

Pages: 1 2 3 4 5 6 7 »