Hello Guest it is November 18, 2019, 01:35:22 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - qwertysimo

Pages: 1 2 »
1
General Mach Discussion / Re: Machining time or run time
« on: February 24, 2018, 07:00:46 AM »
I daresay it is a shame that simulation option was removed from M4.
With all information about machine and gcode available, what else is needed to output very precise runtime estimation?!

Thanks Craig.

2
General Mach Discussion / Re: Machining time or run time
« on: February 24, 2018, 04:49:32 AM »
Hi,

is there a way to get an estimate of the runtime for a file once it is loaded into Mach4?

I cannot find simulate option on Toolpath page in any screen.

Thanks.

3
Mach4 General Discussion / Re: M code macros do not run
« on: September 21, 2017, 03:34:38 AM »
Anyway, isnt it a bit strange?
Lua scripts assigned to on-screen buttons work OK even without the plugin enabled.
What is different with macros placed in Macros folder?

4
Mach4 General Discussion / Re: M code macros do not run
« on: September 21, 2017, 03:30:45 AM »
Craig, it is not the "G code file editor" issue! Meanwhile I found this:

Enable the mcLua plugin. 

Steve

After enabling the plugin, Operator/Edit-Debug scripts opens my script in mcLua editor as expected and all mcs files were compiled upon Mach4 startup.

Craig, Steve, thanks!

5
Mach4 General Discussion / Re: M code macros do not run
« on: September 21, 2017, 03:22:27 AM »
I did another test. I deleted my Macros folder from C:\Mach4Hobby\Profiles\QR\ and copied Macros folder from C:\Mach4Hobby\Profiles\Mach4Mill\

The same problem, No script engine found for C:\Mach4Hobby\Profiles\QR\Macros\m111.mcs

6
Mach4 General Discussion / Re: M code macros do not run
« on: September 21, 2017, 03:12:43 AM »
if you go Operator/Edit-Debug scripts the list of scripts in your profile will be displayed, a very simple test to prove that the file has been placed correctly.

First, I loaded default unmodified Mach4Mill profile. Operator/Edit-Debug scripts menu item opened a file selection dialog window showing content of C:\Mach4Hobby\Profiles\Mach4Mill\Macros folder.
When I selected my testing macro named m111.mcs, mcLua editor opened and I could successfully compile and debug my macro.

Then, I loaded my profile named "QR". Operator/Edit-Debug scripts menu item opened file selection dialog window showing files in C:\Mach4Hobby\Profiles\QR\Macros.
Here comes the problem. When I select m111.mcs, mcLua editor does not open! Instead, Mach4 displays this message in status bar:
No script engine found for C:\Mach4Hobby\Profiles\QR\Macros\m111.mcs

Files m111.mcs placed in Mach4Mill\Macros and QR\Macros are the exact copies, with the same name, file extension and content.

Any idea?

7
Mach4 General Discussion / Re: M code macros do not run
« on: September 21, 2017, 01:12:48 AM »
Hi Craig,

as I wrote, "Mach4 ignores all mcs files in my C:\Mach4Hobby\Profiles\QR\Macros\ (profile name is QR)", this is not the issue.

Other ideas?

Thanks.


Boris


8
Mach4 General Discussion / M code macros do not run
« on: September 20, 2017, 05:21:50 PM »
Hi,

this might be a trivial issue but I cannot figure it out. Mach4 ignores all mcs files in my C:\Mach4Hobby\Profiles\QR\Macros\ (profile name is QR). Bottom of wxMach screen shows active profile QR.

I created m111.mcs for testing with this content:
Code: [Select]
function m111()
wx.wxMessageBox( "here" )
end

if (mc.mcInEditor() == 1) then
m111()
end
After running m111 from MDI nothing happens.


I copied m111.mcs to \Profiles\Mach4Mill\Macros, loaded Mach4Mill profile and the macro works. Mach4 upon startup also compiled mcs files in folder and corresponding mcc files appeared in the same folder. This does not happen with my QR profile.

Please, can you advice how to fix this? It looks like it is related only to my custom profile.


Thanks.


Boris


Best regards
Boris

9
This problem has been discussed in warp9td forum and already fixed. Upgrade your ESS plugin from 206 to latest version.

10
Modbus / Re: Mach4 and modbus - help needed
« on: September 27, 2016, 01:41:11 AM »
BUMP

Another question - modbus function 0x10, write multiple registers. How to enter several integers in one command?
mc.mcRegSetValue( number hReg, number value )
How to specify "value" to represent several integers for multiple registers?

Pages: 1 2 »