Hello Guest it is October 18, 2019, 10:52:14 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Programinator

Pages: 1 2 »
1
Thats the way it should work but my cam is not doing that right.  I have safe z set to 1.5 for example and then z to start at .1  it ignores the .1 and puts all the retract z moves during the program to z.1 which is a big waste of time because it has to feed from there all the way down.  So at any rate i decided to do it this way instead.

But you are right about sitting that up in cam.  must be a bug or something with artcam

2
Ok let me try to clear it up.....

Say i get done running the first tool.  I have my part clamped down and the clamps are thicker than .1

I jog my spindle off the part so i can change tools.  Then load program for next toolpath.

If i had it the way it was it would start by going to z.1 then xy which brings those clamps into play.  Of course i could program the safe z to 1.0 or something higher than the clamps but then i would waste time on g1z- moves.

I always have my machine referenced when i start so the g53 line will not be a problem.

So the way i have it setup now no matter where i am it will go to z home position and then rapid to xy zero THEN rapid to safe z which would be z.1 and feed down from there.

Hope that clears up what i was thinking.

Thanks for your help.

3
Well this is what i ended up doing.  a machine coordanate move to z-.1 then xy to work offset move then z

I like it like this because i change tools manually off the part on the xy and if i had a move to z.1 first then xy it will hit clamps.

This way i dont have to worry about it.

I dont understand why the way you guys suggested will not work.  But this way will do the trick

Thanks for your help


; Set up program header
;
START = "([FILENAME])"
START = "(Material Size) (X=[XSIZE], Y=[YSIZE], Z=[ZMATERIAL])"
START = "(Tool Number:[T]) ([TOOLDESC])"
START = "G90G80G20G49"
START = "G90G53Z-.1"
START = "G0[XH][YH]"
START = "G0[ZH]"

;
; Program moves
;
FIRST_RAPID_RATE_MOVE  = "G0 [X] [Y] [Z]"

4
The second suggestion fails to post.  "Duplicate statement found"

THanks for trying

any other suggestions

5

; Set up program header
;
START = "([FILENAME])"
START = "(Material Size) (X=[XSIZE], Y=[YSIZE], Z=[ZMATERIAL])"
START = "(Tool Number:[T]) ([TOOLDESC])"
START = "G90G80G20G49"
;START = "G0[ZH]"
;
; Program moves
;
FIRST_RAPID_RATE_MOVE  = "G0 [X] [Y] "
RAPID_RATE_MOVE  = "G0 [X] [Y] [Z]"


This code posts like this:  Not the result i need.  i will try the other suggestion now
THanks for trying

(text)
(Material Size) (X=39.370, Y=9.840, Z=1.500)
(Tool Number:1) (0.250 inches dia. slot drill)
G90G80G20G49
G0 X-0.5662 Y0.9343
G1   Z-0.1250 F30

6
Yes im sure this is what i want.  I always start my program with the tool above the part.  For my way of doing things this is way better.  Let me know if you have any ideas on how to change it and i can test it out.

Its for artcam

Thanks

7
G-Code, CAD, and CAM discussions / Edit post for xy position move then z
« on: December 25, 2015, 05:33:43 PM »
This is what my gcode is coming out like:

G90G80G20G49
G0Z0.1000
G0 X-0.5662 Y0.9343 Z0.1000
G1   Z-0.1250 F30

I would like it to come out like this:

G90G80G20G49
G0 X-0.5662 Y0.9343
G0Z0.1000
G1   Z-0.1250 F30

This is what my post looks like:


; Set up program header
;
START = "([FILENAME])"
START = "(Material Size) (X=[XSIZE], Y=[YSIZE], Z=[ZMATERIAL])"
START = "(Tool Number:[T]) ([TOOLDESC])"
START = "G90G80G20G49"
START = "G0[ZH]"
;
; Program moves
;
FIRST_RAPID_RATE_MOVE  = "G0 [X] [Y] [Z]"
;
FIRST_FEED_RATE_MOVE   = "G1 [X] [Y] [Z] [F]"
FEED_RATE_MOVE         = "[X] [Y] [Z]"
;
FIRST_CW_ARC_MOVE      = "G2 [X] [Y] [J] [F]"
CW_ARC_MOVE            = "G2 [X] [Y] [J]"
;
FIRST_CCW_ARC_MOVE     = "G3 [X] [Y] [J] [F]"
CCW_ARC_MOVE           = "G3 [X] [Y] [J]"
;
NEW_SEGMENT_POST_TOOLCHANGE= "(Tool Number:[T]) ([TOOLDESC])"
NEW_SEGMENT_POST_TOOLCHANGE= "M3 [S)"
;
; End of file
;
END = "G0[ZH]"
END = "G0[XH][YH]"
END = "M30"
; M30 = program end and rewind

I have tried a bunch of different codes and i cant get it to post like i wans

Im sure its an easy fix.  Any help would be appreciated

Thanks



8
It works in step mode but not in cont mode

9
If i put the keyboard on it works with the arrow keys but i want to be able to use the tablet without the keyboard on.

Any help is appreciated

10
Hi,  I have mach3 setup on my windows surface.  Everything works good with touch screen exept for the jog directional buttons.  Is there something special i have to do to get them to work.

Thanks

Pages: 1 2 »