Hello Guest it is May 28, 2020, 04:03:31 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Poppey_au

Pages: 1 2 3 4 »
1
General Mach Discussion / Re: A axis will only run one way
« on: November 07, 2017, 01:23:06 PM »
Thanks a lot Craig
Your guidance led me to the problem. The dir pin did stay low in both directions. When changing to an other pin on the BOB the problem was solved.
Now all my tools are set and correctly in the tool table and works perfect! :) ;)

2
General Mach Discussion / A axis will only run one way
« on: November 06, 2017, 12:11:06 PM »
Hi,
Quote
I changed the Active Low for the Dir pin, still the same direction.
tends to make me think that the driver is faulty.

Could you explain in a little more detail:
Quote
I also switched the cable and used one of the other drive, still only one direction.

I think that G28 A0 code will send the machine to machine zero via A0. Is that what you wanted?
G28 is not commonly used in Gcode programs.

Craig
I tried the X drive on the A motor but still only one direction.

I want the X motor to home to the home switch by G28. What code should I use. The ATC has a pneumatic cylinder that open than wait a few sec than turn the motor until it hit the home switch. This should happen every time tool no 1 is selected unless the home switch is triggered.
Gaute


Sent from my iPad using Tapatalk
I put in G28.1 in the code than homing works. Than tool no 1 to 8 works ok as long as I go up in the numbers. I can than put in the M code for tool no 1 and than the tool next in the program if I need to go down in number

3
General Mach Discussion / A axis will only run one way
« on: November 06, 2017, 10:20:47 AM »
Hi,
Quote
I changed the Active Low for the Dir pin, still the same direction.
tends to make me think that the driver is faulty.

Could you explain in a little more detail:
Quote
I also switched the cable and used one of the other drive, still only one direction.

I think that G28 A0 code will send the machine to machine zero via A0. Is that what you wanted?
G28 is not commonly used in Gcode programs.

Craig
I tried the X drive on the A motor but still only one direction.

I want the X motor to home to the home switch by G28. What code should I use. The ATC has a pneumatic cylinder that open than wait a few sec than turn the motor until it hit the home switch. This should happen every time tool no 1 is selected unless the home switch is triggered.
Gaute


Sent from my iPad using Tapatalk

4
General Mach Discussion / A axis will only run one way
« on: November 05, 2017, 02:26:14 PM »
Thank you Craig
I changed the Active Low for the Dir pin, still the same direction. I also switched the cable and used one of the other drive, still only one direction.


Sent from my iPad using Tapatalk
I have a limit switch in the ATC that is set for tool no 1. In the macro I have Code("G28 A0") to home tool 1 this do not work. The switch is set as home for motor A. Is the G code wrong?


Sent from my iPad using Tapatalk

5
General Mach Discussion / A axis will only run one way
« on: November 05, 2017, 02:15:43 PM »
Thank you Craig
I changed the Active Low for the Dir pin, still the same direction. I also switched the cable and used one of the other drive, still only one direction.


Sent from my iPad using Tapatalk

6
General Mach Discussion / A axis will only run one way
« on: November 05, 2017, 12:10:57 PM »
I use the A stepper motor on my lathe ATC to turn the 8 tool turret.
Tool no 1 is set to 0, tool no 2 is set to 25.5 etc. Everything works well if i go from tool 1 to tool 2 until tool tool 8. Then problem starts when going back to tool 1, the turret continue the same direction, not in reverse. After the tools will not end up where it should.
It is Mach3 turn with paralell port. X and Z axis works well.
What have I done wrong?


Sent from my iPad using Tapatalk

7
General Mach Discussion / Re: Tool setting changes Mach3 Turn
« on: October 07, 2017, 04:54:10 AM »
I had the task manager up when running a taper program and CPU and memory was hardly in use. Something else must be wrong.
Funny thing. Axis position suddenly changes from X +23 to -18.5 Z 0 to +42,73

8
General Mach Discussion / Re: Tool setting changes Mach3 Turn
« on: October 07, 2017, 02:18:17 AM »
Still having the problem. I run an old PC may be this is the problem?
Processor is 2387 Mhz
Total Physical Memory 1 024,00 MB
Available Physical Memory 453,42 MB after the tool setting changed.
Tool setting goes lik X +14 to -28 Z from 0 to +88 meaning crash if the emergency button is far away.
I have two parallell ports in the PC, LPT2 is used only for the two MPG wheels.

Any suggestions?

9
General Mach Discussion / Tool setting changes Mach3 Turn
« on: October 04, 2017, 02:19:43 PM »
Hi
I have an issue. My cnc lathe has an 8 tool ACT. The tool table is set with tool no 1 as the master.
Normally every thing works perfect when canging tools but; i run the Mach 3 wizzard, save, post the code and run the code. Evrything is ok. Than I go back and do som changes in the wizzard , save, post code and than the tool setting is completly wrong. No toolchange has been done. Same tool in the DRO as well.
Than I restart the PC, set master tool and every thing is ok again.



Sent from my iPad using Tapatalk

10
General Mach Discussion / Re: Threading Wizard
« on: August 27, 2017, 10:01:11 AM »
Hi
I have removed the USB card and put in two parallell port cards. This solved the treading issue but I have some problems with the speed control. I have a Vacon VFD vit 0-10 VDC.e
When I give S1000 the speed is 672 rpm and STrue shows 224
In ports & pins, Spindel Use Spindel Motor Output and PWM Control is ticked.Minimum PWM 0%, PWM Base Freq 5
Spindel pulley is set to ratio 1 max speed 3000.
Any idea what is wrong?


Pages: 1 2 3 4 »