Hello Guest it is April 09, 2020, 05:21:21 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - marc1b

Pages: 1 2 3 »
1
Thanks, yes that is exactly what I thought the problem is

2
I get it, thanks!!

3
Mach4 General Discussion / Script editor strange behavior - or is it me?
« on: February 28, 2020, 02:25:19 PM »
I'm trying to edit my ScreenScript.lua - the below function appears to be missing the declaration for inst and I get a nil error every time the function is called

No problem, I insert the missing line. The editor won't let me save the file, access is denied. So I do a "save as", exit and rename the file.

I check it to make sure my changes are there.

Then I open Mach and to my surprise if I view the screen script the change is not there. If I exit Mach and edit the file again sure enough it is gone.

I must be missing something

function GetFixOffsetVars() 
        local FixOffset = mc.mcCntlGetPoundVar(inst, 4014)
        FixOffset = FixOffset * 10
        local PoundVarX = 5221
        if (FixOffset < 7) then
            PoundVarX = 5221 + ((FixOffset - 1) * 20)
        else
            PoundVarX = 7001 + ((FixOffset - 7) * 20)
        end
        PoundVarY = PoundVarX + 1
        PoundVarZ = PoundVarX + 2
        return PoundVarX, PoundVarY, PoundVarZ
    end

4
HiCON Motion Controller / 7736 and Mach 4
« on: April 22, 2019, 08:43:14 PM »
I am upgrading my Mach 3 (originally installed in 2014) with an Integra to Mach 4 and so far no joy on spindle and axis. I have the limit switches and outputs for coolant, etc working fine. In the diagnostics I do see the motors are enabled when the drives are. But there is no movement.

I have downloaded and installed the latest plugin & firmware (2.03.07)

The current Integra manual shows a 7737 encoder board and I have a 7736. Is this going to work for me? If so what is the mapping as to the drives and encoders?

Thanks!!

5
I decided better to move forward than backwards, I am upgrading to Mach4

6
I have the same issue, can you tell me what you needed to change? Big thanks!

7
I have found a few differences in the pin mapping between the older version of the 7737 manual and the newer. Is there something I should be changing here?

8
HiCON Motion Controller / No motion after Hicon Integra update - Mach3
« on: April 22, 2019, 11:58:35 AM »
In the process of chasing down a problem with interpolating a circle I updated the firmware to 3.26b and .xsvf to IntegraFPGA_7E7B

Integra 7766 & 7737 ,  Maxsine drives & motors

Aside from the circle error everything was fine before the updates. I am embarrassed to say that I didn't make a record of the motor settings in the Hicon plug in and I am pretty sure that is where my problem is. What should the index & output be for 3 axis?

9
I just need to get pointed in the right direction -


I have a Bridgeport Series 2 with air assist on Z axis. If we turn the air off over night and forget to lock the knee the Z will wind up at the bottom of it's travel below the limit and homing switches.

So I want to have the homing routine look at the current position variable, add to it and make a small move to get it above the switches.

Thanks!

10
HiCON Motion Controller / Re: Motors won't sit still
« on: February 04, 2018, 11:54:34 AM »
Got it figured out. I had to set the drives to the correct model motors and be a little less aggressive with my tuning in the drive.

Pages: 1 2 3 »