Hello Guest it is October 05, 2022, 12:52:45 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - learman

Pages: 1 2 3 4 5 6 7 8 9 10 »
1
Mach4 General Discussion / Re: converting Macro to Lua language
« on: July 09, 2015, 03:46:14 PM »


I don't think i'm saving it properly. I have it saved in the profile i'm using under macros.

I also tried running one of the codes in the Luaexamples file with no luck.

Thanks for the help Scott!

2
Mach4 General Discussion / converting Macro to Lua language
« on: July 09, 2015, 09:47:45 AM »
Hello

I am working on converting one of my workstations from Mach3 to Mach4. Having trouble understanding the Lua scripting. Could someone take a look at this simple Macro and help convert it to Lua.

Thanks
Josh

3
General Mach Discussion / Re: Getting Disillusioned with Mach3.
« on: February 13, 2012, 03:53:36 PM »
Sooo M11 and M10 will still not work with the SS. I'm looking to turn on and off different outputs without any delays..

4
General Mach Discussion / Re: why won't this macro work??
« on: June 30, 2010, 12:26:46 PM »
If Not IsActive (input4) Then   
Code "G1 X 0.020"
While ismoving ()
Wend
sleep (1000)
setDro (0,0)
end if

Hows this?

5
General Mach Discussion / Re: why won't this macro work??
« on: June 30, 2010, 11:29:55 AM »
Yes Sir!! now it works thanks

If Not IsActive (input4) Then   
Code "G1 X 0.020"
While ismoving
sleep (1000)
setDro (0,0)
end if

6
General Mach Discussion / why won't this macro work??
« on: June 30, 2010, 11:23:59 AM »
Hello

Im getting a "compile error" message

If Not IsActive (input4) Then   <<< will work if i get rid of this line
Code "G1 X 0.020"
While ismoving
sleep (1000)
setDro (0,0)

any Ideas??

thanks
Josh

7
General Mach Discussion / why wont this macro work??
« on: June 30, 2010, 11:05:52 AM »
Hello

Can any body tell me why im getting a "compile error" message

If Not IsActive (Input 4) Then    <<< it will run without this line  ???
Code "G1 X 0.020"
While ismoving
Wend
sleep (1000)
setDro (0,0)

Thanks
Josh


8
General Mach Discussion / need a macro
« on: June 28, 2010, 12:42:51 PM »
Hello All

Trying to jog my x axis +.020 once if input 4 is not active, (Pappabear) or scott was kind enough to get me started but im still needing some help!

Scott wrote this
well it might be easier to put a custom macro at the start of your g code file.
i.e. M1000.m1s 
I am not at my work computer so you will have to look up the OEM VB codes below.

You might want to double check my VB also, but you want to look for your input being active.
INPUTx below could be INPUT1-4   (or you could use the OEMs 1-15).
also on your general config page, you will need to set up your Step jog DROs with at least one of them with the value
of 0.02 in it, let us say that is the first value box.

'M1000.m1s

MyNeededInput = IsActive(INPUTx)

If Not(IsActive(MyNeededInput) Then
   If Not(GetOEMLED(*********)) Then        'look up the OEM LED code for the Machine is in Step/Jog mode (not continous or MPG).
      DoOEMButton(*********)                    'Do the button to put the machine into Step/Jog mode.
      DoOEMButton(*********)                    'set the step jog value to the first dro value box OEM button
      DoOEMButton(*********)                    'Push the Jog Button for the X+ direction
      While IsMoving()
      Wend
   Else
      DoOEMButton(*********)                    'set the step jog value to the first dro value box OEM button
      DoOEMButton(*********)                   'Push the Jog Button for the X+ direction
      While IsMoving()
      Wend 
   End If
End if

'scott


If Not Is Active (Input 4) Then
   If Not(GetOEMLED15) Then        This is for Jog Mode Incr
      DoOEMButton(15)                    'Do the button to put the machine into Step/Jog mode. (?? im lost here)
      DoOEMButton(193)                  ' Select Jog increment 3, i have set it to .020
      DoOEMButton(307)                    'Push the Jog Button for the X+ direction
      While IsMoving()
      Wend


Its a start I think ???
josh


9
General Mach Discussion / Re: need a macropump
« on: June 11, 2010, 10:51:36 AM »
Thanks Scott that sound just like what I'm looking to do!!

I have my proxy sensor in series with my start button so let me do some rewiring and i will get back with you on the VB.
josh

10
General Mach Discussion / Re: need a macropump
« on: June 10, 2010, 01:37:35 PM »
@kf2qd.. yep, bandaids and duck tape are my favorite. Its the same file over and over. I do recall trying a home position but it traveled past the position and smashed my proxy sensor

Pages: 1 2 3 4 5 6 7 8 9 10 »