Hello Guest it is May 07, 2021, 06:34:43 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - TomR

Pages: 1 2 »
1
Pretty please!  I won't tell anyone.

2
Well that appears to be the problem.  I have a licensed version at our shop but a demo version at home where I do most of my code development.  When I used BR549's macro on the licensed version, it worked fine.  I was surprised to find the demo has such limitations.

Sorry guys and I hope I didn't waste your time.  I really appreciate your help.

Regards, TomR

3
Attached are the three test files I have been using.  It is actually the Road Runner divided into three separate files. 

Thanks, TomR

4
I tried the above macro but found the tool path regeneration oembutton 160 goes into some kind of indefinite loop.  The tool path dialog box opens indicating the tool path is being regenerated but only "hangs" there indefinitely.  Cycle Start never executes.

Also, I assume DoOemButton(0) is a typo and should be DoOemButton(1000).

Thanks, TomR

5
G-Code, CAD, and CAM discussions / Re: Need Help on a Mcode Macro
« on: May 04, 2012, 11:31:14 AM »
I have tried this earlier and it works fine with one exception.  The tool path is regenerated properly on the first program only.  On all subsequent programs the tool path screen is blank leaving the operator blind to what is being machined.

Thanks, TomR

6
G-Code, CAD, and CAM discussions / Need Help on a Mcode Macro
« on: May 02, 2012, 02:45:01 PM »
I am having problems with a mcode macro which consists on the following:

'M5001 Macro
DoButton(169)  'Close Current G-Code file
LoadFile("C:\Mach3\Gcode\RR2.tap") 'Load Next G-Code File
DoButton(1000)  'Start Cycle after Loading File

What I'm trying to do is daisy chain a series of G-Code programs such that when one program completes, the next program loads, regenerates a new tool path and cycle starts without operator interaction.  The above macro (M5001) will load the G-Code file (C:\Mach3\Gcode\RR2.tap) and regenerate the new tool path, although it does not start the cycle without mousing the "Cycle Start" button.

As an option, I used the "LoadRun" command  which did successfully load and start the G-Code without mousing the "Cycle Start" button.  However this command does not regenerate a new tool path on the Tool Path screen.

What am I doing wrong?

Regards, TomR

7
General Mach Discussion / Parallel Port Help
« on: May 02, 2012, 10:07:43 AM »
I want to operate my router using a lap top computer.  My lap top does not have a DB25 parallel port and Mach3 does not support a USB port.  Any suggestions how I can get around this problem.

Regards, TomR

8
The mcode macro is working fine in running gcode programs sequentially.  However, the tool path is not regenerating on the tool-path screen when the macro loads and runs the gcode.  I tried using an OemButton(160) after the load/run command but without success.  Mach3 shows a dialog box indicating the tool path is being regenerated but neither regenerates the tool path nor runs the gcode.  Seems like its in some kind of loop.

'M5001 Macro to run PushStick.Tap
LoadRun("C:\Mach3\Gcode\PushStick.tap")
While IsLoading()
Wend
DoOEMButton(160)

Thanks, TomR

9
Good thought, I see what you mean.

Thanks again.

10
Thanks BR549. 

Making the above format change has the M5001 macro working perfectly.  I tested a 3-program sequence with complete success.

Thanks for all your help.  Also "push stick"  does include the space as typed, however a good heads-up on your part.

Regards, TomR

Pages: 1 2 »