Hello Guest it is November 20, 2019, 10:01:32 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - machining fool

Pages: 1 2 »
1
Post Processors / Re: Help with Mastercam to Mach post error.
« on: December 09, 2015, 06:32:16 PM »
OK, I am using the generic post out of Mastercam 9.1 and it appears that it is working correctly.  The test Gcode routine that I drew works fine, so it appears that after some setting changes, such as the incorrect choice of setup units, namely mm. instead of inches caused a problem in the Gcode, I guess, because I changed over to the inches  and recalibrated, and it  ran flawlessly., So, I guess my problem is solved, thanks. Bob.

2
Post Processors / Help with Mastercam to Mach post error.
« on: December 08, 2015, 04:39:39 PM »
I downloaded the generic post for Mastercam from the Mach3 download section for posts.  The post is in the post file in Mastercam.  After I drew some lines, I tried to post to Mach3 and got this error message and wouldn't let me put it in the NC file of Mastercam.  "Error, illegal character $ on left side of equation post line number 215---Program halted due to error"  I have not a clue on how to fix this, can someone help?  Also, Most post files also have a machine difintion file and a control definition file, 3 files having to do with a post, and all that was in the Mach3 post download was a .pst file.  Do I need the other two files for the post to work in Mach3 and Mastercam.  I have Mastercam 9.1.  Really need some help. Bob.

3
The E-stop of the PoPendant (wires 15 and 16) must be wired in series to your existing e-stop switch. So, if any of the switches is pressed, the contact is lost and the machine stops.  That was the answer that Matevz gave me, and of course it worked.  I now have E-stop on the console and on the pendant, so all is well. Next, I am going to see if my machine will run a G-code.   Thanks Matevz, you made it sound so easy, even I understood. Bob.

4
NeoTo, I thank you for your attention. I apologize for my ignorance, because am new to this electronics scene. Evidently, when I ask a question about my system, whether it be this forum, or a tech from a manufacturer, they assume that I have more knowledge than I have.  Your tutorial on cutting off the db25 connector from the PoPendant and instructing me where to install the different color wires on the numerous pins went off without a hitch, because I was told, what color of wire, which pin to install it into. No problem.  I can follow directions. So, here is the situation.  I have a 57u Pokeys and a Pokeys keyboard and the Popendant.  I have a dedicated E-stop button next to the Pokeys keyboard on my console.  When I either push the physical big red button, Mach3 goes into stop.  Also on the screen, when I take my mouse and click on reset, it will either go into or out of e-stop, also works when I push reset on the Pokeys keyboard.  Now if I am away from my console, I cannot reach that big red button, but I have one on the  Popendant, but it does not work.  I want it to work to go into E-stop when pushed or out of E-stop when released. So when you say map, map what, to where? Exactly?  When you say dedicated emergency pin, I have a Centipede brk. board and the emergency pin happens to be 19 on that board and goes to E-stop switch on my console.  Can I configure it in the PoPendant configuration page?  It appears to be checked, so what should that configuration file look like to make it functional?  Again, I apologize for my lack of knowledge. This is the only remaining glich to having a viable system. I notice that when I push the momentary button on the side of the PoPendant, the pendant comes alive, and I can control the axis', so does that mean unless that button is pushed, the E-stop button on the PoPendant will not work?  I would like the e-stop on the PoPendant to actuate whether I push the button on the side or not, so If I could get more exacting answer. Thank you, Robert Brown.

5
Well, I think you Tweakie.cnc for your kind words.  I found the directions, for me, a little intimidating because some of the terminology and methods were new to me.  So, I started reading and scanning the posts under the Pokeys post section, and over time, I saw posts that coincided with my problems and finally put together what I was doing wrong.  I must say, for a new guy like me, a better job could have been done in illustrating the two methods of installing  the PoPendant. They could have simply said somewhere, in the documents, that there are two ways of installing PoPendant, one with the Pulse engine and one with just installing the Popendant configuration file.  Nowhere did I find that statement.  The only statement about the Pulse engine was,  "If you are to use the Pulse engine".  That led me to deduce that there must be two ways of getting the PoPendant to work, so at the end of this, it turned out to be very simple, intalling the configuration file for the PoPendant found in the downloads section for the Popendant, and when I did that, there were all of the settings preconfigured and then everythng worked. the fractional feed knob, the axis knob, the momentary switch, and of course, the big knob to control the movement, but not the E- stop. So, that is where I am right now, but it is still not clear to me, when they say, quote, "To enable Pulse engine, the emergency switch input must be connected between pin 52 and ground. The switch must be NC type."  Now there is a wire attached to pin 52 coming from the PoPendant, and a wire going to ground, also from the PoPendant, but do they mean to take a wire from pin 52 and run it to ground? It is still not clear to me, sorry.  I am not using the pulse engine, so does that mean that I don't have to run pin 52 to ground?  Is there something in the configuration file that I have to change?, like go high or go low?  If someone could help, let me know. Using 57U, the K48-- Pokeys, and the PoPendant. It might be that, letting go of the button disables the movement, and I think that is the case.  Another thing, I amazed at the lack of help that I have gotten from my posts, almost zero. Why is that? I took a shower and everything.  Oh well, Bob.



 

6
Well, finally read the directions and put the pendant configuration file into Mach3 and everything is working except the E-stop.  Last question, does anyone know what it means to attach pin 52, for the E-stop, to ground.  Does that mean on the 57U board to run a wire from pin 52 to a ground pin? Now, someone might know that.  Please help. Bob.

7
Is there anyone that can help me to get full functionality of the PoPendant, such as the axis knob to function, the E-stop to work,  the switch on and off to work, and the fractional feed speed knobs to work?  The only thing that works is the large knob that controls the movement of the axis chosen on the Mach3 screen.  Is it correct that I have to use the pulse engine to make these things work?  Isn't there anyone here that knows? Bob.

8
OK, I installed the PoPendant as instructed and it works.  All axis' work when I use the screen Alt A change axis command, but how do I get the knob on the pendant to change the axis? Does anyone know?  I would appreciate it. Thanks. Bob.

9
Forum suggestions and report forum problems. / Re: you posted here
« on: December 05, 2015, 08:51:20 AM »
Thenk you, I thought I was being blackballed or something.  I created all of the posts that say, "you posted here", so that is why I asked. I thank you for your quick answer. Bob..........................................................................................

10
Forum suggestions and report forum problems. / you posted here
« on: December 05, 2015, 07:26:22 AM »
What is the difference of the blocks preceding my post.  One says "you posted here"  and another says " normal post", what is the difference? Bob.

Pages: 1 2 »