Hello Guest it is November 25, 2020, 05:52:32 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Flipz01

Pages: 1 2 3 4 5 6 7 8 9 10 11 »
1
Galil / Galil registry in Windows 7
« on: October 21, 2010, 05:24:32 PM »
I'm trying to get Mach to work with a DMC-2143 Galil board under Windows 7.  No luck.  I just talked to a Galil tech guy who told me that he believes the problem is that Galil no longer bothers to register the controller and Mach is probably looking for this entry.

Probably right!

He says that SmartTerminal did this in the past but is no longer used.  Also, he thought that this program would work in a 32-bit system, but not 64-bit.


Anybody out there running Galil under 64-bit Win 7?  If so, how did you register the controller.

If you are running Galil under 32-bit, did you get SmartTerminal to work?  If not, how did you register the controller?

Or, is there some way for Mach to see the Galil without this registry?

2
General Mach Discussion / Windows 7 Installation Problems
« on: October 21, 2010, 02:28:56 PM »
Trying to install Mach on a 32-bit Windows 7 system.  It has issues.

First, when trying to install, I get error boxes that say "Remove Program for Windows 2000 Drivers has stopped working".  I hit the "Click Online" choice and it seems to find a solution.  This happens several times.

The next ones are for:

ms8runtime.exe has stopped working
Mach3 PlugIn Control has stopped working
Mach3XML.exe has stopped working

They seem to clear when I hit "Click Online for a solution"

Next up is Parallel Port Drivers, and I get "Install Program for Windows 2000 Drivers has stopped working".  It goes back to "Installing Parallel Port Driver" and sits there.  If I open the Task Manager and turn off the Driver Test, I get a box that says "Installation Successful"

But, I don't think it works at all.

Any ideas out there?  I don't recall having any of this when I loaded Mach on a Win 7 64-bit laptop.



3
Galil / Encoder feedback
« on: July 08, 2010, 03:16:25 PM »
I've read through most of the posts here and one of them talks about not reading encoders.  I'm not getting feedback, and I'm not sure why.

I have a DMC-2143 card.  I can see the encoders are working with a TPA command in GalilTools, and if I spin the motor, I can see the Units/min register report the speed in Mach.  But, if Mach reads the encoders to report the speed, why doesn't it display position in the position DRO?  Is there a special type of DRO box for this?

4
Galil / Re: Limit & Input configuration
« on: July 02, 2010, 06:19:52 PM »
A bit more testing and I've discovered that when GalilTools says inputs are "On" - that means they are actually "Off".  Go figure.

Still, can the state of things be manipulated in some fashion?

5
Galil / Inputs and Limits
« on: July 02, 2010, 06:11:13 PM »
Sorry 'bout that, didn't think the first one posted.

6
Galil / Limit & Input configuration
« on: July 02, 2010, 05:11:49 PM »
I'm setting up a DMC-2143 board.  Using the GalilTools program, you can monitor the state of inputs, outputs, etc. 

No matter what I change, Inputs #1-8 and Home Inputs show that they are "On" (green box with a 1).  If I ground the pins, they change state (Red box with a 0), so I know I have it set in a working fashion.

However, for the high and low limits, if I click "config Galil limits active low" in the PlugIn configuration, these all change to off as the defualt state.  I click the same box for the Homes inputs, but they remain On regardless.

Is this normal?  I generally use a ground to turn inputs and homes on/active.  Is this possible with a Galil with settings, or do I have to use pull down resistors to force them low (off) as a normal state?

7
Galil / Re: Galil card not connected
« on: July 01, 2010, 05:34:01 PM »
Thanks Mat.  I just tried that and came back to post that I got it to work.

My problem was that I talked to a Galil tech to ask about setting the static IP address.  He told me I would not need Smart Terminal at all - wrong.

For anyone else reading this:

Set a static IP address for the computer network terminal
Run Galil Tools and connect to the Galil board

Then - run Smart Terminal and do "Controller Registration"

8
Galil / Galil card not connected
« on: July 01, 2010, 04:55:47 PM »
Not sure what I'm doing wrong.  I have the Galil PlugIn set to "Controller 1 - ethernet", I'm using a crossover cable, and Galil Tools talks to and reads the serial # from my DMC-2142 card.  If I hit the enter key while in Galil Tools, I can see the yellow light on the Galil board light each time.

Seems right.

But, when I turn on Mach, it says "Galil card not connected".

What might I be missing?


While I'm looking for help, does the PlugIn read the Abort pin on the Galil?  How?

9
SmoothStepper USB / Re: SmoothStepper with Windows 7
« on: June 05, 2010, 06:23:45 PM »
False alarm as it turns out.  I had a short in one of the ribbon cables and that wouldn't allow activation.

10
SmoothStepper USB / SmoothStepper with Windows 7
« on: June 05, 2010, 04:04:22 PM »
I'm trying to get a SmoothStepper board running on a Windows 7 (32-bit) computer.  I know the board is OK because it works perfectly when I use an XP based computer.

When I try to install the SmoothStepper on the new computer, I can't get the computer to recognize that the SmoothStepper exists.  I don't get a "New Hardware" screen to pop up when I plug it in, and searching for new hardware doesn't find it.  Re-booting doesn't help either.

Does the SmoothStepper work with Windows 7?  If so, how do I get the computer to see it?

Pages: 1 2 3 4 5 6 7 8 9 10 11 »