Hello Guest it is August 08, 2020, 10:52:03 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - novicemachinist

Pages: 1
1
Retuning the motors through Galil took care of homing issue. Also the acceleration and deceleration helped too.

But the problem with the work offset still exists. Also, the tool wear offset doesn't work either.

Thank you.

2
I have my CNC machine built up using Galil 4143 and Mach3 but have some problems. I have trouble with the following.

1.   Homing.  This is not a very frequent problem.
At times the Y-axis overshoots and passes the homing and limit switch during homing routine. Reducing the homing speed to 10% seems to have reduced the problem to certain extent.

2.   Work Offset.
Once the G55 is set, if I home it and send a G55 command I get unreliable results.
a.   X overshoots and hits limit. This occurred if my G55 command is part of the program.
b.   If I use MDI to send G55, the X does go to G55 but it is off by around .004 to .005 inches.

3.   Tool wear offset.
It does not have any effect on the profile.

Please advise.

Thanks,
A

3
Galil / Re: Galil controller compatability (what works with the plugin)
« on: November 19, 2011, 03:48:57 PM »
It works great. Thank you Steve.

4
Galil / Re: Galil controller compatability (what works with the plugin)
« on: October 31, 2011, 10:12:34 AM »
Hello,

If I am using the same limit switch for forward, reverse limits and home, should all of them be mapped with the same pin number in the ports and pins configuration? Could you please help me understand this.

Thanks in advance.

5
Galil / Re: Galil controller compatability (what works with the plugin)
« on: October 28, 2011, 12:37:41 PM »
I did follow the pdf to map my motors and limit switches but I can not get it to work. The motors jog but any G-code I input does not. Also, the limit switches are active only on the X-axis in the diagnostic screen.

I will try reinstalling the plugin and go through all my settings again.

6
Galil / Re: Galil controller compatability (what works with the plugin)
« on: October 28, 2011, 10:58:42 AM »
I also burnt the BM value which is 2500. The motor has 4 pole pairs and the encoder has 10000 counts per rev.

7
Galil / Re: Galil controller compatability (what works with the plugin)
« on: October 28, 2011, 10:56:31 AM »
I did burn MT and CE to the Galil.

The motors do not have an hall effect sensor, so I am using a Galil Sine Amp 43540.

I have burnt the following to Galil:

IP address
MT=1
CE=0
TL=2 (the rated current for the motor is 3.3A)
TK=5.97 (peak current is 9.3A)
AG=2
AU=4 (since the L>4.2 and I am using 24vdc power supply)
KP=15
KD=160
KI=0

I have these burnt for all the three axes.
Also burnt BW for the Z-axis as it has a brake on it.

I am able to achieve the required motion thru galil tools. But when using Mach3, I am not able to. Does this mean my Mach3 settings are misconfigured?

Thanks



8
Galil / Re: Galil controller compatability (what works with the plugin)
« on: October 28, 2011, 10:12:17 AM »
Thank you for the help.

@ NosmoKing:  I believe my MT ad CE settings are good because I am able to achieve desired movements using Galil tools. I have servo motors on X, Y and Z axes which have a quadrature encoder. So, I set my MT to 1 and CE to 0 for all the three axes. I get the runaway condition when I try to jog them using Mach3.

@battwell: I went through the pin configuration in Galil plugin pdf page. It is a bit confusing to me because the input signal screen in ports and pin config says that only pins 10-13 and 15 can be used, but the pdf has some of the limit switches mapped out of this range.
            I did try mapping them according to the pdf and only the limit switches on my X-axis worked. I double checked the switches using galil tools and they seem to be functioning well. Does this have anything to do with the port number?

Thanks



9
Galil / Re: Galil controller compatability (what works with the plugin)
« on: October 27, 2011, 12:56:30 PM »
Hello,

I am new to Galil and Mach3.

I am using Galil DMC 4143 and Automation direct servos with galil inbuilt amps.
I have installed the galil plugin and I can get the motors to jog using mach3. But when I try to run a g-code, it doesn't work. Please let me know if there is any other setting that needs to be done.
Also, I am using the TCP modbus connection. How do I map the limit switches in the ports and pin config in Mach3. I am confused with the port numbers and pin numbers. Please, throw some light on this.

Thanks in advance.

Pages: 1