Hello Guest it is December 04, 2021, 12:26:40 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Backlash

Pages: 1
1
General Mach Discussion / Re: Backlash control on Y axis is bad
« on: March 01, 2007, 10:14:12 AM »
Hi,

I just downloaded the latested verison hot off the press, 2.050, and the backlash comp. works great! I only cut one part, so I have not fully tested it yet. It makes my sloppy machine look great. I am a happy camper.

Thanks,

Robert

2
General Mach Discussion / Re: Backlash control on Y axis is bad
« on: March 01, 2007, 08:39:53 AM »
Hood,

I tried your advice by running in exact step mode, but no luck. I have backlash comp on both X and Y axis, but only the Y axis goes crazy.

For right now, I am going to try to tighten up my machine. I can not afford ball screws right now unless you know where to get retrofit kit for a benchtop mill cheap.

What is an acceptable backlash tolerance could I get from lead screws? I have 0.025 inch of backlash in my lead screws and was wondering how good could I get them. If I could tighten up my machine, it may hold me over until I could get ball screws and just run Mach3 without backlash comp.

Thanks,
Robert

3
General Mach Discussion / Backlash control on Y axis is bad
« on: February 28, 2007, 02:37:38 PM »
Hi,

The backlash on the Y axis does not work properly.
When the backlash option is turned on (only 20% of Max) the Y axis step will output a high rate of pulses,(only in certain parts of the G-code) causing the motor to loose steps. I hooked a logic analyzer to the direction and step pins to verify the it was not noise. I found the the signals were clean, and captured the waveform when the problem happens. When the problem happens, the Y steps pulses are 38.6 us appart. This is about 25.7 KHz, which is my pulse frequency-- Hmmm.. This causes the motor to miss steps.

Note: This does not happen in Jog mode. The backlash function works perfect in the Jog mode. It only happens when running G-code.
Turning the backlash function off fixes the problem, but now I have backlash issues. I tried 5% and 100% of max values, but it makes no difference.

I noticed that someone else posted this exacted problem. This maybe the reason for a lot of posts of "ugly circles" posts.
I could send you the captured waveforms from my logic analyzer if you need them.

Thanks,
Robert



Pages: 1