Hello Guest it is October 25, 2020, 01:49:36 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Intarsicaq4

Pages: 1
1
General Mach Discussion / Tangential Mode
« on: March 08, 2012, 12:32:39 PM »
For knife cutting, the cutter must rotate in the tangential direction as it travels along the path.
According to MACH3 manual, there is an option called tangential mode, does this mean that
when a g-code is generated automatically MACH3 computes a rotation to an axis?

Is there a place where I can find literature related with this matter?

Thank You Very Much
Intarsica


2
FAQs / G-CODE NOT WORKING, JOGGIN IS OK
« on: March 07, 2012, 08:08:09 PM »
Hi There!

I am programming a machine using 4 step motors 1600 oz-in. Two motors are used to move the x-axis, one of them has been slaved (A slaved to X) and I have changed directions in these motors to be consistent with the movement since motors are installed in opposite directions.
After setting all parameters according to the manual, the machine can be moved with the jog smoothly in all three axes and in both directions (+ and -), so everything seems to be working perfectly. Moreover, I have calibrated three axis properly.
However, when I loading G-code from an example motors start failing: One of the motors in the x-axis is not moving at all, and the other one moves OK, y-axis does not move at all, z-axis is working well. Can you give me some advice?

I will appreciate any help on this matter.

Thank You in advance

Intarsica.

3
General Mach Discussion / MACH 3 installation in a Laptop
« on: August 17, 2011, 10:48:24 AM »
Hi there!
Is it possible to install MACH3 in a laptop using a USB cable?

I have installed MACH3 in a PC using a parallel port, and works fine. Now, I am trying to use a laptop to drive my machine with MACH3, is this possible?
If so, where do I look for instructions to do this?

Thank You very much in advance for your help,
Intarsica

4
FAQs / Motors Syncrony Speeds
« on: May 27, 2011, 10:26:03 AM »
I am using inches as units,
My current steps are:
x-axis 625.6152166
y-axis 416.858

I have been moving these numbers to obtain better results, however i have had no better results.

is there a relationship between steps and the perimeter of pinions?
Any help will be appreciated.

Thank You
Intarisica

5
FAQs / Motors Syncrony Speeds
« on: May 24, 2011, 05:59:04 AM »
Hi there!
This problem is about speed synchrony of x and y-axis.
First of all, to move the x-axis and y -axis  I am using two racks with pinions of different pitches. My y-axis has a larger diameter gear, so one revolution of the motors gives larger movements than one of the x-axis.
Additionally, I have calibrated all three axes, so that one inch in Mach3 corresponds exactly to one inch of real movement.

When testing velocities and accelerations independently, both work very steady even with speeds of 1000 ipm, I am setting both axis at lower speeds and also works perfectly, when moving axes independently. However, if I move form GO X-30.0 Y-10.0 to G X 30 Y 10 motors start making sounds like one of the were stopping the other one. I think x-axis motors are stopping from moving faster my y-axis-motor.  Moreover, if I move from G0 X-20.0 Y-20.0 to G0 X20.0 Y 20.0 also movement is still steady.
Is there any way to calibrate these speeds? Do I have to change one pinion so both have the same pitch?

I will appreciate any help regarding this matter.

Thank You very much.

Intarsica

6
General Mach Discussion / STEP MOTORS CONEXTION
« on: April 28, 2011, 04:39:36 PM »
Hi there!
Thank You for your last answer.

Now I would like to mention what I have been doing.

First, my motor seem to be working properly, this is because I changed the direction manually and it did work on both directions.
Now, the problem apparently lies on software or on breakout board.

When connecting the PULSE- and DIR- to pins 2 and 3 motor moves to one direction only. This means that when the computers sends a signal through one of this pins it received by the motors.
However, the signal sent by DIR- is not received to change the spinning direction of this motors. According to my knowledge, this is the way this controller handles direction in
the motor. I am starting thinking that the problem is software, in this case MACH3.
My question is: Is there an extra configuration needed in MACH3 to active the signal sent from the computer to the breakout board?
Apparently, signal is not received by my breakout board.

I will appreciate and help related with this matter.

Sincerely,
E.









7
General Mach Discussion / STEP MOTORS CONEXTION
« on: April 22, 2011, 02:00:35 PM »
Hi there!
I am using MACH 3 for a 3-axis CNC machine.

I am using step motors with four wires.  I am connecting these four cables according to specifications. However when I move these motors in both directions with the Jog,
they only move in one (clockwise!) direction. Of course if I switch two wires my motor moves to the opposite direction, and again, if a press right or left arrow they move counter clockwise.
Do you have any suggestion to move them in both directions?

I appreciate any suggestion related with this matter.


Thank You in advance.

E.

Pages: 1