Hello Guest it is August 11, 2020, 03:05:20 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - eggplant

Pages: 1 2 3 »
1
General Mach Discussion / Re: mad noise and vibrations at slow speed
« on: March 25, 2011, 06:19:39 AM »
Quote
In an X,Y move where one axis has farther to go than the other they both start and finish at the same time - one axis moves continuously and smoothly whilst the other starts and stops in jerks.

I must be having a slow week ! Is blatently obvious now ! It cant NOT jerk to some extent can it if one axis has a fair distance to go but the other a small amount, makes total sense now and also in theory microsteppoing should help as the steps are smaller so more steps to move the smaller amount should be smoother (I think...)!

Calv

2
General Mach Discussion / Re: mad noise and vibrations at slow speed
« on: March 24, 2011, 08:40:50 PM »
Thanks,

For some reason it seems worse if the Y axis has to move the lager amount and the X the smaller. Im looking at increasing the size of the machine and making some other changes so I think I'll build one new motor driver at first and see how it goes. I'll post back with my results but wont be for a few weeks. I did ok with this machine, was very cheap to make and is plenty accurate for what it is, and now I know a little more about it all I can plan better and make parts on this machine where possible for the "upgrade". 

Calv

3
General Mach Discussion / Re: mad noise and vibrations at slow speed
« on: March 23, 2011, 09:34:26 PM »
Thanks,

Seemed to improve a little. MY stepper drivers only do 1/2 step, would microstepping affect this ?


Calv

4
General Mach Discussion / Re: feedrate/motor tuning
« on: March 23, 2011, 09:32:17 PM »
Hi,

Thanks for the info. The stepper drivers Im using can only do 1/2 step so from your formula this gives me 314.9606 steps per mm, so my measurements in the mach3 calibration were pretty close. So going from this, basically I need to either change lead screws or add some sort of gearing to give me 1:3 ?

My machine is very small,  the original reason for building one was for pcb milling but now its working I have many more uses. I plan to either build a new one or increase the size of this one, the problem is Im limited for funds at the moment so its going to be a bit at a time. At the moment Im thinking of changing mine into a moving gantry type rahter than the moving table which should give me a larger working area for the same footprint and I should hopefully be able to do it without taking the machine out of action for long as I would like to use it to make parts for the new one.

Going from that, would the best idea be to change lead screw pitch (I'll need new longer ones anyway) or do the gearing? the motors are way overpowered, I sort of bought larger ones rather than ending up being underpowered. The ones I have are these ones http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=260725764391&ssPageName=STRK:MEWNX:IT

Thanks

Calv

5
General Mach Discussion / Re: feedrate/motor tuning
« on: March 22, 2011, 05:51:37 AM »
Hi,

No gearing, the main frame, lead screws, mountings etc was bought as a kit (new but 2nd hand) off ebay. Didnt come with instructions but I managed to find it and it is this one http://modularcnc.blogspot.com/search/label/CNC%20Mini%20Mill The third one down. According to that page, the lead screws are 1/4 x 20. I'll double check my distances when I get back home. Is using an imperial thread and me working in metric going to cause any issues?

Thanks

6
General Mach Discussion / Re: alignment
« on: March 21, 2011, 08:44:06 PM »
Quote
One idea that may work for you is clamp a piece of material to the table as near as you can get to true with the axis then run along the edge to dress it true, then you can slide your workpiece against it and clamp it and if needed remove the stop material before machining.

Logical, thanks. Maybe a piece of mdf or plastic could be fastened to the table and routhed/engraved in concentric squares, might work I'll have to have a go. Thinking about it, I suppose its only the same as using a rule, not 100% accurate but probably ok for starters.

Thanks again


7
General Mach Discussion / Re: feedrate/motor tuning
« on: March 21, 2011, 08:39:00 PM »
Hi,

I should have posted more details now thninking about it.

It moves 1mm/revolution, the calibration set it to about 318 steps/rev. motors are nema 23 1.8 degree 200 steps/rev. running at 36V I can get to over 3000 in the motor tuning but it sounds ill to me, a sort of high pitched sound rather than the smooth sound I would expect. I did get it running a bit better on the motor tuning but then when I jogged the motor stalled. Im not sure what I should be aiming for, if Im a mil eoff then obviously I need to fix it but Im sort of stuck without knowing what to aim for.

Thanks

8
General Mach Discussion / alignment
« on: March 21, 2011, 08:24:49 PM »
Hi all,

Just a quick question. If say I put a piece of material to cut onto my machines table, how do I go about making sure its exactly aligned along the x and y planes? I could of course line up the workpiece by making it level with the edge of the table but if the workpiece was smaller and was to be positioned in the middle of the table how would I ensure it was straight? For eg if I was to cut a square 60mm square onto a piece of 100mm material how would I ensure the square I cut was parralell to the 100mm material (assuming Im not cutting right through of course !)

Thanks

9
General Mach Discussion / feedrate/motor tuning
« on: March 21, 2011, 08:19:45 PM »
Hi all,

I found the answer a while ago whilst browsing the forum but now cant for the life of me find the post.

Im up and running now and have gone through the motor tuning and calibration. I found the maximum smooth motor velocity for eaxch axis and then knocked a bit off for safety. Whilst I can get to high speeds, the motor sounds rough. At the moment the maximum I am able to get is about 800mm/min. I will be mainly cutting mdf, plywood, hdpe and some aluminium. The machine is small and uses a proxxon (like a dremel) so only small bits. Is this speed ok? I know the feedrate varies depending on the material, tool, etc but from looking at videos on youtibe mine seems quite slow and whilst a few test cuts have been sort of ok, I want to get the machine and software set right before I start going any further.

Thanks

10
General Mach Discussion / mad noise and vibrations at slow speed
« on: March 21, 2011, 08:01:08 PM »
Hi all,

My machine is now functional and calibrated as much as I can with a ruler and magnifying glass - waiting on a DTI arriving.

It runs smoothly but if I move X and Y at once, with a small amount on one axis but large on the other it makes a horrible noise and vibrates.
For eg, from 0,0 I can do G1 X50 F500  and it works fine as does G1 Y50 F500 but, if I have say G1 X50 Y1 F100 it hates it and sounds a bit like when you have the step timing wrong on a stepper or try to use too low a voltage for a set speed - not exactly the same but similar.

Hard to explain, I know but Im sure someone must have come accross this problem too. If anyone can offer any assistance? All 3 axis work fine and can move together at all speeds except when one has a small distance to go and one has a lot more to go.


Thanks


Pages: 1 2 3 »