Hello Guest it is October 21, 2020, 03:13:37 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ceramics

Pages: 1 2 »
1
General Mach Discussion / Re: Setting up Tangential Knife-Questions
« on: April 11, 2012, 04:36:00 PM »
Here is the Gcode for Method 2... :)

2
General Mach Discussion / Re: Setting up Tangential Knife-Questions
« on: April 11, 2012, 04:34:58 PM »
ET,
Thanks for the quick response.  Glad to hear you are having success on your end. 

I have two different directions that I can go with my Tangential setup.

Method 1.
Use the Tangential Feature in Mach3 and create my g-code as with an Engraving option in RhinoCAM.
This seems to be the most straight forward approach, however I am having some difficulties with this method right now. The Mill moves in a very jerky motion. It may be do to using G01... but I haven't been able to sort this yet.

Method 2. (My Preferred method if I can get it to work)
Use custom software to predetermine the A axis numbers needed for a given curve. This part I have actually done already and it seems to give me good numbers for a given set of curves.
This is basically similar to what Mach3 is doing on the Fly as Method 1 happens. I am also having difficulties with getting Mach3 to respond well to this Gcode too. When I run the attached g-code, The machine does what it should, just Very Very slowly.  I turn up the Feed override and it seems to go a bit faster, but no where near a useable speed.  Mach3 says is is going 30 ipm, but it seems more like 3-4 ipm.
My guess is that my problems are coming from G01 moves... where mach3 is trying to get the A axis to reach its coordinate at the same moment as X and Y are reached for each line.
Of course I would like this to happen in this manner, but I asking too much... where is the bottleneck in terms of speed if this is the case.  I have the Stepper which drives A tuned to a high acceleration and Velocity.
Look ahead is 200.
My XmL for Method 2 is attached.
Thanks for any ideas that anybody has.  I have been pulling my hair out with this one.


3
General Mach Discussion / Re: Setting up Tangential Knife-Questions
« on: April 10, 2012, 06:09:23 PM »
Having trouble attaching multiple attachments... having to reply to my own post :)

4
General Mach Discussion / Re: Setting up Tangential Knife-Questions
« on: April 10, 2012, 06:07:49 PM »
Here some code that I am using for testing.  It is far from an efficient means of directing a particular motion, but regardless of this fact, I am hoping to get things to move faster.

5
General Mach Discussion / Setting up Tangential Knife-Questions
« on: April 10, 2012, 06:04:41 PM »
I have finally gotten to the point where I am testing the Hardware that I have been building for a Tangential Knife set up.
There are some posts on the forum about it, but I haven't seen my particular problem worked out yet.  Hopefully somebody has some suggestions for things that I can try.... I have been racking my brain trying to solve this.
I am using some software that I wrote which will take regular 3 axis gcode and add in the fourth axis--  Axis A.  I know that Mach3 has a feature for this, but I would like greater control if it is possible.
The problem is that with every new motion called for axis A, the other X, Y, and Z motions slow to a crawl.
I have attached the gcode that I have been using for a test.
Any advice is welcome.
Thanks to everybody for a great forum.... I have learned a lot from reading the diverse topics covered.

Sincerely, Andy :)

6
One on one phone support. / Re: About one on one phone support.
« on: October 06, 2011, 02:52:01 PM »
Thanks for the great support Brian.
You saved me so much time and pain.
 :)

7
One on one phone support. / Re: About one on one phone support.
« on: September 28, 2011, 11:37:15 AM »
If possible, I would like to pay for phone support with Brian about discussing a workaround dealing with the gcode interpreter and pauses that I get when running Mcodes.
I am not expecting the problem to be solved in one phone call... i just need to talk with somebody that knows this stuff inside and out... so I can look in the right direction for what is a realistic solution for the problem I am facing.

email: brayman@mac.com

Thanks  :)

8
PoKeys / Re: M code Pauses Machine while running G-code
« on: September 28, 2011, 10:41:30 AM »
TP,
Thanks for the reply. That really helps give me an route figuring out a work around.  Unfortunately I have been building a system where I will need to turn on 22 different solenoids.  I have this working fine with custom Mcodes and the Pokeys 55T, except for the delay when turning off solenoids during movement.

I wonder if it would be possible to use a phantom axis as you suggest... and have it trigger 22 solenoids.

For example have the phantom axis move to C +.0001 for solenoid 1 ON

Move to C -.0001 for solenoid 1 OFF
Move to C+.0002 for solenoid 2 ON
Move to C- .0002 for solenoid 2 OFF
and on and on for all 22 solenoids.

I will give this some more thought and look into the laser group.
That is cool that Mach USED to have a High speed output function... It would be even cooler if it still worked.  I wonder if there are plans to fix it?

Thanks again!

Would I then use Brains to then link the C movements to output to SetUserLED high or low whatever the case.

 

9
PoKeys / Re: M code Pauses Machine while running G-code
« on: September 22, 2011, 12:02:19 AM »
Well I see there have been a lot of people that have read my post, but no takers on offering advice... I will take this to mean that I have asked a difficult question that doesn't have a easy answer... or at least an easy explanation as to why the question is not so simple.
From further research, it looks as though this pausing to process a mcode may be unavoidable in Mach3.  This may come down to the way that Windows is built from what I have read, but I am not sure.
I know there are some real experts out there that haven't bitten at my request for info... I have been told that I could move to EMC2  to do what I need, but
hopefully there is still a way to hack something together with Mach3... because I really like the software for regular Milling (which is obviously what it is designed for).

I know I am trying to do something that is outside of the area that Mach3 is designed, but I would love to find a workaround for this problem.

Any takers for sharing some expert advice?  I could really use it.

10
PoKeys / M code Pauses Machine while running G-code
« on: September 17, 2011, 03:32:18 PM »
I am stumped as to how to find a work around for a problem I am facing.

When I run my g-code that contains custom M-codes that trigger solenoids on the toolhead I am getting a delay with every mcode... if the machine is making a movement when a Mcode is read, it pauses movement for about a second in order to run the macro.  Normally this would be fine, but I am controlling solenoids which cause a liquid to be sprayed along the toolpath... so it makes a large Dot where the pause happens.

Any ideas as to how to avoid this?

I have only a little scripting experience and I have never used the Brains route... Would that be a possible work around?

Thanks for any advice.
All in all I am really pleased with the Pokeys Platform.  PoppaBear was a huge help getting things up an running with basic operations... now I am getting down tweaking the setup that I have.

Attached is a bit of test g-code.  The M-codes basically just send a signal out that triggers relays to turn on or off. 
 :)



Pages: 1 2 »