Hello Guest it is November 28, 2021, 07:33:56 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - xaco

Pages: 1 2 3 »
1
General Mach Discussion / Re: axis changes from + to - by itself
« on: April 26, 2011, 03:49:08 AM »
great answer Tweakie,i guess thats it,just in that case the change of direction should always occur in same direction..instead of going -x and -y it switches to +x and +y i guess, and never it could switch from +x to -x cos for that we need 5 volts impulse...i guess. So do you know where in mach i can see for what + or - direction i need those 5 volts?...anyway..this can be answer to my old question"why my mach suddenly go crazy" cos i experienced that doing parallel finish  sometimes instead of continuing going back and forth ,the tool continues to go forth and breaks...again as i remember ,it continued to +y instead of getting back to -y(which would obviously need 5 volts that he didn't get). thx

2
General Mach Discussion / axis changes from + to - by itself
« on: April 24, 2011, 10:01:29 AM »
hello everyone,i have a problem that occurs sometimes but ruins all...   it happened that i wanted to stop milling process and i did it with "feed hold" button...but after i started milling again with "cycle start" it happened that both x axis and y axis switched + and - ,so milling  continued in opposite,wrong direction.         :-\   this problem occurred also when i would move my tool with jogging,for example i push "up" button but it goes down,and after few tries it goes up as it should be...  whats happening??

3
General Mach Discussion / Re: puting decimal numbers
« on: April 12, 2011, 02:49:16 PM »
ok!  I changed to keyboard and its working great...thank you

4
General Mach Discussion / Re: puting decimal numbers
« on: April 12, 2011, 02:33:56 PM »
I did that too... it dosnt work,still i can only put whole number and a dot.  like he dosnt wanna put "PI".... is it posible that i put numbers with keybord?maybe that would work

5
General Mach Discussion / Re: puting decimal numbers
« on: April 12, 2011, 02:22:27 PM »
I put numbers in   with a  box that openes when i klick on a  field,i menage to put a dot after whole number,but thats all....If i klick on "PI"  it enters only" 3."   not 3.14..... if i put "5/2" it enters only "2" not 2.5.    I have this problem on my PC and Laptop also. 

6
General Mach Discussion / puting decimal numbers
« on: April 12, 2011, 01:13:28 PM »
hello everyone, :-\   I  would like to ask why i cant put digital numbers in any field,for example i want to put 0.1 in A axis rotation diameter for radius correct.  I menage to put only whole numbers  like 1,2,3...    Thank you :-X

7
how many revolutions does your motor turn if you command G0 A360
   if i put "4" in Steps Per it makes 1 turn (4 steps for 1 degree,so it makes 1440 steps).  ..if i put 8 in steps per-it makes 2 turns,if i put 2000 in Steps Per it will make....500 turns. ...problem is that when i set it on "4 steps per" the movement is in steps,not smooth,and i have heavy chuck and its shaking after every step,..but when i set it on "2000 steps per" the movement is fast and smooth but it dosnt match the degrees  in DRO...

8
Ian,how can i set those microsteps? i have steper motor(2degress/step),its not microsteper motor.The only way i managed  to get  a full circle  in practice and i DRO is if i put "4" in motor tuning "steps per" box for my 4th axis...So,can i put 2000 in "steps per" box and calibrate it to get full 360circle  in DRO and in real, or thats imposible? and how can i set my motor to do more than 4 steps per degree without adding gearing?

9
Just wondering but when you ask "how to set A-axis to move continuously,not in steps?" do you really mean "continously" or do you mean you want more resolution. I think maybe there's a misunderstanding going on here - at least that's what I get when I read your second post.
  You are right,i realized that now too,well,I would like to have better resolution,smaller steps when i do toolpath along x as i do now, I also want to be able to execute toolpaths with 4th axis that are perpendicular to x axis.For that i need 4th axis to move smooth and not in steps.I gues smooth is right word ,not continuous like lathe.I did set my 4th axis as spindle but than i cant use it as A axis,so now i changed Steps Per in motor tuning for A axis from 4 to 2000 and now i have smooth movement but now degrees  dont match in DRO as RICH said.So,is it possible to calibrate degrees from DRO with actual degrees?

10
thanks RICH,i want to make a ring on my 4th axis,lets say i want to engrave letters using v-bit carving so where letter is thicker v-bit will go deeper. Currently  i can do this but as my chuck is heavy and steps r big(1/4 of degree) i get bad result...i also want to make rings with 3D relieves using toolpath thats not along x(my 4th axis is along x).                                                                                                i now tried  to set my 4th axis as a spindle but i didnt know how...
Quote
This is from the mach3 yahoo group,

Config> ports and Pins> motor output> enable the spindle and enter the pin
numbers for the indexer step and direction pins.
Don't forget to click on apply.
Next, click on Config> ports and Pins> Spindle set up> put a check mark in"Use
Spindle Motor output" and another check mark in step and direction.

Last go to
> config> pulley set up
and provide the necessary info.

Then in your G code you will need the M3 command and the S value.
Such as S 200 for 200 RPM ...........................................................i didnt get if i set spindle pins do i leave my a axis pins same?and what pulley is right,and do i have to set ports for spindle.what should i set to be able to make a ring ?and can my motor be set to make more than 4 steps per degree?

Pages: 1 2 3 »