Hello Guest it is August 14, 2020, 01:41:32 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bluebirdiran

Pages: 1
1
Thanks Hood, You were spot on. Although I had suspected this as well but could never bring myself to believe that a three strand cable of 1mm dia. each could ever do that to me. The chances were infinitesimal. But it was that. Thank you very much.
Cheers Bluebird

2
Hi to all

I have this homemade plasma CNC that was working alright. Suddenly the x axis started to miss steps and then stopped alltogether. This now happens regularly but sometimes without stopping, only missing steps. I changed the motor, no good. I swapped over the X and Y drives but the same motor still has the problem. I changed the transistor in my buffer circuit, no good. I changed back to the motherboard LPT port instead of the auxiliary one that I had been using, no good. I installed KCAM software instead of Mach3, the same problem. I reinstalled Windows XP, no good. One consistent thing seems to happen though and that is when the y axis has moved about 25cm, the x axis starts to show this problem. Apart from calling in an exorcist, can anybody tell me what could be wrong that I haven't looked into yet.
Motors are 18 kg.cm chinese
Drives are chinese

Thanks guys
Bluebird

3
General Mach Discussion / Re: Freeing the motor to avoid overheating
« on: February 28, 2010, 08:17:33 AM »
Hi,
Thanks to all. Your help is appreciated very much. I have been fiddling around with Mach3 configuration options and have just found an option under the heading"general Config...", then under the section titled "Prgm end, M30 or rewind" under which you can tick "Turn off all outputs". Has anybody else tried this? Does it actually do what it says. I used it in Gcode and after some idle standing, one of the motors was as cool as a cucumber but the other one was warm to the touch. (I only have 2 motors). So I cannot tell weather this was due to this option or is unrelated. If anybody has had any similar experience with this pls. let everyone benefit from the information.

Cheers Bluebird

4
General Mach Discussion / Re: Freeing the motor to avoid overheating
« on: February 26, 2010, 02:17:49 PM »
Hi RICH
Thanks for your help. I asked this as a precaution really. I have never dared to leave the drivers idle for long. Although the driver does cut the current down by 50% after only a tenth of a second, I still think it is a good idea to be able to include this feature in the Gcode to make sure the motors are freed at the end of a run.

Cheers
Bluebird

5
General Mach Discussion / Freeing the motor to avoid overheating
« on: February 26, 2010, 08:49:39 AM »
Hello all,

Can anyone tell me how to include code to make sure the motor stops being energized when standing idle or at the end of a job to avoid overheating the motors. How is it actually done hardwarewise. I mean what pin should be connected to the "free motor" screw terminal on the driver and where in the configuration can this pin be assigned.

Thank you
Bluebird

6
General Mach Discussion / Anomalies in the LPT signalling
« on: February 16, 2010, 09:02:22 AM »
Hi to all,

I am getting some unexpected results from the LPT port. I hope you will bear with me while I give a full explanation. I use the circuit attached to verify that I get the correct TTL signals from my LPT port pins. When I use a little software called LPTinterface.exe I get logical results, ie when I make say pin 2 high I get the LED in the circuit go off and when I make pin 2 low I get the LED lit up. The same happens on other pins up to 7 that I have tried. I have measured the current and the LPT can apparently supply as much as 35mA to the optocoupler at about 3.5Volts.
The problem starts when I use the Mach3 software. All the necessary configurations are done but when I try to jog in the x or y or z direction using the arrow keys, the LED toggles the first time I push the appropriate arrow key but the LED stays in the same condition indefinitely regardles of which arrow key I push next. This happens when the "low active" column is not ticked. 
On the other hand when the "low active" is ticked I sometimes get a very dimly lit LED for the pulses as long as the key is kept down. Can anyone tell me what is happening and how to overcome this problem. I have to add that when the pins are connected to a step motor driver it won't drive the motors unless I use a buffer circuit as an interface. Is there any reason why the LPT should be able
to drive the below circiut using the LPTinterface.exe but not when using Mach3?
I have increased the pulse duration to the max. of 25mS still with no improvement.
I will be grateful for any help.
Cheers Bluebirdiran

Pages: 1