Hello Guest it is September 28, 2021, 01:26:47 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - geast

Pages: 1 2 3 4 5 »
1
General Mach Discussion / Re: Work offset not remembered
« on: July 04, 2019, 04:09:31 PM »
Thanks a lot for the answer.
It would be perfect if all this could be done in the background without the use of a button. By the time of shutdown the work offsets are saved and also there is a popup window asking you if you want to save them. It would be great if in this function the last work offset would be saved by your "button routine", somehow.
Anyway i will try this its a good approach anyway.

2
General Mach Discussion / Re: Work offset not remembered
« on: July 04, 2019, 08:53:23 AM »
Thank you for the reply.
Yes i have noticed this string and i was also wondering from where it comes from, so i can change it.
Any way, yes if i would always use for example the G55 , this would be a solution, but i want to use whatever work offset i was working before i shut down my machine.

3
General Mach Discussion / Work offset not remembered
« on: July 04, 2019, 02:36:00 AM »
Hello.
I notice that when i work to a work offset, like G56, or whatever except G54, and shut down normally the Mach3, when i startup again the work offset is always G54. In general config everything is checked as persist. Is there a way to accomplish that the last working work offset will be remembered, and when i startup the mach3 it will be in G57 for example and that i don't have to switch to this work offset every time i startup?
Any help will be appreciated.

4
I have a similar problem, is the  the gcode in incremental G91 or absolute G90 coordinates?

5
I have another suggestion to make.
I draw a button on the screen "THC ON" the OEM button 123 "Torch enable toggle" and then i modify the M3 macro like that.

If GetOEMLed (24) Then
   DoSpinCW()
End If   

So when i push this button and d energize the THC the torch want go down but the movement on axis X and Y are done.

Simple or not?



6
VB and the development of wizards / Re: Internal error <SetUserDRO>
« on: February 07, 2014, 12:52:30 AM »
Yes after a fresh installation, now i'm running R03.043.066 everything works fine. Thanks alot.

7
VB and the development of wizards / Re: Internal error <SetUserDRO>
« on: February 06, 2014, 06:02:32 AM »
No luck, i attach the pictures, as simple as it gets.
The mach version im using is R3.043.022.

8
VB and the development of wizards / Re: Internal error <SetUserDRO>
« on: February 06, 2014, 05:42:21 AM »
None worked, either the parenthesis nor the Call, or the 123.4
Any other ideas?

9
VB and the development of wizards / Internal error <SetUserDRO>
« on: February 06, 2014, 03:24:15 AM »
A very strange error only in windows XP

I write a simple macro in windows XP

Dim  Y As Integer
Dim A  As Double

Y = 1000
A = 1234

aaa= GetUserDRO(1000)

SetUserDRO(Y,A)

and when i executed in windows vista everything is ok, but when in XP i have an error Internal error <SetUserDRO>.
Please check the attached pictures

10
General Mach Discussion / Re: stop waiting G4
« on: May 22, 2013, 06:57:53 AM »
Hello everybody.
I'm facing the same problem with achilleas and the DoOEMButton(288) didnt solve the problem.
Any ideas?

Pages: 1 2 3 4 5 »