Hello Guest it is November 27, 2022, 07:58:33 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Sparky60090

Pages: 1
1
General Mach Discussion / Re: Motor tuning dillema
« on: March 24, 2011, 08:08:55 AM »
Sorry, Hood. In my haste to try to do 15 things at once, I sent the wrong xml and misread the dip switches on the drive. Here's the REAL file and The drive is configured for 800 microsteps, not 400.

2
General Mach Discussion / Re: Motor tuning dillema
« on: March 23, 2011, 04:03:26 PM »
Sorry it takes so much time to respond. I've been putting out so many fires in this place that I'm considering calling the arson squad. ;)
The screw pitch is 5 turns/in. The reduction ratio is 2:1. I have the drive set for 400 microsteps/ revolution. The current setting in the drive setup is 8026.
Since I see 8026 in the setup, shouldn't that be reflected in the xml ? ???

3
General Mach Discussion / Re: Motor tuning dillema
« on: March 23, 2011, 12:27:22 PM »
Both the X and Y are working great.

I really appreciate the help on this, Hood.

4
General Mach Discussion / Re: Motor tuning dillema
« on: March 23, 2011, 11:54:55 AM »
The drives are Keling KL-9082, and the steppers are 1290oz/in Nema 34.

Rapid traverse seems to work fine, but if I try to run at a lower feed rate I get the growl. It almost seems like it's fighting itself.

5
General Mach Discussion / Motor tuning dillema
« on: March 23, 2011, 10:27:34 AM »
A couple of months ago a new guy was hired as a "machinist" for my team. The first thing that I wanted to know was if he could adjust to Mach after working with a more "commercial" type of cnc. The 1st assignment that I gave him was to familiarize himself with the mill. I gave him the manual and told him to try some things. The next afternoon he quit with no explanation. My mill has not been the same since. Motors were out of tune Homing didn't work. I must have suffered from an enormous brain fart because I didn't retain a backup copy of the xml file. (Please don't rub it in, as I plan to burn the xml to a disc with a backup on the network.) I went into the xml backup folder and all the contents were gone. Empty. After spending the next hour swearing and beating my self up, I began the process of retuning. I got ALMOST everything done I still have a problem with the X axis. It seems to run fine during normal operation, but when I try to jog it, it growls, stalls, and when I attempt to reverse direction it tries to go in the same direction that I was going into previously. At times it faults and then I have to power down to reset it. HELP!!!!! I have tried and tried to retune it but nothing seems to work. Any ideas??

6
General Mach Discussion / Tool compensation in copycat
« on: October 21, 2009, 12:45:28 PM »
Can anyone please help me figure how to set the tool compensation in copycat? I went thru the manual, but it doesn't seem to address this.

Thanks,

Keith

7
General Mach Discussion / 5vdc source
« on: August 24, 2009, 10:32:21 AM »
I know this has probably been brought up before, but do I use a 5 vdc source from my PC power supply to activate things like relays, pulse +/-, enable +/- , dir +/- , limit switches, etc, or do I need to use a separate power supply for this? I have 1 on order just in case. Will there be a conflict with the + or ground with the PC ? I'm ready to wire, but I don't want to burn anything up. :-[.

Any help with this would be greatly appreciated as the deadline on this project is drawing nearer.

Keith

8
General Mach Discussion / Re: Linear encoders and steppers (newbie ?)
« on: August 13, 2009, 09:04:28 AM »
Gecko 204V is a great stepper drive. I just sold the last of mine and they did a great job for me while I had them.

You are handing them a tall order with those big steppers. The Geckos top out at 7A

Why have you decided on steppers over servos?

Quite frankly, cost and inexperience are the 2 major factors. If I screw up, it won't cost too much to fix my mistake, and maybe I won't get fired. (j/k)

The steppers I've spec'd are rated @ 4.0 A/phase. I'm hoping that they will do the trick. The parts I'll be making (right now) are all fairly small and speed isn't as much of a factor as accuracy is. If everything works out this time, I might be able to convince the powers that be to cough up the funds to go all the way. We have 6 Bridgeport type knee mills, and this is the 1st I'll be refitting, but ti probably won't be the last.

I appreciate your input. I've relied a great deal on info that I've gleaned from the posts on here. You (Simpson) and Hood seem to have the best handle on some of the idiosyncrasies of a project like this.

Thanks for your input

Keith

9
General Mach Discussion / Re: Linear encoders and steppers (newbie ?)
« on: August 10, 2009, 03:01:34 PM »
Thanks, Hood.

The only reason I asked was because there are encoder inputs, and I haven't seen any where in the software where it differentiates between steppers and servos.

I'll be using 1260 in/oz motors utilizing Gecko G203V drives. Should that be sufficient?

Will I be able to use the DRO ccrdinants in manual mode?

I appreciate your help and input.

Keith

10
General Mach Discussion / Linear encoders and steppers (newbie ?)
« on: August 10, 2009, 02:16:52 PM »
Well, I got stuck with this project at work, and I am green when it comes to CNC setup and conversion, so please bear with me.

I'm currently researching what I need to retrofit a "Handyman" knee mill. I'll be replacing everything. I've been reading in the posts about position loss using stepper motors, and a question came to mind.

Can I use feedback from the glass scales currently installed on the mill with the new stepper motors to create a closed loop system for positioning and running? If I can, I'll use a double parallel port so that I have enough input. (Anybody know of a good double BOB?)

I am hoping this is the case as it would eliminate problems with both loss of position, and backlash.

Pages: 1