Hello Guest it is August 08, 2020, 10:57:09 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - frogblender

Pages: 1 2 »
1
General Mach Discussion / Mach3 using SSD harddrive.... any problems ??
« on: December 09, 2011, 09:59:36 AM »
Does anyone know if there are known problems with using Mach3 on a machine booted from an SSD? 

I am using XP;  normally SSDs and XP don't mix too well, but the SSD in question is a Kingston V+100, which has automatic "garbage collection", so it apparently works well with XP.
I am also using a smoothstepper - not sure if this makes a difference.

2
SmoothStepper USB / Re: G4 Dwell Setting _Smoothstepper
« on: December 06, 2011, 09:28:59 AM »
Greg says it is a Mach issue:

I don't have any control over the dwell commands since Mach interprets the gcode and then commands the plugin. I brought this up to Brian and he was going to look into it. The SmoothStepper can do very accurate dwells if Mach commands it properly. I would ask Brian and see if he can change Mach. Dwells can be implemented as zero-velocity moves, and the plugin doesn't need to do anything. Or he could send a notification and the plugin can send a command to the device to have it delay.

In any case, megabytes of code and macros can be changed from ms to seconds in about an hour, assuming one is DOS-savvy, and with judicious use of grep.  Here's what I did:
1) There are four cases to search for:  "G04 P",  "G04P", "G4 P", and "G4P".   Both your macros folder (and subfolders) and your NC folders (and subfolders) must be searched.
2) Search each with:   grep -irl "G04 P" *.* >go.bat     This puts each filename with the occurrence into a list in a batch file.   (the grep options are "i"=case insensitive, "r"=recurse dir tree, "l" = output only filenames).
3) edit go.bat by putting "notepad " in front of each filename (or use your favourite text editor.  I use Notepad2, which I renamed to n2 for speed in typing). 
4) Run the batch file.   When notepad pops up each file, search for all occurrences of "G04 P", change to milliseconds, and save and close the file;  then the batch file will pop up the next file for editing.

In my shop, G4 is not used extensively, so total edits was manageable.



3
SmoothStepper USB / Re: G4 Dwell Setting _Smoothstepper - still busted
« on: December 05, 2011, 02:24:57 PM »
It appears this is still broken as of v17efb (2011.10.30) -  Smoothstepper always interprets G04 in SECONDS, even if Mach3 General Config is set to milliseconds.

Can this be fixed?  Seems like it'd be an easy code change.  The smoothstepper was supposed to be a drop-in solution for buggy LPT ports, but now I'm faced with manually diddling MEGAbytes of NC and macro code to get it to work.


4
General Mach Discussion / Re: Sherline Mode kills Output#1 - why??
« on: November 29, 2011, 03:52:17 PM »
Have you tried the lockdown instead of the development version?
Hood
No.  My original goal was fixing my suspected missed steps, and the siren call of the "updated parallel port driver" in the development version was too tempting to ignore.  Is it worth going back?

I've bit bullet and ordered a smoothstepper.

5
General Mach Discussion / Sherline Mode kills Output#1 - why??
« on: November 29, 2011, 11:45:38 AM »
I'm having missed steps problems, and want to try Sherline mode.

When I enable Sherline, Output#1 (which is my coolant) ceases to function - the physical pin is always stuck low (.063v).  Mach's Diagnostic page shows Output1 toggling properly, even though the physical pin is not.

When I disable Sherline, the physical pin toggles fine.

Output#1 is the only output I use (other than Motor pins, which seem fine); I didn't try the other outputs.

Any ideas ?


Using Mach 03.043.053

6
General Mach Discussion / Re: Delay at end of each drill op
« on: September 30, 2011, 02:52:41 PM »
Please Please  put a fix for this on your to-do list!

G81 has a pause before moving to the next hole.   I estimate the pause is around 700ms (the dude above estimate 1second).   With today's noodle-hertz CPU speeds.... what on earth could be going on during this time?   I realize .7s per hole ain't gonna put me outta business, but it makes my mill look bush-league -  the ladies' aren't impressed by the doddering movement, especially after they've seen those super-fast mills on youtube.  Please please please fix!   U da man.    Spock out.

7
I use VB scripts.   If there is an error (syntax or otherwise) in the script, you don't know until you try to run it.

Trouble is, if your script is part of a Gcode program, and Mach3 encounters a script compiler error, Mach3 continues on to the next G-code command as if nothing happened.   Chaos ensues.

Some of these errors may be deep in a branch of code which rarely gets executed, and so are difficult to catch.

How do I get Mach3 to Estop if it encounters a vbscript error??


8
General Mach Discussion / Display Spindle Temperature on Mach3 ??
« on: May 17, 2010, 12:41:05 PM »
I have a USB temperature probe, which writes the temperature to a textfile every 10 seconds.

I want Mach3 to:
1)  read the temperature from the textfile and display it in a DRO every 10 seconds.
2) estop if the temperature exceeds some setpoint.


Any ideas how to do this?    I'm fluent in vbscripts.

9
Maybe the answer is obvious, but danged if I can figger it out.

From within g-code (NOT a vb script):  How do I set the DROs in Mach3, the same as if you'd clicked on them with the mouse and typed in a number by hand?

10
Ok, I found the Button on the main screen which overrides the "ignore M01" in the GeneralConfig.  And deleted it from the .set file with screen4.exe.  It seems like a rather dangerous and not-too-useful button to have.

Unfortunately, I don't know if it was inadvertently clicked, and the cause of my problem.   Anyhoo, now M01 stops OK.

However, it doesn't stop on a toolchange gcode command: ie.

T98

for tool #98.  In fact, the Tool number displaybox on Mach's main screen always stays at zero.  GeneralConfig has ToolChanges set to "stop and wait", as well as another dangerous button on the "Settings" (Alt-6) page is not enabled.   Any ideas?


Pages: 1 2 »