Hello Guest it is August 14, 2020, 02:19:06 AM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Racer

Pages: 1 2 »
1
Mach4 General Discussion / Re: GSim Mach4 Material Removal Simulator
« on: January 29, 2015, 05:26:30 PM »
Art,

I get this.

Mach4 CNC GUI has encountered a problem and needs
to close.  We are sorry for the inconvenience.

Windows xp and Darwin

Thanks
Jerry


2
Mach4 General Discussion / Re: Need Help with Darwin and Spindle DRO
« on: December 09, 2014, 08:44:54 AM »
I have the same problem. In Darwin input I can see spindle RPS but I cant get it in a Mach4 DRO true speed.



Hello all,
 Iv'e been trying to get get a spindle RPM DRO working for awhile with Darwin. on the diagnostic tab you can see the index led flash when the spindle is running. but I can not figure out how to turn that pulse into a DRO value on the screen. if you open diagnostic logging you can also see the signal change from 1 to 0 continuously. so at this point is this even possible to do?

3
Mach4 General Discussion / Re: Mach4 Printer Port Discussions
« on: November 05, 2014, 11:51:30 AM »

  The Mach4hobby may be Mach4 instead.. but the file should be named as above and placed in the licenses folder.
If it still gives a -33 error, then make sure m4 is up to date as well.

Art



[/quote]
Renamed to C:\Mach4Hobby\Licenses\DarwinLic.dat
getting a -37 now
Failed to license feature M4_DARWIN (mcDarwin)
Darwin License has failed with -37.
Do MDI

Should I ask for a new License?

Thanks

Jerry

4
Mach4 General Discussion / Re: Mach4 Printer Port Discussions
« on: November 05, 2014, 10:58:32 AM »
That's perhaps the best way to ensure compatible versions of both M4 and Darwin  ;)

Tweakie.

I installed 2071 Mach4 and 2071 Darwin and still i get this in history.

Failed to license feature M4_DARWIN (mcDarwin)
Darwin License has failed with -33.
Do MDI
Do MDI

I tried renaming license file but still get the same thing.
Mach4 stops working after 10 min. or so.

5
Mach4 General Discussion / Re: Mach4 Printer Port Discussions
« on: August 25, 2014, 10:42:44 AM »
Jerry:

  Post your machine.ini when its not working but should be. Might be some setting that Darwin is screwing up on when saving..
( Or it might be Mach4 is limited to 3 axis.. I havent used 4 yet..)


Art

Had to rename the file.

6
Mach4 General Discussion / Re: Mach4 Printer Port Discussions
« on: August 25, 2014, 09:50:32 AM »
Ahh, pin 8..

 Ill run a check just to be absolutley sure ..

Art


Art:

More testing on the Y axes not working.

In Darwin Control all 4 axes setup and working (x,y,z,a)
X out to Mach 4 set everything up in Motors and Maping, did not enable.
Went back to Darwin control, all still working.
Back to Mach 4 and hit enable all work execpt Y axes on pins 8 step and 3 direction.
Go back to Darwin controal and Y not working.
The only way to get y working in Darwin Controal is Create new profile and start over.


Again Mach 3 works good on same config, same computer.
Might be a Mack 4 problem.

Thanks
Jerry

7
Mach4 General Discussion / Re: Mach4 Printer Port Discussions
« on: August 22, 2014, 04:09:02 PM »
Ahh, pin 8..

 Ill run a check just to be absolutley sure ..

Art


The Index number is real HI,  like 25018  when jogging motor #1
Motor #0 is 3221

Jerry


8
Mach4 General Discussion / Re: Mach4 Printer Port Discussions
« on: August 22, 2014, 03:38:58 PM »
Well, that proves its not Mach then. :)

 OK, so we need to know why pin 3 doesnt work ( Im assuming the STEP pin is pin 3? )
Well ignore the DIR pin as if it was bad the motor would still move, just in the wrong direction.
So search for any signal you may have turned in in other motors, or outputs that is set to pin3.
Its about the only thing that can stop you. The pin will not be set to step unless no other pin uses it.
  Pin3 is a bit in the 8 bit area of pins 2-9 , so theres nothing particularly special about it, so I cant see
anything other than 2 possibilites, the Y axis isnt working or the pin 3 signal is getting overwritten by an output
or other motor..

Any chance its that?

Art

   
Pin 8 is step but I tried switching 3 and 8 no go.

All outputs are disabled.
All inputs are disabled.

I will keep playing with it.

Thanks Art


9
Mach4 General Discussion / Re: Mach4 Printer Port Discussions
« on: August 22, 2014, 03:21:39 PM »
Hi Jerry:

>>I have everything working on my 3D printer except no movement on Y axes.
>>X pins 7 and 1
>>Y pins 3 and 8 ( I tried switching them but same thing)
>>Mach 3 same computer works fine.
 
  If you switch the X and Y settings, does the Y then move when you try to move X? Does X move when you try to move Y?

Art


X Moves when I try to move Y
nothing moves when I try to move X

I switched the pin assignment only.

10
Mach4 General Discussion / Re: Mach4 Printer Port Discussions
« on: August 22, 2014, 02:23:16 PM »
Art,

I have everything working on my 3D printer except no movement on Y axes.
X pins 7 and 1
Y pins 3 and 8 ( I tried switching them but same thing)
Z pins 4 and 5
A pins 17 and 16.

Moch 3 same computer works fine.

Any help?

Thanks
Jerry


Pages: 1 2 »