Hello Guest it is December 03, 2021, 02:46:21 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Tony Bullard

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 »
1
PoKeys / Pokey57CNC Pendent signals
« on: June 05, 2021, 07:45:55 AM »
Before I set the pendent up I'd like to know if there is a way to change the value the Jog Step Increment signals.
I'd like to use the "Step x0.001" signal to have a value of 0.0001. Does the "Step x0.001" signal represent the Control General Config Jog Increment Position 4 or is it in the Pokeys code?

Thanks for any help.
Tony

2
Thank you Steve.

I installed in build 4612 in "C:\Mach4Hobby-4612". Imported my profile and my screen sets in 4612 and all worked well. Restored my computer to three days ago and updated  "C:\Mach4Hobby" to build 4612 again and all is well. I don't know what the problem was but it is fixed now. Thank you!

Tony

3
I updated to version 4.2.0.4612 from 4.2.0.4300. Now I can't load screens. I get this message:

Mach4gui Error
Unexpected Exception has occurred: bad allocation, the program will terminate.

I switched back to .4300 and all is well. Any help would be appreciated.

Thanks,

4
Mach4 General Discussion / Re: Merry Christmas
« on: December 18, 2020, 03:42:11 PM »
Mary Christmas and Happy new year too Bill and to all the generous and supportive people on this forum who help so many rookies like me. Thank you All.

Tony

5
Mach4 General Discussion / Re: G31 not working in screen function
« on: December 18, 2020, 07:29:25 AM »
The trouble with mc.mcCntlGcodeExecuteWait is that it pauses the PLC script while it is waiting so the position DROs in the GUI don’t update until it is done.

DasTheGas has a great tutorial on coroutines that explains this: https://www.youtube.com/watch?v=t2xQYvAXT8o

6
Mach4 General Discussion / Re: G31 not working in screen function
« on: December 17, 2020, 10:51:58 AM »
I think I'll have to write a coroutine.yield() after the probe move for the rest of the code to execute properly. Stay tuned!

7
Mach4 General Discussion / Re: G31 not working in screen function
« on: December 17, 2020, 10:42:00 AM »
Thank you! That worked. I've been fighting with this for a week. I really do appreciate your help.
Tony

8
Mach4 General Discussion / G31 not working in screen function
« on: December 17, 2020, 09:51:44 AM »
Mach4Lathe: When G31 G01 X-.20 F5 is called from the MDI the machine stops at the probe strike as it should.

I have this function in the screen load script and it is called from a button press.
Code: [Select]
function TestG31()
local inst = mc.mcGetInstance()
mc.mcCntlGcodeExecute(inst, "G31 G01 X-.20 F5")
mc.mcAxisHome(inst,0,0)
end
It doesn’t stop at the probe strike but finishes as a G01 X-.20 command. I eventually would like this code in the RefAllHome() function to stop on an encoder Index pulse.
Any help with this would be appreciated.


9
I found out the SmartBob plugin only supports one probe, probe 0 and it has to be an input signal to the PMDX motion controller.

10
Thank you. I have Pokeys57ECNC on my Hurco Mill and their plugin works beautifully with home with index. The lathe I'm trying to set up for my son in law uses a PMDX 424 motion controller and SmartBob plugin which I don't believe supports this function.

Will your Mach4 Lathe support any G31 functions in the MDI?
Is anybody using G31 functions in Mach4 Lathe?
Thanks,

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 »