Hello Guest it is December 04, 2021, 01:12:15 PM

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - watswood

Pages: 1 2 »
1
Competitions / Re: ******Guess and win a G100 Grex******
« on: May 25, 2007, 06:30:24 PM »
2810706

2
General Mach Discussion / Re: changing offsets and keeping z value?
« on: March 16, 2007, 11:09:47 AM »
Graham,
I'm fairly new to gcode and mach and may need to do some research into tool changes/offsets, which is something I have not yet used.  The problem for me is that I do not have a tool changer and everytime I change a tool the z offset for that tool may be off by .05" or so depending on where I happen to chuck it.  The bit is then rezeroed to the top of the material and a new z offset is created(in whatever work offset I happen to be in).   I'm guessing, but this would mean that I would have to manually enter the z offset somewhere, and the word "manual" is what I'm trying to eliminate.  Let me do some looking into tool changes and tool offsets and see what I can figure out.  Thanks.

3
General Mach Discussion / Re: changing offsets and keeping z value?
« on: March 16, 2007, 12:40:29 AM »
Gary,  I think I just figured out a way to do this.  I created 2 simple macros which can be inserted in your code:

;M110 -- can be any available macro number

Code "G0 Z1"
SetOEMDro (1110,GetOEMDro (49))      ;oemdro 1110 is a temp. location for storing the current z

;M111

SetOEMDro (49, GetOEMDro (1110))     ;oemdro 49 is the z offset dro found on the offset page

In your code you need to insert macro M110 right after a tool change/rezero and insert the following when changing offsets:
G0 Z1
G59 P25     ;your new offset #
M111

 I did some simple tests and it seems to work.  I'll know for sure tomorrow morning.


4
General Mach Discussion / Re: changing offsets and keeping z value?
« on: March 15, 2007, 09:33:15 PM »
Hi Graham,
It's the tool change that makes it a hassle.  I have 4 boards mounted on the table, each with its own offset location.  Each board will be cut identically.  I've tried to use one offset and then use g52 to locate the other 3 boards, the only problem is that the file(s) for  each board contain their own g52 offsets to locate 8 parts within the board.  G52's within a g52 doesn't work out right.
For now, what I've been doing is whenever I change a bit and rezero it, I go in and set the z value the same for each offset.  It works, but I'm concerned that one time I'll forget to update all the offsets after a bit change.
Any ideas?
Thanks

5
General Mach Discussion / changing offsets and keeping z value?
« on: March 15, 2007, 03:29:33 PM »
Is it possible to change offsets and transfer the z value from the previous offset.  For example, if I'm in offset 25 and Z=1, I'd like to switch to offset 26 and have z =1 regardless of what value happens to be stored in offset 26 for Z.
Thanks
Eugene

6
Well, I must have looked over the wiki 5 times and didn't see the "not all dro's can be written" statement.  Sometimes I have to post a ? here in order to be able to see!

7
Are some DRO's Write protected?

Here is a section of my macropump:

sov=GetoemDRO (202)

If  (sov <= 9500) Then
   'set spindle speed to 9000 RPM
   ActivateSignal (output6)
   DeActivateSignal (output7)
   DeActivateSignal (output8)
   DeActivateSignal (output9)
   SetOEMDRO (39,9000)
   End If
   
If (sov > 9500) And (sov <= 10500) Then
   'set spindle speed to 10000 RPM
   DeActivateSignal (output6)
   ActivateSignal (output7)
   DeActivateSignal (output8)
   DeActivateSignal (output9)
   SetOEMDRO (39,10000)
   End If

Everthing is working fine except the SetOemDro command.  Any ideas?
Thanks
Eugene

8
General Mach Discussion / Re: temperature alarms for motors?
« on: February 12, 2007, 12:19:44 AM »
I would put heat-shrink tubbing completely over the leads and your wire joints, then tape the disc,with electrical tape,  to the hottest part of your motor.  Wrap the disc and wires several times so it's completely covered.  It's no guarantee, but its cheap and easy to try.  As for your motor temp., I would try to find some data on them.

9
General Mach Discussion / Re: temperature alarms for motors?
« on: February 11, 2007, 01:23:05 AM »
Here are some surplus ones that should work:

http://www.allelectronics.com/cgi-bin/item/THSW-75/765/THERMAL_CIRCUIT_PROTECTOR,_75_C_.html

75C is a good trip temp. for most steppers.

Eugene

10
General Mach Discussion / feedhold problems
« on: September 09, 2006, 11:40:05 AM »
I'm having some issues with feedhold temporarily losing position and thus ruining parts.  I say temporarily because as soon as the file is finished, the machine will find it's start point(g0x0y0 ends up being right on the money after the file is done).  The toolpath display will show this position loss(a deviation from toolpath center by as much as .25"), and thus indicates where the machine is at also.  This helped me eliminate the controller/machine  and be able to reproduce the position loss while running offline and cycling through feedhold and start a few times to get this to happen.  This appears to be a random problem, though it happens more often than not(of course when I press feedhold is random).  I'm running Mach3's latest version 1.90.081. Any help on this would be greatly appreciated. 

Thanks
Eugene

Pages: 1 2 »